Buscar

teorico (2)

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Você viu 3, do total de 24 páginas

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Você viu 6, do total de 24 páginas

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Você viu 9, do total de 24 páginas

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Prévia do material em texto

Conectividade 
de Redes
Material Teórico
Responsável pelo Conteúdo:
 Prof. Esp. Antonio Eduardo Marques da Silva
Revisão Textual:
Prof.ª Me. Sandra Regina Fonseca Moreira
Protocolos de Encapsulamento em WAN 
• Introdução;
• Protocolos de Enlace;
• Encapsulamento WAN;
• Encapsulamento HDLC;
• Encapsulamento PPP;
• Protocolo Frame-Relay.
• Compreender e abordar os conceitos fundamentais sobre o que são protocolos de enlace e 
tipos de encapsulamentos utilizados em comunicações de longa distância (WANs);
• Estudar as principais características do HDLC, PPP, Frame Relay e outros.
OBJETIVOS DE APRENDIZADO
Protocolos de Encapsulamento
em WAN 
Orientações de estudo
Para que o conteúdo desta Disciplina seja bem 
aproveitado e haja maior aplicabilidade na sua 
formação acadêmica e atuação profissional, siga 
algumas recomendações básicas: 
Assim:
Organize seus estudos de maneira que passem a fazer parte 
da sua rotina. Por exemplo, você poderá determinar um dia e 
horário fixos como seu “momento do estudo”;
Procure se alimentar e se hidratar quando for estudar; lembre-se de que uma 
alimentação saudável pode proporcionar melhor aproveitamento do estudo;
No material de cada Unidade, há leituras indicadas e, entre elas, artigos científicos, livros, vídeos 
e sites para aprofundar os conhecimentos adquiridos ao longo da Unidade. Além disso, você tam-
bém encontrará sugestões de conteúdo extra no item Material Complementar, que ampliarão sua 
interpretação e auxiliarão no pleno entendimento dos temas abordados;
Após o contato com o conteúdo proposto, participe dos debates mediados em fóruns de discus-
são, pois irão auxiliar a verificar o quanto você absorveu de conhecimento, além de propiciar o 
contato com seus colegas e tutores, o que se apresenta como rico espaço de troca de ideias e de 
aprendizagem.
Organize seus estudos de maneira que passem a fazer parte 
Mantenha o foco! 
Evite se distrair com 
as redes sociais.
Mantenha o foco! 
Evite se distrair com 
as redes sociais.
Determine um 
horário fixo 
para estudar.
Aproveite as 
indicações 
de Material 
Complementar.
Procure se alimentar e se hidratar quando for estudar; lembre-se de que uma 
Não se esqueça 
de se alimentar 
e de se manter 
hidratado.
Aproveite as 
Conserve seu 
material e local de 
estudos sempre 
organizados.
Procure manter 
contato com seus 
colegas e tutores 
para trocar ideias! 
Isso amplia a 
aprendizagem.
Seja original! 
Nunca plagie 
trabalhos.
UNIDADE Protocolos de Encapsulamento em WAN 
Introdução
Para um bom conhecimento em redes, o entendimento dos protocolos de en-
capsulamento de redes de longa distância (WANs) é de extrema importância para o 
desenho, aplicação e configuração dessas redes. 
Nessa unidade, vamos descrever alguns protocolos de encapsulamento de enlace 
utilizados em conexão de redes remotas, por exemplo, o HDLC, o PPP, o Frame-Relay 
e outros.
Protocolos de Enlace
Conceitos da Camada de Enlace de Dados de WAN
Como já comentado, uma tecnologia WAN é baseada, na grande maioria das 
vezes, em sua camada física e de enlace de dados. E, por este motivo, além dos 
dispositivos de camada física, as WANs exigem protocolos de camada de enlace de 
dados para estabelecer o respectivo enlace (ligação) através da linha de comunica-
ção do dispositivo de envio para o dispositivo receptor. 
O objetivo dessa unidade é descrever alguns dos protocolos mais comuns de link 
de dados que são utilizados nas redes corporativas atuais para implementar cone-
xões de WAN (STALLINGS, 2010).
Protocolos de Enlace de Dados 
Os protocolos da camada de enlace (camada 2 do modelo OSI) de dados defi-
nem como os dados são encapsulados para transmissão a sites remotos e os meca-
nismos para transferir os quadros resultantes em uma conexão. Uma variedade de 
tecnologias é utilizada, como o ISDN ou RDSI (Rede Digital de Serviços Integrados) 
no Brasil, o Frame Relay, o ATM e muitos outros. Muitos desses protocolos utili-
zam o mesmo mecanismo de enquadramento básico, o HDLC, que é um padrão 
ISO ou um de seus subconjuntos ou variantes, os equipamentos de roteamento da 
Cisco (roteadores), por exemplo, utilizam por padrão (default) em suas interfaces 
seriais, ou seja, o HDLC Cisco setado de fábrica. Já o ATM é diferente dos outros 
tipos, porque utiliza células pequenas (comutação por células) de tamanho fixo de 
53 bytes (48 bytes para dados e 5 bytes para header), ao contrário das outras 
tecnologias de comutação de pacotes, que utilizam pacotes de tamanhos variáveis.
8
9
HDLC, PPP, SLIP
Circuit-Switched
Telephone
Company
Leased Line
HDLC, PPP, SLIP
Packet-Switched
X 25, Frame Relay, ATM
Service Provider
Figura 1 – Protocolos de Enlace de Dados
Fonte: Adaptado de Getty Images
Os protocolos de link de dados da WAN mais comuns são os seguintes:
• High-Level Data Link Control (HDLC);
• Protocolo Ponto a Ponto (PPP);
• Frame Relay (FR);
• Multiprotocol Label Switching (MPLS);
• Asynchronous Transfer Mode (ATM).
O ISDN, X.25 e ATM são protocolos de enlace de dados mais antigos, utilizados 
com menos frequência hoje em dia. No entanto, o ISDN ainda é, às vezes, coberto 
devido a sua utilização ao provisionar uma rede VoIP usando links PRI através de 
linhas telefônicas digitais. Já o X.25 é mencionado para ajudar a explicar a relevân-
cia do Frame Relay. Além disso, o X.25 ainda está em uso nos países em desen-
volvimento, onde as redes de dados por pacotes (PDN) são usadas para transmitir 
transações de cartão de crédito, TAF e débito dos varejistas (TANENBAUM, 2011).
9
UNIDADE Protocolos de Encapsulamento em WAN 
Encapsulamento WAN
Os dados da camada de rede são passados (encapsulados) para a camada de 
enlace de dados para entrega dentro de um link físico, que normalmente é ponto a 
ponto em uma conexão de longa distância. A camada de enlace de dados cria um 
quadro (frame que é sua PDU) ao redor dos dados da camada de rede para que 
as verificações e controles necessários possam ser aplicados. Cada tipo de cone-
xão WAN utiliza um protocolo de enlace (Camada 2) para encapsular um pacote, 
enquanto ele está sendo transmitido em um link WAN. Para garantir que o proto-
colo de encapsulamento correto seja utilizado, o tipo de encapsulamento de enlace 
usado para cada interface serial do roteador deve ser devidamente configurado 
(TANENBAUM, 2011).
A escolha dos protocolos de encapsulamento depende da tecnologia WAN e do 
equipamento. O HDLC foi proposto pela primeira vez em 1979. Por esse motivo, 
a maioria dos protocolos de encapsulamento desenvolvidos posteriormente baseia-
-se nele. Examinar a parte do cabeçalho de um quadro HDLC ajuda a identificar 
campos comuns usados por muitos protocolos de encapsulamento WAN. O quadro 
sempre inicia e termina com um campo de sinalizador de 8 bits, conhecido como 
“trailer”, sendo que o padrão de bits é 01111110. 
O campo “Endereço” não é necessário para links WAN, uma vez que a sua 
grande maioria segue uma conexão ponto-a-ponto. Porém, o campo “Endereço” 
ainda está presente e pode ter 1 ou 2 bytes de comprimento. O campo “Contro-
le” depende do protocolo, mas geralmente indica se os dados são informações de 
controle, ou dados da camada de rede que carregam efetivamente informações. 
O campo de controle normalmente tem o tamanho de 1 byte (8 bits).
A História da Internet – TecMundo em: https://youtu.be/pKxWPo73pX0
Ex
pl
or
Os campos de Endereço e Controle são chamados de cabeçalho (header) do 
quadro/frame. Os dados encapsulados seguem o campo Controle. Em seguida, 
uma sequência de verificação de quadros (FCS) utiliza o mecanismo de verificação 
de redundância cíclica (CRC) para estabelecer um campo de 2 ou 4 bytes. E tem 
como função determinar a integridade com que o dado é devidamente transmitido 
(COMER, 2016).
Existem vários tipos de formatos de encapsulamento WAN, incluindo subcon-
juntos e versões proprietárias do HDLC. O PPP e a versão do HDLC da Cisco têm 
um campo extra no cabeçalho para identificaro protocolo da camada de rede dos 
dados encapsulados. Esse campo ajuda muito em tecnologias de rede de multipro-
tocolos, pois evitam que se dedique um link físico para cada protocolo suportado. 
O campo protocolo dá essa flexibilidade.
10
11
1 1 or 2 1 or 2 Variable 2 1
Flag Address Control Data FSC Flag
Receive sequence
number
Poll �nal Send sequence
number
0
Receive sequence
number Poll �nal
Function
code 0 1
Function code Poll �nal
Function
code 1 1
Information (I) frame format
Supervisory (S) frame format
Unnumbered (U) frame format
Figura 2 – Formato de um Quadro de Encapsulamento
Opções de Conexão de Links WAN
Muitas opções para implementar soluções de WAN estão disponíveis atualmente. 
Elas diferem em tecnologia, velocidade e custo. A familiaridade com essas tecno-
logias é uma parte importante do projeto e avaliação da rede. Podemos observar 
várias opções de conexão do link WAN:
• Opções de Conexão de WAN Privada: As conexões da WAN privada in-
cluem as opções de link de comunicação dedicada e comutada:
 » Links de Comunicação Dedicados: quando conexões dedicadas per-
manentes são necessárias, as linhas ponto-a-ponto são usadas com várias 
capacidades, limitadas apenas pelas instalações físicas subjacentes e pela 
disposição dos usuários em pagar por essas linhas dedicadas. Um link pon-
to-a-ponto fornece um caminho de comunicação de WAN preestabelecido 
das instalações do cliente através da rede do provedor para um destino re-
moto. As linhas ponto-a-ponto geralmente são alugadas de uma operadora 
e também são chamadas linhas alugadas;
 » Links de Comunicação Comutados: Links de comunicação comutados 
podem ser comutados por circuitos ou por pacotes. Links de comunicação 
comutados por circuito: a comutação por circuito estabelece dinamicamente 
uma conexão dedicada para voz ou dados entre um emissor e um receptor. 
Antes que a comunicação possa começar, é necessário estabelecer a cone-
xão através da rede do provedor de serviços. Exemplos de links de comu-
nicação comutados por circuito são a conexão analógica (PSTN) e a ISDN; 
11
UNIDADE Protocolos de Encapsulamento em WAN 
 » Links de Comunicação Comutados por Pacote: muitos usuários da WAN 
não fazem uso eficiente da largura de banda fixa disponível com circuitos 
dedicados, comutados ou permanentes, porque o fluxo de dados flutua. 
Os provedores de comunicações têm redes de dados disponíveis para atender 
de forma mais adequada a esses usuários. Em redes comutadas por pacotes, 
os dados são transmitidos em quadros, células ou pacotes rotulados. Os links 
de comunicação comutados por pacotes incluem o Frame Relay, ATM, X.25 
e Metro Ethernet.
• Opções de Conexão da WAN Pública: conexões públicas usam a infraestru-
tura global da Internet. Até recentemente, a Internet não era uma opção de 
rede viável para muitas empresas, devido aos riscos significativos de segurança 
e à falta de garantias de desempenho adequadas em uma conexão de Internet 
de ponto-a-ponto. Com o desenvolvimento da tecnologia VPN, no entanto, a 
Internet é agora uma opção barata e segura para conectar-se a teletrabalha-
dores e escritórios remotos, onde garantias de desempenho não são críticas. 
Os links de conexão da Internet WAN são feitos através de serviços de banda 
larga, como o as tecnologias xDSL, modem a cabo (cable modem) e banda 
larga sem fio (wireless), e são combinados com a tecnologia VPN para fornecer 
privacidade e segurança através da Internet.
WAN
Privado Público
Dedicado Comutado Internet
Linhas
alugadas
Comutação
por Circuito
Comutação
por Pacotes
VPN de
banda larga
T1/E1
T3/E3
PSTN
ISDN
ATM de
Frame Relay
de MPLS
Ethernet Metro
Conectividade
sem �o de
cabo DSL
Figura 3 – Layout de Formas de Comutação WAN 
12
13
Definindo Protocolos de Encapsulamento WAN
Cada conexão WAN utiliza um protocolo de enlace para encapsular o tráfego 
de rede enquanto atravessa o link WAN. Para garantir que o protocolo de encap-
sulamento correto seja utilizado, é necessário configurar o tipo de encapsulamento 
da Camada 2 apropriado. A escolha do protocolo de encapsulamento depende da 
tecnologia WAN e do equipamento de comunicação a ser utilizado. Os protocolos 
típicos da WAN incluem os seguintes:
• High-Level Data Link Control (HDLC): O HDLC é o tipo de encapsula-
mento padrão nas interfaces seriais síncronas da Cisco. É um protocolo de 
camada de enlace de dados síncrono orientado por bits. O HDLC especifica 
um método de encapsulamento de dados em links seriais síncronos usando 
caracteres de quadro e somas de verificação. O HDLC é um padrão aber-
to para interpretação. Como resultado, existem diferentes versões do HDLC.
Se estiver se comunicando com um dispositivo não Cisco, o PPP síncrono é 
uma opção mais viável;
• Point-to-Point Protocol (PPP): O PPP (PPPoE e PPPoA) surgiu originalmente 
como um protocolo de encapsulamento para o transporte de tráfego IP sobre 
links ponto-a-ponto. O PPP também estabeleceu um padrão para atribuição 
e gerenciamento de endereços IP, encapsulamento síncrono assíncrono (start/
stop) e bit orientado, multiplexação de protocolo de rede, configuração de 
link, teste de qualidade de link, detecção de erro e opção de negociação para 
recursos como negociação de endereço de rede e de comunicação de dados.
O PPP oferece suporte a essas funções fornecendo um Protocolo de Controle de 
Link, do inglês Link Control Protocol (LCP), extensível e uma família de NCPs
(Network Control Protocols, ou em português, Protocolos de Controle de 
Rede) para negociar parâmetros e instalações opcionais de configuração.
O tipo de conexão de banda larga utilizado determina o uso do protocolo ponto-a-
-ponto sobre Ethernet (PPPoE) ou protocolo ponto-a-ponto sobre ATM (PPPoA);
• Frame Relay: É o protocolo WAN de comutação de pacotes de alto desem-
penho, que opera nas camadas física e de enlace de dados do modelo de refe-
rência OSI. O Frame Relay foi projetado originalmente para uso em interfaces 
ISDN. Atualmente, ele ainda é usado em várias outras interfaces de rede e 
normalmente opera em instalações de WAN que oferecem serviços de cone-
xão mais confiáveis e um maior grau de confiabilidade, com um bom custo be-
nefício. Mas, em função do tempo que é utilizado, possui algumas limitações;
• Asynchronous Transfer Mode (ATM): O ATM é o padrão internacional de 
comutação por célula, no qual vários tipos de serviço (como voz, vídeo ou da-
dos) são transmitidos em células de comprimento fixo (53 bytes), onde 48 bytes 
são dedicados ao campo dados e 5 bytes ao cabeçalho. Células de compri-
mento fixo permitem que o processamento ocorra no hardware, reduzindo, 
13
UNIDADE Protocolos de Encapsulamento em WAN 
assim, os atrasos de trânsito de rede e utilização desnecessária de CPU do dis-
positivo de rede. O ATM é projetado para aproveitar as mídias de transmissão 
de alta velocidade, como E3, SONET e T3, ou qualquer meio de transmissão 
de até 10 Gbps;
• Multiprotocol Label Switching (MPLS): O MPLS é uma técnica de rotea-
mento em redes de comunicação que direciona dados de um nó para o próximo 
com base em rótulos (label) de caminho curto, ao invés de longos endereços de 
rede como o IP Address, por exemplo, evitando consultas complexas em uma 
tabela de roteamento e acelerando os fluxos de tráfego. Os rótulos identificam 
links virtuais (caminhos) entre nós distantes, ao invés de pontos de extremi-
dade como nas técnicas de roteamento clássicas. O MPLS pode encapsular 
pacotes de vários tipos de protocolos de rede, daí a referência “multiprotocolo” 
em seu nome. Este protocolo pode suportar uma variedade de tecnologias de 
acesso, incluindo T1/E1, ATM, Frame Relay e DSL;
• Metro Ethernet: Também conhecida como Rede Ethernet Metropolitana, 
Ethernet MAN ou apenas rede Metro Ethernet, é uma rede metropolitana 
(MAN) baseada em padrões Ethernet. É comumente utilizada para conectar 
assinantes a uma rede de serviços maior, ou à própria Internet. As empresas 
também podem usar a Ethernet (criada para redeslocais) de área metropolita-
na para conectar seus próprios escritórios entre si. Uma interface Ethernet é 
muito mais barata que, por exemplo, uma SONET/SDH ou uma PDH, essas 
utilizadas para a conexão de redes em longa distância e com uma largura de 
banda aproximada. Outra vantagem distinta de uma rede de acesso baseada 
em Ethernet é que ela pode ser facilmente conectada à rede do cliente, devido 
ao uso e conhecimento predominante de Ethernet em redes corporativas e, 
mais recentemente, residenciais. A rede típica de um provedor de serviços é 
uma coleção de switches e roteadores conectados por fibra óptica. A topolo-
gia pode ser um anel, hub-and-spoke (estrela) ou malha completa (full-mesh) 
ou parcial (partial-mesh). Essa rede também segue uma hierarquia composta 
de núcleo, distribuição (agregação) e acesso. O núcleo, na maioria dos casos, 
é um backbone IP/MPLS existente, mas pode migrar para novas formas de 
transporte Ethernet com velocidades de 10Gbit/s, 40Gbit/s ou 100Gbit/s ou 
até mesmo 400Gbit/s.
Encapsulamento HDLC
O Controle de Link de Dados de Alto Nível, ou do inglês High-Level Data Link 
Control (HDLC), é um protocolo de encapsulamento de enlace de WAN utilizado 
em interfaces seriais ponto-a-ponto dedicadas.
Embora o HDLC seja tecnicamente um protocolo padrão ISO, a implementação 
do HDLC da Cisco é exclusiva e não funcionará com outros roteadores. Nesse 
14
15
contexto, o HDLC também é o tipo de encapsulamento padrão da Cisco para links 
ponto-a-ponto seriais (CISCO, 2017).
O HDLC é um protocolo simples, antigo e não fornece nenhum mecanismo de 
autenticação e compactação. Porém, o HDLC da Cisco possui em seu cabeçalho 
o campo conhecido como “Protocolo”, que especifica o que está sendo encasulado 
dentro desse quadro de WAN.
Encapsulamento PPP
O protocolo ponto-a-ponto, do inglês point-to-point protocol (PPP), é um proto-
colo de encapsulamento de enlace de WAN padronizado e que pode ser utilizado 
em uma ampla variedade de tecnologias WAN, incluindo:
• Interfaces seriais ponto-a-ponto dedicadas;
• Links dial-up assíncronos;
• Rede Digital de Serviços Integrados (ISDN).
O PPP possui quatro componentes clássicos, são eles:
• Conexão Física: padrão para comunicação serial física (como EIA/TIA-232-
-C, V.35, ISDN etc.);
• HDLC (High-Level Data Link Control): para encapsular pacotes em qua-
dros sobre interfaces seriais;
• LCP (Link Control Protocol): para estabelecer, manter e finalizar os links 
ponto-a-ponto. Negociações de camada de enlace;
• NCP (Network Control Protocol): permite que vários protocolos da Camada 3
(como IP e IPX) sejam encapsulados em quadros. Negociações em camada 
de rede.
O PPP suporta vários recursos que o HDLC independente não possui, por exemplo:
• Autenticação: protege a comunicação forçando os dispositivos de envio/rece-
bimento a se identificarem com um nome de usuário e senha. O PPP suporta 
duas formas de autenticação, são elas: PAP (Password Authentication Protocol) 
e CHAP (Challenge Handshake Authentication Protocol);
• Compressão: melhora a eficiência em links lentos. O PPP suporta duas for-
mas de compactação: Stac e Predictor;
• Multilink: permite que vários canais sejam empacotados ou compartilhados 
em conjunto para negociar a largura de banda ideal. Os canais agrupados são 
tratados como um canal lógico;
15
UNIDADE Protocolos de Encapsulamento em WAN 
• Callback: fornece serviços de segurança e faturamento. Permite que um clien-
te primeiro disque um servidor PPP, desconecte e faça com que o servidor PPP 
chame o cliente de volta, evitando que o cliente gaste tarifas telefônicas; 
• Controle de Erros: fornece técnicas de controle de erros para manter os da-
dos transmitidos íntegros e confiáveis.
Configurando o PPP Básico
Para configurar uma interface serial para o encapsulamento PPP:
Router(config)# interface s0/0
Router(config-if)# encapsulation ppp
Lembre-se de que o PPP suporta dois métodos de autenticação, PAP e CHAP. 
O PAP (Password Authentication Protocol) envia senhas em texto não criptogra-
fado e, portanto, não oferece muita segurança. Já o CHAP (Challenge Handshake 
Authentication Protocol) usa o MD5 para aplicar um hash irreversível e, por esse 
motivo, é mais seguro que o PAP (CISCO, 2017).
Para configurar a autenticação PPP:
Router(config)# hostname Router1
Router1(config)# username Router2 password SENHA 
Router1(config)# interface s0/0
Router1(config-if)# ppp authentication chap
A primeira linha do comando define o nome do host do roteador (Router1). 
A segunda linha do comando define o nome de usuário e senha que serão utilizados 
para autenticação PPP. O nome de usuário deve ser o nome do host do roteador 
remoto, e a senha deve ser a mesma nos dois roteadores que farão parte do pro-
cesso de autenticação.
A configuração acima define a autenticação para o chap. Para configurar a au-
tenticação pap:
Router(config)# interface s0/0
Router(config-if)# ppp authentication pap
Protocolo Frame-Relay
Configurando o Frame-Relay Básico
O Frame-Relay é uma tecnologia de enlace de comutação de pacotes que com-
partilha a largura de banda entre os usuários em uma rede comutada. Os provedo-
res de serviços que ofertam essa tecnologia pressupõem que nem todos os clientes 
16
17
precisarão da capacidade total de sua largura de banda em todos os momentos da co-
municação. Assim sendo, o Frame-Relay é mais barato que as linhas WAN dedicadas,
por exemplo, ainda que os clientes dessa tecnologia não tenham largura de banda 
total garantida (COMER, 2016).
Todos os locais se conectam à nuvem Frame-Relay, que é um conglomerado de 
dezenas ou centenas de switches Frame-Relay e roteadores de rede. A nuvem FR 
é a rede do provedor de serviços a ser contratado e o cliente não possui controle 
(muito menos conhecimento específico) do que ocorre dentro dessa infraestrutura 
de rede, ou seja, para o cliente, é uma rede transparente.
Para comunicação entre dois locais, os circuitos virtuais (VC – Virtual Circuit) 
devem ser criados. Sendo que um VC nada mais é do que um caminho unidirecio-
nal através da nuvem Frame-Relay. Os circuitos de quadro estabelecidos podem ser 
permanentes, do inglês Permanent Virtual Circuit (PVC), ou comutados, do inglês 
Switched Virtual Circuits (SVC). Um PVC é sempre mantido ativo e é o circuito 
virtual mais comumente utilizado, já o SVC é criado somente quando o tráfego pre-
cisa ser enviado e é interrompido quando a comunicação é devidamente concluída.
Circuitos virtuais são identificados com Identificadores de Conexão de Link de 
Dados, do inglês Data Link Connection Identifier (DLCIs). Os switches Frame-Relay
tomam decisões de encaminhamento com base nos DLCIs aprendidos. É importan-
te entender que os Switches Frame Relay tomam decisões de encaminhamento via 
DLCIs, já os Switches Ethernet (estes usados em redes locais), tomam decisões de 
encaminhamento baseando-se através dos MAC aprendidos (COMER, 2016).
A diferença entre um DLCI de significado global ou local está em sua perspec-
tiva de posicionamento. Como pudemos verificar, um DLCI identifica um circuito 
virtual unidirecional. Para que isso funcione corretamente, precisamos mapear um 
DLCI para um endereço IP correspondente, a fim de apontar os eventuais destinos 
da comunicação Frame-Relay.
CIR Frame-Relay
O provedor de serviços que oferta a tecnologia Frame-Relay e o cliente con-
cordam com uma taxa de informação comprometida, do inglês Committed
Information Rate (CIR), que nem sempre é garantia de largura de banda ofertada. 
O provedor fará um ótimo esforço para atender o CIR definido contratualmente 
com o cliente, que é medido em bits por segundo como, por exemplo, 256.000 
bps, 512.000 bps, 1544000 bps e outros valores.
Às vezes, as velocidades de largura de banda podem estourar (BE) acima do CIR 
contratado. E, nesse caso, as velocidades acima do CIR provavelmente não são ga-
rantidas, e se a rede Frame-Relay ficar congestionada, todos os dados que excedam 
o CIR tornam-se descartáveis e corremo risco de ser descartados naturalmente 
pela própria rede.
17
UNIDADE Protocolos de Encapsulamento em WAN 
Tipos de Encapsulamento de Frame Relay
Nos equipamentos de roteamento da Cisco (roteadores), dois possíveis encapsu-
lamentos do Frame-Relay podem ser configurados nas interfaces seriais do rotea-
dor, são eles:
• Cisco: É o encapsulamento Frame-Relay padrão e proprietário da Cisco, ou 
seja, só funciona entre dois dispositivos desse fabricante;
• IETF: o encapsulamento Frame-Relay padronizado pela Internet Engineering 
Task Force e, por esse motivo, é um encapsulamento aberto e de utilização de 
vários tipos de fabricantes.
Interface de Gerenciamento Local do Frame-Relay (LMI)
O Local Management Interface (LMI) é o tipo de sinalização utilizada entre o 
roteador e o switch Frame-Relay em seu provedor de serviço. O LMI fornece atuali-
zações de status de circuitos virtuais entre o switch Frame e o roteador, sendo parte 
do estabelecimento e gerência desse link. Existem três tipos de LMI conhecidos em 
dispositivos da Cisco, são eles:
• Cisco: padrão e proprietário;
• ANSI’s: T1.617 Annex D standard;
• ITU-T’s: Q.933 Annex A standard (Q933a).
O tipo de LMI é detectado automaticamente pelos roteadores da Cisco por pa-
drão, porém, pode ser definido manualmente, caso seja desejado pelo administra-
dor de rede (DAVID, 2013).
Configuração Frame-Relay Ponto-a-Ponto
A conexão Point-to-Point, do português Ponto-a-Ponto, com certeza é a forma 
mais simples de configuração do Frame-Relay. Lembre-se de que os PVCs são ape-
nas circuitos unidirecionais e, portanto, precisamos criar dois PVCs em cada ponta 
para que ocorra uma comunicação correta e completa.
Nuvem Frame-Relay2811
Router0
2811
Router1
Figura 4 – Frame-Relay Ponto-a-Ponto
Fonte: Acervo do Conteudista
18
19
Configuração Router0:
Router0(config)# interface s0/0 
Router0(config-if)# ip address 172.16.1.1 255.255.0.0 
Router0(config-if)# encapsulation frame-relay 
Router0(config-if)# frame-relay lmi-type q933a 
Router0(config-if)# frame-relay interface-dlci 102 
Router0(config-if)# no shutdown
Configuração Router1:
Router(config)# interface s0/0 
Router(config-if)# ip address 172.16.1.2 255.255.0.0 
Router(config-if)# encapsulation frame-relay 
Router(config-if)# frame-relay lmi-type q933a 
Router(config-if)# frame-relay interface-dlci 201 
Router(config-if)# no shutdown
Note através dos comandos descritos, que ambos os roteadores da topologia 
Frame-Relay estão na mesma sub-rede IP 172.16.1.0 255.255.0.0.
O comando “encapsulation frame-relay” define o tipo de encapsulamento de 
quadros na interface do roteador para o padrão Cisco. Nesse caso, ambos os en-
capsulamentos devem ser os mesmos em todos os dois roteadores. Para alterar o 
tipo de encapsulamento padrão, basta anexar a palavra-chave “ietf” ao comando 
encapsulation frame-relay:
Router(config)# interface s0/0 
Router(config-if)# ip address 172.16.1.1 255.255.0.0 
Router(config-if)# encapsulation frame-relay ietf
O comando “frame-relay interface-dlci ...” identifica o PVC unidirecional.
A conexão entre o Router0 e Router1 foi atribuída ao DLCI 102. A conexão entre 
Router1 e Router0 foi atribuída ao DLCI 201. O provedor Frame-Relay geralmente 
determina quais números de DLCI devem ser utilizados, pois o switch Frame-Relay 
do provedor é configurado com as informações de DLCI apropriadas. Nesse caso, 
geralmente o provedor de serviços envia um comunicado ao cliente para identificar 
o DLCI que deve ser aplicado no router.
O roteador pode realmente receber todas as informações de PVC e DLCI dire-
tamente do switch Frame-Relay via LMI, usando ARP inverso (inverse ARP), e o 
ARP inverso é habilitado por padrão nos roteadores Cisco.
19
UNIDADE Protocolos de Encapsulamento em WAN 
Portanto, se a opção Frame-Relay estiver configurada corretamente, o coman-
do frame-relay interface-dlci ... poderá, teoricamente, ser removido e a conexão 
frame-relay ainda funcionará. Há circunstâncias em que os DLCIs devem ser atri-
buídos manualmente. Nesses casos, o Inverse ARP poderá ser desativado em uma 
interface com o seguinte comando:
Router(config)# interface s0/0
Router(config-if)# no frame-relay inverse-arp
Como Funcionam os Protocolos de Rede, os Pacotes, Firewall e Switch.
Disponível em: https://youtu.be/IOIWEjh5QNAE
xp
lo
r
20
21
Material Complementar
Indicações para saber mais sobre os assuntos abordados nesta Unidade:
 Livros
Módulo de Roteamento e Switching: Conceitos Essenciais (CCNA2)
CISCO NETACAD – Módulo de Roteamento e Switching: Conceitos Essenciais 
(CCNA2) – 6ª Versão, Cisco Systems, 2017. (Material on-line).
Módulo de Roteamento e Switching: Dimensionamento (CCNA3) 
CISCO NETACAD – Módulo de Roteamento e Switching: Dimensionamento 
(CCNA3) – 6ª Versão, Cisco Systems, 2017. (Material on-line).
Redes de Computadores
DAVID, B. S.; PETERSON, L. L. Redes de Computadores. 5ª Ed. São Paulo: Editora 
Campus, 2013.
Comunicação de Dados
ROCHOL, J. Comunicação de Dados. Porto Alegre: Editora Bookman, 2012. (e-book).
CCNP Routing and Switching Official Cert Library
KEVIN, W, LACOSTE, R; HUCABY, D. CCNP Routing and Switching Official 
Cert Library. Indianápolis – EUA: Editora Cisco Press, 2015.
21
UNIDADE Protocolos de Encapsulamento em WAN 
Referências
COMER, D. E. Redes de Computadores e Internet 6. ed. Porto Alegre: Editora 
Bookman, 2016.
KUROSE, James F; ROSS, Keith W. Redes de Computadores e a Internet: uma 
abordagem top-down. 6. ed. São Paulo: Editora Pearson, 2013.
STALLINGS, W.; ROSS K. Redes de Computadores e a Internet. 5. ed. São 
Paulo: Editora Pearson, 2010.
TANENBAUM, A. S; WETHERALL, D. Redes de Computadores. 5. ed. Rio de 
Janeiro: Editora Campus, 2011.
22

Materiais relacionados

Perguntas relacionadas

Materiais recentes

Perguntas Recentes