A maior rede de estudos do Brasil

Grátis
22 pág.
Aula2_Algoritmos3

Pré-visualização | Página 3 de 4

("------- - ------- ----- -- -----------") 
 escreva (" ") 
 escreva ("Qual a distancia (Km) percorrida pelo veiculo? ") 
 leia(distancia) 
 escreva ("Quantos litros de combustível foram gastos no trajeto? ") 
 leia(volume) 
 consumo <- volume/distancia 
 escreva("O consumo medio de combustível foi de ", consumo, " litros/km") 
 escreva("O carro fez ", distancia/volume, "km com 1 litro") 
Fim 
 
2. Calcular a média parcial de um aluno da UFRN, dadas as suas três primeiras notas. 
Algoritmo MediaParcial 
 Real : media, nota1, nota2, nota3 
Inicio 
 escreva ("------- -- ----- -------") 
 escreva ("Calculo da média Parcial") 
 escreva ("------- -- ----- -------") 
 escreva (" ") 
 escreva ("Digite as suas três primeiras notas: ") 
 leia(nota1, nota2, nota3) 
 media <- (nota1*4 + nota2*5 + nota3*6)/15 
 escreva("A sua média na disciplina é ", media) 
Fim 
 
3. Calcular o valor da função f(x,y) = 3x2 + 2y2 - xy em um ponto qualquer do plano 
cartesiano. 
Algoritmo PontoNoPlano 
 Real: fxy, x, y 
Inicio 
 escreva ("===========================================") 
 escreva ("Calculo da função f(x,y) = 3x^2 + 2y^2 - xy") 
 escreva ("===========================================") 
 escreva (" ") 
 escreva ("Digite as cordenadas x e y de um ponto: ") 
 leia(x,y) 
 fxy <- (3*x^2) + (2*y^2) - (x*y) 
 escreva ("O valor da função f(x,y) ") 
 escreva ("para x = ", x, " e y = ", y, " é igual a ", fxy) 
Fim 
 
4. Leia uma temperatura em graus centígrados e imprima a equivalente em graus 
farheneit ( F = 9C/5 + 32). 
Algoritmo CelsiusFarheneit 
 Real: tempCel, tempFar 
Inicio 
 escreva ("++++++++++++++++++++++++++++++++++++++++++++") 
 escreva ("| Conversão Celsius - Farheneit |") 
 escreva ("++++++++++++++++++++++++++++++++++++++++++++") 
 escreva ("") 
 escreva ("Qual a temperatura em graus Celsius? ") 
 leia(tempCel) 
 tempFar <- 9 * tempCel/5 + 32 
 escreva ("A temperatura digitada é equivalente a", tempFar, "F") 
Fim 
 
5. Leia uma quantidade de chuva dada em polegadas e imprima a equivalente em 
milímetros ( 1 polegada = 25,4 milímetros ). 
Algoritmo PolegadaMilimetro 
 Real: polegadas, milimetros 
Inicio 
 escreva ("---> Conversão de Polegadas em Milimetros <---") 
 escreva ("") 
 escreva ("Qual a medida em polegadas? ") 
 leia(polegadas) 
 milimetros <- polegadas * 25.4 
 escreva ("A medida equivale a", milimetros, "mm") 
Fim 
 
Aula 6 
Exercícios de Instruções Primitivas 
1. O que vai ser impresso na tela para cada uma das instruções abaixo e qual a diferença 
entre cada uma delas? O que é o nome três na letra c? Existe mais de uma saída 
possível? 
a. Escreva (“A resposta é”, 3) 
b. Escreva (“A resposta é 3”) 
c. Escreva (“A resposta é”, tres) 
d. Escreva (“A resposta é três”) 
 
2. Qual o a saída do algoritmo abaixo? 
Algoritmo ServidorPublico 
 Logico: funcionario 
 Inteiro: anosDeServico 
Inicio 
 funcionario <-V 
 anosDeServico <- 4 
 escreva (“Recebe benefício: ”, AnosdeServico > 5 e funcionario) 
Fim 
 
3. Identifique os erros e corrija o algoritmo abaixo: 
Alg. Lucro 
 
Inicio 
 escreva “Qual a arrecadação da sua empresa?” 
 leia (“arrecadacao”) 
 escreva ("Qual o gasto da sua empresa? ") 
 leia “gastos” 
 lucro <- arrecadacao - gastos 
 escreva ("O lucro da sua empresa foi de, lucro”) 
Fim 
4. Identifique os erros e corrija o algoritmo abaixo: 
Algoritmo Consumo 
 Real: consumo medio, distancia total, volume 
Inicio 
 escreva ("Qual a distancia percorrida pelo veiculo? ") 
 leia(distancia total) 
 escreva ("Quantos litros de combustível foram gastos no trajeto? ") 
 leia(volume) 
 consumo medio = volume/distancia total 
 escreva("O consumo médio de combustível foi de ", consumo, " litros/km") 
Fim 
 
5. Quais os valores das variáveis a e b nas linhas 6, 8 e 9 do algoritmo abaixo: 
Algoritmo Estado 
 Inteiro: a, b 
Inicio 
 a <- 5 
 b <- 2 
 escreva (a, b) // linha 6 
 b <- a; 
 escreva (a, b) // linha 8 
 a <- b; 
 escreva (a, b) // linha 9 
Fim 
 
6. Construa a seção de declaração de variáveis do algoritmo abaixo: 
Algoritmo Estado 
 
Inicio 
 a <- 5.5 
 b <- 2 
 total <- a * b 
Fim 
 
7. O algoritmo abaixo foi escrito para a ferramenta VisuAlg. Identifique as diferenças 
entre a linguagem utilizada no VisuAlg e a linguagem de pseudocódigo utilizada na 
disciplina de algoritmos e programação de computadores. 
algoritmo "CelsiusFarheneit" 
// Função : Converte um temperatura de graus Celsius para Farheneit 
// Autor : Judson Santiago 
// Data : 21/03/2007 
var 
 tempCel, tempFar : real 
inicio 
 escreval ("Conversão Celsius - Farheneit") 
 escreval ("") 
 escreva ("Qual a temperatura em graus Celsius? ") 
 leia(tempCel) 
 tempFar <- 9 * tempCel/5 + 32 
 escreval ("A temperatura digitada é equivalente a", tempFar, "F") 
Fimalgoritmo 
 
8. Crie um algoritmo para pedir o nome e senha de um usuário. O algoritmo deve 
imprimir verdadeiro se o nome e senha forem respectivamente iguais a “aluno” e 
“algoritmos”, e falso caso contrário. Não utilize a instrução SE. 
 
9. Faça um algoritmo para construir uma mensagem de boas vindas aos novos hospedes 
de um hotel. O algoritmo deve pedir o nome, sobrenome e cidade de origem do 
hospede e imprimir uma mensagem seguindo este padrão: 
Bem vindo NOME SOBRENOME. 
Esperamos que a sua viagem de CIDADE até Natal tenha sido agradável. 
 
Aula 7: Controle de Fluxo de Execução 
 
Até agora todos os algoritmos seguiam uma estrutura de execução linear, em que cada 
instrução é executada após a instrução anterior. Certas estruturas de controle permitem 
mudar o fluxo de execução de um algoritmo. 
As estruturas de controle se classificadas em: 
• Estruturas de decisão 
� Se 
� Escolha 
• Estrutura de repetição 
� Para 
� Enquanto 
� Repita 
Estrutura de Decisão SE 
Sintaxe: 
 Se ( <condição> ) então Se ( <condição> ) então 
 <instruções1> <instruções> 
 Senão Fimse 
 <instruções2> 
 Fimse 
Semântica: Apenas um bloco de instruções é executado. Qual deles é executado depende da 
avaliação da expressão <condição>. Se a condição é verdadeira, então o bloco <instruções1> é 
executado; se a condição é falsa o bloco <instruções2> é executado. 
Exemplo: Determinar se a senha do usuário é igual a “algoritmos” 
As instruções dentro do SE podem conter outras estruturas de decisão SE, formando SE’s 
aninhados ou encaixados. 
Exemplo: Determinar o maior (max) e o menor (min) valor entre 3 numeros (a, b, c). 
Estrutura de Decisão ESCOLHA 
Sintaxe: 
Escolha ( <expressão de seleção>) 
 Caso (<exp1>) faça 
 <instruções1> 
 ... 
 Caso (<expn>) faça 
 <instruçõesn> 
 Senão 
 <instruções> 
Fimescolha 
 
Semântica: a expressão de seleção deve ser um nome de variável. A expressão <exp> de cada 
caso deve listar os possíveis valores que a variável deve ter para a execução do caso. 
Exemplo: Decidir de qual cidade é o time de um torcedor de futebol. 
Algoritmo Torcedor 
 Literal: time 
Inicio 
 Escreva ("Entre com o nome de um time de futebol: ") 
 Leia (time) 
 Escolha (time) 
 Caso ("Flamengo", "Fluminense", "Vasco", "Botafogo") 
 Escreva ("É um time carioca.") 
 Caso ("São Paulo", "Palmeiras", "Santos", "Corínthians") 
 Escreva ("É um time paulista.") 
 Senão 
 Escreva ("É de outro estado.") 
 Fimescolha 
Fim 
 
Estrutura de Repetição PARA 
Sintaxe: 
Para <variável> de <valor inicial> até <valor final> faça 
<instruções> 
Fimpara 
 
Semântica: A variável inicialmente recebe <valor inicial>; se o valor da variável é menor ou 
igual ao valor final, o bloco de instruções é executado e o valor da variável é incrementado de 
uma unidade; o processo