A maior rede de estudos do Brasil

Grátis
123 pág.
lógica e algoritmo apol 1 a 5

Pré-visualização | Página 7 de 9

�����
   leia(n)
   para i de 1 ate n faca
     escreval("Digite um numero qualquer:")
     leia(v[i])
   fimpara
   limpatela 
   k<-0 
   j<-0
   para i de 1 ate n faca
     se (v[i]>0) entao
        k<-k+1
        vp[k]<-v[i]
     senao
        j<-j+1
        vn[j]<-v[i]
     fimse
   fimpara 
   escreval("Positivos:") 
   para i de 1 ate j faca
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
      escreval(vp[i])
   fimpara
  
   escreval("Negativos:")
   para i de 1 ate k faca
      escreval(vn[i])
   fimpara
Fimalgoritmo 
A
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
positivos<-0 
   negativos<-0
   escreval("Positivos:")
   para i de 1 ate j faca
      escreval(vp[i])
      positivos<-positivos+1
   fimpara
  
   escreval("Negativos:")
   para i de 1 ate k faca
      escreval(vn[i])
     negativos<-negativos+1
   fimpara
 
   escreval(“Total de Positivos:”,positivos)
   escreval(“Total de Negativos:,negativos) 
B
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
positivos<-0 
   negativos<-0
   escreval("Positivos:")
   para i de 1 ate j faca
      escreval(vp[i])
      positivos<-positivos+vp[i]
   fimpara
  
   escreval("Negativos:")
   para i de 1 ate k faca
      escreval(vn[i])
     negativos<-negativos+vn[i]
   fimpara
 
   escreval(“Soma Positivos:”,positivos)
   escreval(“Soma Negativos:",negativos)
Você acertou!
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
C
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
 positivos<-0 
   negativos<-0
   escreval("Positivos:")
   para i de 1 ate j faca
      escreval(vp[i])
   fimpara
  
   escreval("Negativos:")
   para i de 1 ate k faca
      escreval(vn[i])
   fimpara
 
   escreval(“Total de Positivos:”,positivos)
   escreval(“Total de Negativos:,negativos) 
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
D escreval("Positivos:") 
   para i de 1 ate j faca
      escreval(vp[j])
      positivos<-positivos+vp[i]
   fimpara
  
   escreval("Negativos:")
   para i de 1 ate k faca
      escreval(vn[k])
     negativos<-negativos+vn[i]
   fimpara
 
   escreval(“Total de Positivos:”,positivos)
   escreval(“Total de Negativos:,negativos)
Questão 6/10
Para o algoritmo abaixo, qual é o código mais adequado a incluir para calcular a quantidade de números ímpares? 
algoritmo "matriz_par"
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
var
 
  m:vetor[1..3,1..3] de inteiro
  resto, qtpar,i,j:inteiro
 
inicio
 
qtpar <-0
 
escreval("***** Entrada de Dados *****")
escreval("")
para i de 1 ate 3 faca
  para j de 1 ate 3 faca
       escreva("Digite um valor para linha:",i," coluna:",j,":")
       leia(m[i,j])
        resto<-m[i,j] mod 2
        se(resto=0) entao
           qtpar<-qtpar+1
        fimse
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
  fimpara
fimpara
 
limpatela
 
escreval("***** Resultados da matriz *****")
para i de 1 ate 3 faca
  para j de 1 ate 3 faca
     resto<-m[i,j] mod 2
     se(resto=0) entao
        escreval("Linha:",i," Coluna:",j," Numero=",m[i,j])
     fimse
  fimpara
fimpara
escreval("Quantidade de numeros pares: ", qtpar)
 
 
 
fimalgoritmo
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
A resto<-m[i,j] mod 2 
se(resto<>0) entao
     qtimpar<-qtimpar+1
fimse 
B resto<-m[i,j] mod 2 
se(resto<>0) entao
     qtimpar<-qtimpar+m[i,j]
fimse 
C resto<-m[i,j] mod 2 
se(resto=~0) entao
     qtimpar<-qtimpar+1
fimse 
Você acertou!
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
D resto<-m[i,j] mod 2 
se(resto=0) entao
     qtimpar<-qtimpar+1
fimse 
Questão 7/10
Para o algoritmo abaixo, qual deveria ser o resultado exibido para uma matriz 3X3? 
algoritmo "matriz"
 
var
 
  matriz:vetor[1..10,1..10] de inteiro
  i,j,m,n:inteiro
 
inicio
 
escreval("***** Entrada de Dados *****")
escreval("")
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
escreva("Digite o numero de linhas e o numero de colunas para matriz:")
leia(m,n)
para i de 1 ate m  faca
  para j de 1 ate n faca
       escreva("Digite um valor para linha:",i," coluna:",j,":")
       matriz[i,j]<-i+1
  fimpara
fimpara
 
limpatela
 
escreval("***** Resultados da matriz *****")
para i de 1 ate m faca
  para j de 1 ate n faca
     escreva(matriz[i,j])
  fimpara
     escreval("")
fimpara
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
 
fimalgoritmo
A 1 1 1 
2 2 2
3 3 3
B 2 2 2 
3 3 3
4 4 4
C 2 2 2 
2 2 2
3 3 3
D 1 1 1 
3 3 3
5 5 5
Você acertou!
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
Questão 8/10
Para o algoritmo abaixo, qual deveria ser a saída para uma matriz 2X2? 
algoritmo "matriz"
 
var
 
  matriz:vetor[1..10,1..10] de inteiro
  i,j,m,n:inteiro
 
inicio
 
escreval("***** Entrada de Dados *****")
escreval("")
escreva("Digite o numero de linhas e o numero de colunas para matriz:")
leia(m,n)
para i de 1 ate m  faca
  para j de 1 ate n faca
       escreva("Digite um valor para linha:",i," coluna:",j,":")
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
       matriz[i,j]<-j+1
  fimpara
fimpara
 
limpatela
 
escreval("***** Resultados da matriz *****")
para i de 1 ate m faca
  para j de 1 ate n faca
     escreva(matriz[i,j])
  fimpara
     escreval("")
fimpara
 
fimalgoritmo
A 2 3 
2 3
Você acertou!
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
B 2 1 
2 1
C 2 0 
2 0
D 4 2 
4 2
Questão 9/10
Para o algoritmo abaixo, qual deveria ser a saída para uma matriz 2X3? 
algoritmo "matriz"
 
var
 
  matriz:vetor[1..10,1..10] de inteiro
  i,j,m,n:inteiro
 
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
inicio
 
escreval("***** Entrada de Dados *****")
escreval("")
escreva("Digite o numero de linhas e o numero de colunas para matriz:")
leia(m,n)
para i de 1 ate m  faca
  para j de 1 ate n faca
       escreva("Digite um valor para linha:",i," coluna:",j,":")
       matriz[i,j]<-j+1