A maior rede de estudos do Brasil

Grátis
123 pág.
lógica e algoritmo apol 1 a 5

Pré-visualização | Página 9 de 9

�����
leia(n3)
escreva("Digite o peso do segundo valor:")
leia(n4)
 
x<-fsx(n1,n2,n3,n4)
 
escreval("O valor da operação de ",n1," com ",n2," =",x)
 
fimalgoritmo
A inicio 
total<-((v1*v3)+(v2*v4))/(v3+v4)
retorne total
B
Você acertou!
Conteúdo abordado nas aulas 7, 8, 9 e 10. 

���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
inicio 
total<-((n1*n3)+(n2*n4))/(n1+n2)
retorne resultado
C inicio 
total<-((n1*n3)+(n2*n4))/(n3*n4)
retorne total
D inicio 
total<-((n1*n3)+(n2*n4))/10
retorne resultado
Questão 6/10
Para o código que contém as funções abaixo, qual seria o resultado de uma entrada de dados que atribui o valor “Joaquim
Nabuco” para a variável completo? 
 
  qt_carc<-Compr(completo)
  espaco<-Pos(" ",completo)              //note que é necessário um espaço em branco entre as aspas
  sobrenome1<-Copia(completo,espaco+1,qt_carc)
  retorne sobrenome1
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
A Joaquim 
B Nabuco 
C 1Nabuco 
D Nabuco, Joaquim 
Questão 7/10
Para o código que contém as funções abaixo, qual seria o resultado de uma entrada de dados que atribui o valor “16” para a
variável valor? 
r<-Raizq(valor)
potencia<-exp(r, 3)
Você acertou!
Conteúdo abordado nas aulas 7, 8 9 e 10 

���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
escreval("O resultado da operação e: “, potencia) 
A 4
B 12
C 48
D 64
Questão 8/10
Analise o código do algoritmo abaixo e assinale a alternativa que relaciona todas as funções pré-definidas utilizadas? 
 
  qt_carc<-Compr(nome)
  espaco<-Pos(" ",nome)
Você acertou!
Conteúdo abordado nas aulas 9 e 10.

���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
  x<-Copia(nome,espaco+1,qt_carc)
  retorne x
A Compr, Pos 
B Pos, Copia
C Compr, Pos, Copia
D  Nome, Compr, Pos, Copia
Questão 9/10
Procedimentos e funções tem a mesma finalidade? 
A Não. Função obrigatoriamente retorna um valor, já um procedimento não retorna um valor, apenas executa uma
ação. 
Você acertou!
Conteúdo abordado nas aulas 9 e 10

���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
B Sim. Possuem a mesma finalidade e ambos retornam um valor. 
C Não, pois a Função executa uma única ação e procedimento executa uma ação e retorna um valor. 
D Sim, Funções e procedimentos são apenas sub-rotinas. 
Questão 10/10
No algoritmo abaixo quantas linhas com asteriscos serão mostradas na tela? 
algoritmo "Procedimento"
var
x:caracter
 
procedimento linha
var
 
Você acertou!
Conteúdo abordado nas aulas 09 e 10.

���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
inicio
 
  escreval("******************************************************")
  escreval("")
 
fimprocedimento
 
 
inicio
// Seção de Comandos
 
 
escreval("***** Titulo *****")
escreval("")
 
linha
leia(x)
linha
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
escreval(x)
linha
linha
 
fimalgoritmo
A Duas 
B Quatro
C Três
D Nenhuma
Você acertou!