A maior rede de estudos do Brasil

Grátis
9 pág.
APOL 5   Lógica de Programação e Algorítmos

Pré-visualização | Página 1 de 1

16/04/2016 AVA UNIVIRTUS
http://univirtus­277877701.sa­east­1.elb.amazonaws.com/ava/web/#/ava/AvaliacaoUsuarioHistorico/55296/novo/1 1/9
APOL 5
PROTOCOLO: 201603151260111734C5EJOSÉ CARLOS CANTARINI FILHO - RU: 1260111 Nota: 100
Disciplina(s):
Lógica de Programação e Algoritmos
Data de início: 15/03/2016 11:56
Prazo máximo entrega: - 
Data de entrega: 15/03/2016 12:13
Questão 1/10
Para que o programa abaixo faça a média ponderada, quais seriam as linhas de código mais adequadas para
substituírem a parte pontilhada? 
 
algoritmo "Função"
// Seção de Declarações
var
 
n1,n2,n3,n4,x:real
 
funcao fsx(v1,v2,v3,v4:real):real
var
total:real
..........................
..........................
..........................
 
fimfuncao
 
inicio
// Seção de Comandos
 
escreva("Digite o primeiro valor:")
leia(n1)
escreva("Digite o segundo valor:")
leia(n2)
escreva("Digite o peso do primeiro valor:")
leia(n3)
escreva("Digite o peso do segundo valor:")
leia(n4)
 
16/04/2016 AVA UNIVIRTUS
http://univirtus­277877701.sa­east­1.elb.amazonaws.com/ava/web/#/ava/AvaliacaoUsuarioHistorico/55296/novo/1 2/9
x<­fsx(n1,n2,n3,n4)
 
escreval("O valor da operação de ",n1," com ",n2," =",x)
 
fimalgoritmo
A inicio 
total<­((v1*v3)+(v2*v4))/(v3+v4)
retorne total
B inicio 
total<­((n1*n3)+(n2*n4))/(n1+n2)
retorne resultado
C inicio 
total<­((n1*n3)+(n2*n4))/(n3*n4)
retorne total
D inicio 
total<­((n1*n3)+(n2*n4))/10
retorne resultado
Questão 2/10
Para o código que contém as funções abaixo, qual seria o resultado de uma entrada de dados que atribui o valor “16”
para a variável valor? 
r<­Raizq(valor)
potencia<­exp(r, 3)
escreval("O resultado da operação e: “, potencia) 
A 4
B 12
C 48
D 64
Você acertou!
Conteúdo abordado nas aulas 7, 8, 9 e 10.

Você acertou!
Conteúdo abordado nas aulas 9 e 10.

16/04/2016 AVA UNIVIRTUS
http://univirtus­277877701.sa­east­1.elb.amazonaws.com/ava/web/#/ava/AvaliacaoUsuarioHistorico/55296/novo/1 3/9
Questão 3/10
Procedimentos e funções tem a mesma finalidade? 
A Não. Função obrigatoriamente retorna um valor, já um procedimento não retorna um valor, apenas
executa uma ação. 
B Sim. Possuem a mesma finalidade e ambos retornam um valor. 
C Não, pois a Função executa uma única ação e procedimento executa uma ação e retorna um valor. 
D Sim, Funções e procedimentos são apenas sub­rotinas. 
Questão 4/10
No algoritmo abaixo quantas linhas com asteriscos serão mostradas na tela? 
algoritmo "Procedimento"
var
x:caracter
 
procedimento linha
var
 
inicio
 
  escreval("******************************************************")
  escreval("")
 
fimprocedimento
 
 
inicio
// Seção de Comandos
 
 
escreval("***** Titulo *****")
Você acertou!
Conteúdo abordado nas aulas 09 e 10.

16/04/2016 AVA UNIVIRTUS
http://univirtus­277877701.sa­east­1.elb.amazonaws.com/ava/web/#/ava/AvaliacaoUsuarioHistorico/55296/novo/1 4/9
escreval("")
 
linha
leia(x)
linha
escreval(x)
linha
linha
 
fimalgoritmo
A Duas 
B Quatro
C Três
D Nenhuma
Questão 5/10
Para que o programa abaixo faça a divisão de dois valores, sendo o primeiro pelo segundo, quais seriam as linhas de
código mais adequadas a substituirem as linhas pontilhadas? 
algoritmo "Função"
// Seção de Declarações
var
 
n1,n2,x:real
 
funcao fsx(v1,v2:real):real
var
total:real
............................................
............................................
............................................
 
fimfuncao
 
Você acertou!
16/04/2016 AVA UNIVIRTUS
http://univirtus­277877701.sa­east­1.elb.amazonaws.com/ava/web/#/ava/AvaliacaoUsuarioHistorico/55296/novo/1 5/9
 
inicio
// Seção de Comandos
 
escreva("Digite um valor:")
leia(n1)
escreva("Digite o segundo valor:")
leia(n2)
 
x<­fsx(n1,n2)
 
escreval("O valor da operação de ",n1," com ",n2," =",x)
 
 fimalgoritmo
A inicio 
total<­v1/v2
retorne total
B inicio 
total<­v1/2
retorne resultado
C inicio 
 total<­v2/v1
 retorne total
D inicio 
total<­v2/2
retorne resultado
Questão 6/10
Considerando o bloco de código de um algoritmo mostrado abaixo qual seria a alternativa adequada para substituí­lo? 
preco[1]<­150.00
preco [2]<­250.00
preco[3]<­10.00
preco [4]<­40.00
preco[5]<­120.00
Você acertou!
Conteúdo abordado nas aulas 7, 8, 9 e 10.

16/04/2016 AVA UNIVIRTUS
http://univirtus­277877701.sa­east­1.elb.amazonaws.com/ava/web/#/ava/AvaliacaoUsuarioHistorico/55296/novo/1 6/9
preco [6]<­500.00
preco[7]<­12.00
preco [8]<­13.00 
A  n<­8 
 para i de 1 ate n faca
    leia(preco(i))   
 fimpara 
B  n<­8 
 para i de 1 ate n faca
    leia(preco[i])   
 fimpara 
C para i de 1 ate n faca 
    leia(preco(k))   
fimpara
D para i de 1 ate n faca 
    leia(preco)   
fimpara
Questão 7/10
Para o código que contém as funções abaixo, qual seria o resultado de uma entrada de dados que atribui o valor
“Joaquim Nabuco” para a variável completo? 
 
  qt_carc<­Compr(completo)
  espaco<­Pos(" ",completo)              //note que é necessário um espaço em branco entre as aspas
  sobrenome1<­Copia(completo,espaco+1,qt_carc)
  retorne sobrenome1
A Joaquim 
B Nabuco 
Você acertou!
Assunto das aulas 7, 8, 9 e 10

Você acertou!
16/04/2016 AVA UNIVIRTUS
http://univirtus­277877701.sa­east­1.elb.amazonaws.com/ava/web/#/ava/AvaliacaoUsuarioHistorico/55296/novo/1 7/9
C 1Nabuco 
D Nabuco, Joaquim 
Questão 8/10
Analise o código do algoritmo abaixo e assinale a alternativa que relaciona todas as funções pré­definidas utilizadas? 
 
  qt_carc<­Compr(nome)
  espaco<­Pos(" ",nome)
  x<­Copia(nome,espaco+1,qt_carc)
  retorne x
A Compr, Pos 
B Pos, Copia
C Compr, Pos, Copia
D  Nome, Compr, Pos, Copia
Questão 9/10
O que a função definida no algoritmo abaixo faz? 
 
algoritmo "Função"
// Seção de Declarações
var
 
n1,n2,resultado1:real
 
funcao fsx(v1,v2:real):real
var
  total:real
inicio
  total<­v1+(v2*v2)
  retorne total
Conteúdo abordado nas aulas 7, 8 9 e 10
Você acertou!
Conteúdo abordado nas aulas 9 e 10

16/04/2016 AVA UNIVIRTUS
http://univirtus­277877701.sa­east­1.elb.amazonaws.com/ava/web/#/ava/AvaliacaoUsuarioHistorico/55296/novo/1 8/9
fimfuncao
  
inicio
// Seção de Comandos
 
escreva("Digite um valor:")
leia(n1)
escreva("Digite o segundo valor:")
leia(n2)
 
resultado1<­fsx(n1,n2)
 
escreval("O valor da operação de ",n1," com ",n2," =",resultado1)
  
fimalgoritmo
A A soma dos quadrados dos valores. 
B A soma do primeiro valor com o quadrado do segundo valor. 
C A soma do quadrado do primeiro valor pelo segundo valor. 
D O quadrado das somas dos valores. 
Questão 10/10
Avalie o bloco de código de um algoritmo mostrado abaixo, e selecione a alternativa adequada para substituí­lo. 
preco[1,1]<­1 
preco [1,2]<­2
preco[1,3]<­3
preco [1,4]<­4
preco[2,1]<­23.00
preco [2,2]<­500.00
preco[2,3]<­12.00
preco [2,4]<­13.00 
A
Você acertou!
Conteúdo abordado nas aulas 7, 8, 9 e 10.

16/04/2016 AVA UNIVIRTUS
http://univirtus­277877701.sa­east­1.elb.amazonaws.com/ava/web/#/ava/AvaliacaoUsuarioHistorico/55296/novo/1 9/9
para i de 1 ate 2 faca 
     para j de 1 ate 4 faca
         leia(preco[i,j])
     fimpara
fimpara
B para i de 2 ate 1 faca 
     para j de 4 ate 1 faca
         leia(preco(i,j))
     fimpara
fimpara
C para i de 1 ate 2 faca 
     para j de 1 ate 4 faca
         leia(preco[j,i])
     fimpara
fimpara
D para i de 1 ate 2 faca 
     para j de 1 ate 4 faca
         leia(preco[i])
     fimpara
fimpara
Você acertou!
Conteúdo abordado nas aulas 7, 8, 9 e 10
