exercicio de progamaçao resolvidos visualg
4 pág.

exercicio de progamaçao resolvidos visualg


DisciplinaAlgoritmos e Programação de Computadores568 materiais5.582 seguidores
Pré-visualização1 página
Ler um numero e calcular o dobro
algoritmo "calcular o dobro"
var
valor, dobro : inteiro
inicio
escreva ("digite um valor")
leia (valor)
dobro <- (2*valor)
escreva (&quot;o dobro e&quot;, dobro)
fimalgoritmo
Escrever um programa para ler um numero inteiro e exibir seu sucessor e seu antecessor 
algoritmo &quot;antecessor e sucessor&quot;
var
valor, antecessor, sucessor : real
inicio
escreva (&quot;digite valor&quot;)
leia (valor)
antecessor <- (valor-1)
sucessor <- (valor+1)
escreva (&quot;antecessor e&quot;, antecessor )
escreva (&quot;sucessor e&quot;, sucessor)
fimalgoritmo
Ler dois números e escrever a diferença entre o maior e o menor valor lido 
algoritmo &quot;semnome&quot;
// Função :
// Autor :
// Data : 13/04/2016
// Seção de Declarações 
var
n1, n2, subt : inteiro
inicio
escreval (&quot;digite o primeiro numero&quot;)
leia (n1)
escreval (&quot;digite o segundo numero&quot;)
leia(n2)
se n1>n2 entao
subt<- (n1-n2)
senao
subt <-(n2-n1)
 fimse
escreval (&quot; a diferença é &quot;,subt)
// Seção de Comandos 
fimalgoritmo
Fazer um fluxograma para ler a hora, minuto e segundo e converter tudo para segundos.
Fazer um fluxograma para ler dois tempos (hora, minuto e segundo) e escrever a diferença de tempo dentre eles.
Todo restaurante, embora por lei não possa abrigar o cliente a pagar, cobra 10% para o garçom. Fazer um algoritmo que leia o valor gasto com as despesas realizadas em um restaurante e imprima o valor da gorjeta e o valor da despesas (despesas + gorjetas)
algoritmo &quot;gorjeta&quot;
var
despezas, gorjeta : real
inicio
escreva (&quot;digite valor da despezas&quot;)
leia (despezas)
gorjeta <- (1.1*despezas)
escreva (&quot;valor total e&quot;, gorjeta)
fimalgoritmo
Para vários tributos a base de calculo e o salario mínimo. Fazer um algoritimo que leia o valor do salario mínimo e o valor do salario de uma pessoa. Calcular e exibir quantos salario mínimos essa pessoa ganha.
algoritmo &quot;salario minimo&quot;
var
salario, salario_pessoal, quantidade : real
inicio
escreva (&quot;valor de um salario&quot;)
leia (salario)
escreva (&quot;quanto e seu salrio?&quot;)
leia (salario_pessoal)
quantidade <- (salario_pessoal/salario)
escreva (&quot;a quantidade de salarios e&quot;, quantidade)
fimalgoritmo
Criar um algoritimo que exiba a media aritimetica entre os números 7,8 e 9
algoritmo &quot;media&quot;
var
nota1, nota2, nota3, media : real
inicio
escreva (&quot;digite primeira nota&quot;)
leia (nota1)
escreva (&quot;digite segunda nota&quot;)
leia (nota2)
escreva (&quot;digite terceira nota&quot;)
leia (nota3)
media <- (nota1 + nota2 + nota3)/3
escreva (&quot;a media e&quot;, media)
fimalgoritmo
Escrever um algoritimo que entre com 4 numeros reais e exiba a media ponderada. Sabendo-se que os pesos são respectivamente: 1, 2, 3 e 4
algoritmo &quot;semnome&quot;
var
n1, n2, n3, n4, p1, p2, p3, p4, mp : real
inicio
escreval (&quot;digite a primeira nota: &quot;)
leia (n1)
escreval (&quot;digite o peso: &quot;)
leia (p1)
escreval (&quot;digite a segunda nota: &quot;)
leia (n2)
escreval (&quot;digite o peso: &quot;)
leia (p2)
escreval (&quot;digite a terceira nota: &quot;)
leia (n3)
escreval (&quot;digite o peso: &quot;)
leia (p3)
escreval (&quot;digite a quarta nota: &quot;)
leia (n4)
escreval (&quot;digite o peso: &quot;)
leia (p4)
mp <- (n1*p1+n2*p2+n3*p3+n4*p4)/(p1+p2+p3+p4)
escreval (&quot;a media ponderada e: &quot;, mp)
fimalgoritmo
Fazer um aplicativo que obtenha do usuário o saldo de uma aplicação e imprima o novo saldo considerando o rendimento de 2,5%.
algoritmo &quot;conta bancaria&quot;
var
valor, total : real
inicio
escreva (&quot;digite saldo atual&quot;)
leia (valor)
total <- (1.025* valor)
escreva (&quot;seu novo saldo e&quot;, total)
fimalgoritmo
Fazer um aplicativo que entre com a base e altura de um retângulo e exiba seu perimetro e sua área. Saber que 
Perímetro = 2* (base + altura)
Área = base * altura 
algoritmo &quot;area e perimentro de retangulo&quot;
var
base, altura, perimetro, area : real
inicio
escreva (&quot;digite a o tamnho da base&quot;)
leia (base)
escreva(&quot;digite a altura&quot;)
leia (altura)
perimetro <- (base+ altura)*2
area <- (base*altura)
escreva (&quot;o perimetro e&quot;, perimetro, &quot;e a area e&quot;, area)
fimalgoritmo
Criar um aplicativo que calcule e exiba a área de um triangulo. Saber-se que.
Área = (base * altura)/2
algoritmo &quot;area de um triangulo&quot;
var
base, altura, area : real
inicio
escreva (&quot;digite a base &quot;)
leia (base)
escreva (&quot;digite altura&quot;)
leia (altura)
area <- (base*altura)/2
escreva (&quot;a area e&quot;, area)
fimalgoritmo
Criar um aplicativo que leia uma temperatura em graus centigrafos e apresente-a convertida em graus Fahrenheit. A formula de conversão é.
F = (9*C+160)/5
algoritmo &quot;celsius para fahrenheit&quot;
var
celsius, fahrenheit : real
inicio
escreva (&quot;digete em grau e celsius&quot;)
leia (celsius)
fahrenheit <- (9*celsius+160)/5
escreva (&quot;graus em fahrenheit e&quot;, fahrenheit)
fimalgoritmo
F= temperatura em Fahrenheit e C= centigrafos 
Criar um aplicativo que leia o valor de uma hora e informe quantos minutos se passaram desde inicio do dia ate aquela hora.
algoritmo &quot;horas&quot;
var
horas, minutos : real
inicio
escreva (&quot;que horas sao?&quot;)
leia (horas)
minutos <- (horas*60)
escreva (&quot;ja se passaram&quot;, minutos, &quot;minutos&quot;)
fimalgoritmo
Criar um aplicativo que leia o peso de uma pessoa em quilograma. Calcule e exiba o peso da pessoa em grams e o novo peso em gramas. Se a pessoa engordar 12%
Em épocas de pouco dinheiro os comerciantes procuram aumentar suas vendas oferecendo desconto. Faça um aplicativo que possa entrar om o valor de um produto e exiba o novo valor tendo em vista que o desconto foi de 9%
algoritmo &quot;desconto&quot;
var
produto, desconto : real
inicio
escreva (&quot;digite o valor do produto&quot;)
leia (produto)
desconto <- (0.91*produto)
escreva (&quot;o valor do produto e&quot;, desconto)
fimalgoritmo
Uma conta de caderneta de poupaçafoi aberta com um deposito de R$500,00. Faça um programa que calcule o valor do saldo da conta após cinco meses. Considerando que a conta é remunerada em 1,2% de juros ao mês.
Determinar a quantidade de litros de combustível gastos em uma viagem por um automóvel que faz 12Km/l. para isso sabe-se que o tempo gasto na viagem é t= 35min e a velocidade media do automóvel e v= 80km/h
Faça um programa para ler valores para as variáveis inteiras A e B. Efetuar a troca dos valores de forma que a variável A passe a possuir o valor da variável B e que a variável B passe a possuir o valor da variável A. Apresentar os valores iniciais e valores finais de A e B.
Tendo como dados de entrada a distancia total (em km) percorrida por um automóvel e a quantidade de combustível (em litros) consumida para percorre-la. Calcule e imprima o consumo médio de combustível.
algoritmo &quot;consumo medio&quot;
var
km, litro, consumo_medio : real
inicio
escreva (&quot;distancia pencorrida&quot;)
leia (km)
escreva (&quot;quantidade de litros&quot;)
leia (litro)
consumo_medio <- (km/litro)
escreva (&quot;o consumo medio e&quot;, consumo_medio)
fimalgoritmo
algoritmo &quot;media&quot;
var
nota1, nota2, nota3, nota4, media : real
contador, qtd : inteiro
inicio
escreval (&quot;digite a quantidade de alunos&quot;)
leia (qtd)
contador <- 0
enquanto contador < qtd faca
contador <- contador + 1
escreval (&quot;digite a primeira nota&quot;)
leia (nota1)
escreval (&quot;digite a segunda nota&quot;)
leia (nota2)
escreval (&quot;digite a terceira nota&quot;)
leia (nota3)
escreval (&quot;digite a quarta nota&quot;)
leia (nota4)
media <- (nota1+nota2+nota3+nota4)/4
 se media >= 7 entao
 escreval (&quot;aprovado com a media: &quot;, media)
 senao
 se media < 4.5 entao
 escreval (&quot;reprovado com a media: &quot;, media)
 senao
 escreval (&quot;recuperacao com a media: &quot;, media)
 fimse
 fimse
fimenquanto
fimalgoritmo