A maior rede de estudos do Brasil

Grátis
4 pág.
AV2 » ALGORITMOS

Pré-visualização | Página 1 de 1

Avaliação: CCT0239_AV2_201301218821 » ALGORITMOS
Tipo de Avaliação: AV2
Aluno: 201301218821 - CARLA HELENA MARTINS VELOZO 
Professor:
JANE TAVARES ALVAREZ DA SILVA
RICARDO CEZAR OLIVEIRA DAMASCENO
Turma: 9009/AI
Nota da Prova: 3,0 de 8,0 Nota do Trabalho: Nota de Participação: 2 Data: 15/06/2013 10:11:30
1a Questão (Cód.: 16557) Pontos:0,5 / 0,5
Qual das sentença em C++ a seguir verifica se o valor da variável x do tipo inteiro é diferente de 7 e maior que 
10?
if (x == 7 || x <= 10)
if (x != 7 && x > 10)
if (x != 7 || x >= 10)
if (x == 7 && x > 10)
if (x != 7 || x > 10)
2a Questão (Cód.: 10261) Pontos:0,0 / 0,5
Indique qual o comando que deve ser usado em um algoritmo quando se deseja repetir um bloco de 
comandos a partir de uma condição.
else
se encadeado
se
enquanto
var
3a Questão (Cód.: 49002) Pontos:0,0 / 1,5
Implemente um programa em C que receba o primeiro termo e a razão de uma P.A. e liste seus 30 primeiros 
termos, lembrando-se que um termo de uma P.A é gerado pela soma do termo anterior com a razão.
Resposta:
Gabarito: int main() { 
float a,r; 
int i; 
cout << "Entre com o primeiro termo e a razão de uma P.A.:"; 
cin >> a >> r; 
cout << "30 Primeiros termos da P.A.:"; 
for(i=1;i<=30;i++) { cout << a << " "; a+=r; } 
system("pause"); } 
Página 1 de 4BDQ Prova
20/06/2013http://bquestoes.estacio.br/prova_resultado_preview_aluno.asp?cod_hist_prova=3243...
4a Questão (Cód.: 10355) Pontos:1,0 / 1,0
O algoritmo a seguir representa a seleção de candidatos a um concurso público que exigiu duas avaliações. 
Suponha que um determinado candidato obteve 7,0 na primeira avaliação, escolha a alternativa CORRETA que 
indica qual a nota que o candidato deve obter na segunda avaliação para que ele seja aprovado, sabendo-se que 
não há arredondamento no cálculo da média.
Algoritmo Concurso
real: nota1,nota2,media
inicio
 escreva("Digite as duas notas:")
 leia(nota1,nota2)
 media<- (nota1+nota2)/2
 se (media >= 8) então
 escreva ("APROVADO")
 senao
 escreva ("REPROVADO")
 fim_se
fim 
Entre 6,0 e 6,9
Entre 8,0 e 8,9
Candidato reprovado
Entre 7,0 e 7,9
Entre 9,0 e 10,0
5a Questão (Cód.: 94188) Pontos:0,0 / 1,0
Analise o código mostrado na figura abaixo e assinale a alternativa que descreve corretamente a sua execução:
Nada será escrito na tela
A palavra "Algoritmos" será escrita diversas vezes na tela, separadas por espaço
A palavra "Algoritmos" será escrita na tela de trás pra frente
A palavra "Algoritmos" será escrita na tela normalmente, em texto corrido, conforme se escreve
A palavra "Algoritmos" será escrita na tela verticalmente, uma letra em cada linha
6a Questão (Cód.: 15032) Pontos:0,0 / 0,5
Página 2 de 4BDQ Prova
20/06/2013http://bquestoes.estacio.br/prova_resultado_preview_aluno.asp?cod_hist_prova=3243...
São considerados comandos condicionais de repetição na linguagem Portugol:
Enquanto, Repita e Para
Escreva e Leia
Se, Escolha, Enquanto e Para
Se e escolha
Se, Escolha, Escreva e Leia
7a Questão (Cód.: 10248) Pontos:0,5 / 0,5
Suponha um algoritmo desenvolvido em linguagem C++. 
Em uma determinda linha aparece o comando CONT = (CONT + 1);
Neste caso, o que é executado? 
CONT recebe o valor 1
CONT recebe o valor zero
CONT recebe o próprio valor acrescido de uma unidade 
CONT permanece inalterado
CONT recebe o próprio valor decrescido de uma unidade 
8a Questão (Cód.: 10573) Pontos:0,5 / 0,5
Interprete o algoritmo abaixo e informe o valor final da variável X.
Início
Inteiro: X;
 X 
��3;
 Se X < 4 então
 X 
��0;
 Senão
 X 
��X+7;
 Fim Se;
Fim.
3
4
0
1
10
Página 3 de 4BDQ Prova
20/06/2013http://bquestoes.estacio.br/prova_resultado_preview_aluno.asp?cod_hist_prova=3243...
9a Questão (Cód.: 49031) Pontos:0,0 / 1,5
Um número primo é aquele que é divisível apenas por um ou por si mesmo. Implemente um programa em C++ 
que receba um número inteiro, verifique e informe se o mesmo é um número primo.
Resposta: #include < iostream>#include <cstring>using namespace std:int main {}{int a , numcout<< ("Digite 
um numero inteiro\n:");float>>numse ((num % 1 == num) || (num % num == 1)cout<< ("numero 
primo\n");senaocout<<("numero não é inteiro\n");system ("Pause");}
Gabarito:
int main() {
 int x, i, c=0; 
cout << "Entre com um número inteiro:"; 
cin >> x;
for(i=1;iif(x % i == 0) { 
c++; 
} 
} 
if(c==1) { cout << "Valor eh numero primo\n"; } 
else { cout << "Valor NAO eh numero primo\n"; 
} system("pause"); } 
10a Questão (Cód.: 15070) Pontos:0,5 / 0,5
De acordo com o trecho de código abaixo o que será exibido se o usuário digitar os valores 2 e 4, respectivamente?
leia(n1,n2)
se ((n1 < 2) e (n2 < 5 )) entao
 escreva("O valor foi: ", n1)
senao 
 se ((n1 > 1) e (n2 > 4) ) entao
 escreva ("O valor foi: ", n1+2 )
 senao
 se ((n1 > 3) ou (n2 < 10)) entao
 escreva("O valor foi: ", n2+n1)
 senao
 escreva("O valor foi: ", 5)
 fimse
 fimse
fimse
O valor foi:4
O valor foi:6
Nenhuma das alternativas anteriores
O valor foi:2
O valor foi:5
Período de não visualização da prova: desde 03/06/2013 até 18/06/2013.
Página 4 de 4BDQ Prova
20/06/2013http://bquestoes.estacio.br/prova_resultado_preview_aluno.asp?cod_hist_prova=3243...