Avaliação On Line 3 (AOL 3)   .
6 pág.

Avaliação On Line 3 (AOL 3) .


DisciplinaLógica de Programação e Algoritmos2.904 materiais33.145 seguidores
Pré-visualização2 páginas
20/08/2017 Revisar envio do teste: Avaliação On-Line 3 (AOL 3) - ...
https://sereduc.blackboard.com/webapps/assessment/review/review.jsp?attempt_id=_1395482_1&course_id=_6662_1&content_id=_396670_1&r\u2026 1/6
 Unidade 2 Revisar envio do teste: Avaliação On-Line 3 (AOL 3) - QuestionárioH
Revisar envio do teste: Avaliação On-Line 3 (AOL 3) -
Questionário
Usuário Thiago de Lima Alves
Curso 2811 . 7 - Lógica de Programação Algorítmica - 20172.A
Teste Avaliação On-Line 3 (AOL 3) - Questionário
Iniciado 20/08/17 14:51
Enviado 20/08/17 15:02
Status Completada
Resultado
da
tentativa
10 em 10 pontos 
Tempo
decorrido
10 minutos
Instruções Atenção! Você terá 1 opção de envio. Você pode salvar e retornar quantas vezes desejar,
pois a tentativa só será contabilizada quando você decidir acionar o botão ENVIAR.
Após o envio da atividade, você poderá conferir sua nota e o feedback, acessando o
menu lateral esquerdo (Notas).
IMPORTANTE: verifique suas respostas antes do envio desta atividade.
Resultados
exibidos
Todas as respostas, Respostas enviadas, Respostas corretas, Perguntas respondidas
incorretamente
Pergunta 1
Nas mais diversas linguagens, costumamos encontrar o comando:x := x + valor. A função
dessa variável X é :
Resposta Selecionada: e. Funcionar como um acumulador
Respostas: a. Armazenar o menor valor
b. Contabilizar uma média
c. Armazenar o maior valor
d. Funcionar como um contador
e. Funcionar como um acumulador
Pergunta 2
Em vários programas de computador, tanto podemos encontrar o comando x := x + 1
quanto o comando x++ . Quanto esse tipo de comando é encontrado, a variável x está
fazendo o papel de:
Disciplinas Cursos
1 em 1 pontos
1 em 1 pontos
Thiago de Lima Alves 1
20/08/2017 Revisar envio do teste: Avaliação On-Line 3 (AOL 3) - ...
https://sereduc.blackboard.com/webapps/assessment/review/review.jsp?attempt_id=_1395482_1&course_id=_6662_1&content_id=_396670_1&r\u2026 2/6
Resposta Selecionada: d. Contador
Respostas: a. Acumulador
b. Maior valor
c. Menor valor
d. Contador
e. Média
Pergunta 3
As alternativas abaixo tratam da linguagem utilizada no Visualg. Qual delas não
corresponde à verdade?
Resposta
Selecionada:
e.
No visualg, o comando PARA usa uma variável de controle do tipo caracter (ou
literal)
Respostas: a.
O comando SE... Então...Senao....Fimse (ou IF em outras linguagens) permite
variar a resposta que o algoritmo dá dependendo do dado que foi inserido e do
resultado da sentença lógica, podendo ser usado mais de uma vez no programa
b.
O comando PARA, no visualg e em outras linguagens, normalmente permite
mudar o passo da variável de controle, podendo ser 1, 2 ou qualquer outro valor
inteiro
c.
O comando PARA equivale ao FOR em outras linguagens, que podem ser mais
ou menos detalhadas ou flexíveis em relação ao visualg
d.
O comando ENQUANTO (ou while em outras linguagens) pode ser usado em
repetições do tipo indeterminado ou determinado
e.
No visualg, o comando PARA usa uma variável de controle do tipo caracter (ou
literal)
Pergunta 4
Analise o algoritmo abaixo, execute no visualg e escolha a alternativa correta:Var 
 
I : inteiro 
Inicio 
 
Para i:=1 ate 10 faca 
 escreval(\u201ci\u201d) 
Fimpara 
Resposta Selecionada: c. O algoritmo exibe o texto \u201ci\u201d 10 vezes.
Respostas: a. O algoritmo exibe a média de números entre 1 e 10.
b. O algoritmo exibe a soma de 1 a 10.
c. O algoritmo exibe o texto \u201ci\u201d 10 vezes.
d. O algoritmo exibe os números de 10 a 1.
1 em 1 pontos
1 em 1 pontos
20/08/2017 Revisar envio do teste: Avaliação On-Line 3 (AOL 3) - ...
https://sereduc.blackboard.com/webapps/assessment/review/review.jsp?attempt_id=_1395482_1&course_id=_6662_1&content_id=_396670_1&r\u2026 3/6
e. O algoritmo roda normalmente exibindo os números de 1 a 10.
Pergunta 5
Em programas de computador, costumamos encontrar comandos onde se divide um
acumulador(total) por um contador(qtd), como no comando abaixo.
X := total / qtd
Normalmente, nesse caso, a variável X está fazendo um papel de:
Resposta Selecionada: e. Média
Respostas: a. Menor valor
b. Acumulador
c. Maior valor
d. Contador
e. Média
Pergunta 6
Observe o algoritmo abaixo e escolha a alternativa correta:
ALGORITMO \u201cLENDONOMES\u201d
VAR
 
I : inteiro
nome : literal
Inicio
 
Para i:=1 ate 5 faca
 Escreval(\u201cinforme nome\u201d)
leia(nome)
Fimpara
 
Para i:=1 ate 5 faca
 Escreval(\u201cnome cadastrado :\u201d , nome)
Fimpara
FIMALGORITMO
Resposta
Selecionada:
b.
O algoritmo lista os nomes, mas vai mostrar apenas o último nome
cadastrado cinco vezes.
Respostas: a.
1 em 1 pontos
1 em 1 pontos
20/08/2017 Revisar envio do teste: Avaliação On-Line 3 (AOL 3) - ...
https://sereduc.blackboard.com/webapps/assessment/review/review.jsp?attempt_id=_1395482_1&course_id=_6662_1&content_id=_396670_1&r\u2026 4/6
Nesse algoritmo são recebidos cinco nomes que ficam armazenados
podendo ser listados posteriormente.
b.
O algoritmo lista os nomes, mas vai mostrar apenas o último nome
cadastrado cinco vezes.
c. Esse algoritmo usa um vetor na sua listagem.
d. 
A variável nome deveria ser real.
 
 
e. O uso de um vetor não seria apropriado nesse caso.
Pergunta 7
Leia o trecho de programa no Visualg abaixo e selecione a alternativa correta:
var
 
i: inteiro
 
inicio
 
Para i:=1000 ate 1 faca
 
escreval(i + 30)
 
fimpara
Resposta
Selecionada:
a.
 O programa inicia uma contagem e termina rapidamente, pois o valor inicial é
maior que o final - na hora em que for executado não vai mostrar nada.
Respostas: a.
 O programa inicia uma contagem e termina rapidamente, pois o valor inicial é
maior que o final - na hora em que for executado não vai mostrar nada.
b. O programa faz um somatório com a variável i.
c. O programa conta de 1000 até 1, ou seja, de trás pra frente, de 30 em 30.
d. O i é uma variável para cálculo de média.
e. O programa não vai rodar, pois a variável I deveria ser real e não inteira
Pergunta 8
Num determinado programa de computador, você encontrou o comando abaixo:
x := x + valor
 
Nesse algoritmo, a variável x está fazendo o papel de: 
1 em 1 pontos
1 em 1 pontos
20/08/2017 Revisar envio do teste: Avaliação On-Line 3 (AOL 3) - ...
https://sereduc.blackboard.com/webapps/assessment/review/review.jsp?attempt_id=_1395482_1&course_id=_6662_1&content_id=_396670_1&r\u2026 5/6
Resposta Selecionada: e. acumulador
Respostas: a. contador
b. média
c. menor valor.
d. maior valor.
e. acumulador
Pergunta 9
Analise o algoritmo abaixo e em seguida, escolha a alternativa correta. Esse algoritmo
inicia, executa, mas não faz o que deveria, que é contar regressivamente de 500 até 400,
recuando de 5 em 5. Porque isso acontece? 
ALGORITMO \u201cteste\u201d
VAR
I : inteiro
Inicio
 Para i:=500 ate 400 passo 5 faca
 Escreval(i)
 Fimpara 
 FIMALGORITMO
Resposta Selecionada: b. Porque o passo está positivo e deveria ser negativo
Respostas: a. Porque a variável passo deveria ser declarada
b. Porque o passo está positivo e deveria ser negativo
c. Porque o passo deveria ser real
d. Porque a variável I deveria ser real
e. Porque a variável \u201c i \u201d deveria iniciada com 5 e não 500
Pergunta 10
Num determinado programa de computador, você encontrou o comando
abaixo:
x := total / qtd
 
Nesse algoritmo, a variável x está fazendo o papel de:
Resposta Selecionada: c. média
Respostas: a. maior valor.
1 em 1 pontos
1 em 1 pontos
20/08/2017 Revisar envio do teste: Avaliação On-Line 3 (AOL 3) - ...
https://sereduc.blackboard.com/webapps/assessment/review/review.jsp?attempt_id=_1395482_1&course_id=_6662_1&content_id=_396670_1&r\u2026 6/6
Domingo, 20 de Agosto de 2017 15h02min45s BRT
b. menor valor.
Ariadne
Ariadne fez um comentário
Você tem o questionario da AOL2
0 aprovações
Carregar mais