Estrutura condicional Algoritmo
7 pág.

Estrutura condicional Algoritmo


DisciplinaAlgoritmo e Programação1.227 materiais12.953 seguidores
Pré-visualização1 página
Respostas: 
1- 
var
 a, b, c : real
inicio
escreval ("informe o primeiro número: ")
leia (a)
escreval ("informe o segundo número: ")
leia (b)
escreval ("informe o terceiro número: ")
leia (c)
se(a + b < c) entao
escreval(&quot;A soma dos dois primeiros números é menor que o terceiro número.&quot;)
senao
escreval(&quot;A soma dos dois primeiros números é maior que o terceiro número.&quot;)
fimse
fimalgoritmo
2- 
var
 nome, sexo, civil : literal
 temp : caractere
inicio
escreval (&quot;informe o seu nome: &quot;)
leia (nome)
escreval (&quot;informe o seu sexo: &quot;)
leia (sexo)
escreval (&quot;informe o seu estado civil: &quot;)
leia (civil)
se(sexo = &quot;f&quot;)e (civil = &quot;casada&quot;) entao
escreval(&quot;Informe o tempo de casada&quot;)
leia (temp)
escreval(&quot;Obrigado&quot;)
senao
escreval(&quot;Obrigado&quot;)
fimse
fimalgoritmo
3- 
var
 num : inteiro
inicio
escreval (&quot;Digite um número: &quot;)
leia (num)
se num mod 2 = 0 entao
escreval(&quot;Esse número é par: &quot; ,num)
senao
escreval(&quot;Esse número é impar: &quot; ,num)
fimse
fimalgoritmo
4-
var
 a, b, c : inteiro
inicio
escreval (&quot;Digite um número: &quot;)
leia (a)
escreval (&quot;Digite outro número: &quot;)
leia (b)
se a = b entao
c <- a + b
escreval(&quot;A soma desses dois números é: &quot; ,c)
senao
c <- a * b
escreval(&quot;A multiplicação desses dois números é: &quot; ,c)
fimse
fimalgoritmo
5-
var
 num, resul : inteiro
inicio
escreval (&quot;Digite um número: &quot;)
leia (num)
se num > 0 entao
resul <- num * 2
escreval(&quot;O dobro desse número é: &quot; ,resul)
senao
resul <- num * 3
escreval(&quot;O triplo desse número é: &quot; ,resul)
fimse
fimalgoritmo
6- 
var
 num1, num2 : inteiro
inicio
escreval (&quot;Digite um número: &quot;)
leia (num1)
escreval (&quot;Digite outro número: &quot;)
leia (num2)
se (num1 > num2) entao
escreval(&quot;Verdadeiro, o primeiro número é maior &quot;)
fimse
se (num2 > num1) entao
escreval(&quot;Falso, o primeiro número não é maior&quot;)
fimse
se (num1 = num2) entao
escreval(&quot;Números iguais!&quot;)
fimse
fimalgoritmo
7 \u2013 
var
num1, num2 : inteiro
inicio
escreval (&quot;Digite um número: &quot;)
leia (num1)
se num1 mod 2 = 0 entao
num2 <- num1 + 5
escreval(&quot;A soma do número digitado + 5 é:&quot; ,num2)
senao
num2 <- num1 + 8
escreval(&quot;A soma do número digitado + 8 é:&quot; ,num2)
fimse
fimalgoritmo
8 \u2013 
var
n1,n2,n3 : inteiro
inicio
escreval(&quot;Informe o primeiro número: &quot;)
leia(n1)
escreval(&quot;Informe o segundo número: &quot;)
leia(n2)
escreval(&quot;Informe o terceiro número: &quot;)
leia(n3)
Se (n1 > n2) e (n2 > n3) entao
escreval(&quot; Ordem decrescente dos números: &quot;,n1, n2, n3)
senao
fimse
Se (n1 > n3) e (n3> n2) entao
escreval(&quot; Ordem decrescente dos números: &quot;,n1, n3, n2)
senao
fimse
Se (n2 > n1) e(n1> n3) entao
escreval(&quot; Ordem decrescente dos números: &quot;,n2, n1, n3)
senao
fimse
Se (n2 > n3) e (n3> n1) entao
escreval(&quot; Ordem decrescente dos números: &quot;,n2, n3, n1)
senao
fimse
Se (n3 > n2) e (n2 > n1) entao
escreval(&quot; Ordem decrescente dos números: &quot;,n3, n2, n1)
Senao
fimse
Se (n3 > n1) e (n1 > n2) entao
escreval(&quot; Ordem decrescente dos números: &quot;,n3, n1, n2)
fimse
fimalgoritmo
9 \u2013
var
alt, ideal : real
sexo, nome : caractere
inicio
escreval(&quot;Olá! Qual é o seu nome? &quot;)
leia(nome)
escreval(nome, &quot; qual seu sexo? F ou M? &quot;)
leia(sexo)
escreval(nome, &quot; qual é a sua altura? (inclua o ponto): &quot;)
leia(alt)
Se (sexo = &quot;M&quot;) entao
ideal <- (72.7 * alt)- 58
escreval(nome, &quot; seu peso ideal seria: &quot;,ideal)
senao
fimse
Se (sexo = &quot;F&quot;) entao
ideal <- (62.1 * alt)- 44.7
escreval(nome, &quot; seu peso ideal seria: &quot;,ideal)
fimse
fimalgoritmo
10 \u2013
var
alt, peso, IMC : real
inicio
escreval(&quot;Por favor informe sua altura? (inclua o ponto): &quot;)
leia(alt)
escreval(&quot;Qual é o seu peso? (inclua o ponto): &quot;)
leia(peso)
IMC <- peso / (alt * alt)
Se (IMC <= 18.4) entao
escreval(&quot;Está abaixo do peso: &quot;, IMC)
senao
fimse
Se (IMC >= 18.5) e (IMC <= 25) entao
escreval(&quot;Está no peso normal: &quot;, IMC)
senao
fimse
Se (IMC >= 26) e (IMC <= 30) entao
escreval(&quot;Está no peso normal: &quot;, IMC)
senao
fimse
Se (IMC >= 31) entao
escreval(&quot;Está com obesidade: &quot;, IMC)
fimse
fimalgoritmo
Aluna: Cristiane Iraci Rosa  (DP)
RA: 8786733