Algoritmos da Rota de Aprendizagem
48 pág.

Algoritmos da Rota de Aprendizagem


DisciplinaLógica de Programação6.196 materiais48.003 seguidores
Pré-visualização4 páginas
escreva("Digite um numero inteiro para iniciar:") 
 leia(ni) 
 escreva("Digite um numero inteiro para finalizar:") 
 leia(nf) 
 
 para i de ni ate nf faca 
 
 resto<-i mod 2 
 se(resto=0) entao 
 escreval(i, &quot; - par&quot;) 
 senao 
 escreval(i, &quot; - impar&quot;) 
 fimse 
 
 fimpara 
 
fimalgoritmo 
 
algoritmo &quot;Quadrado&quot; 
// Seção de Declarações 
var 
 lado, area: real 
 
inicio 
// Seção de Comandos 
 escreval(&quot;Digite o valor para um lado: &quot;) 
 leia(lado) 
 area<-lado*lado 
 escreval(&quot;Area do quadrado=&quot;,area) 
 
fimalgoritmo 
 
 
algoritmo &quot;quadrados&quot; 
// Seção de Declarações 
var 
n,i:inteiro 
soma,valor:real 
 
inicio 
// Seção de Comandos 
 
escreval(&quot;Soma dos Quadrados&quot;) 
 
escreval(&quot;&quot;) 
escreval(&quot;Digite o número de valores:&quot;) 
leia(n) 
escreval(&quot;&quot;) 
 
soma<-0 
para i de 2 ate n faca 
 escreval(&quot;Digite um valor:&quot;) 
 leia(valor) 
 soma<-soma+(valor*valor) 
fimpara 
 
escreval(&quot;Soma dos quadrados=&quot;,soma) 
 
fimalgoritmo 
 
algoritmo &quot;Triangulo&quot; 
// Função : identificar tipo de triangulo 
// Autor : Profa. Maristela. 
// Data : 11/01/2015 
// Seção de Declarações 
var 
 a,b,c: real 
 
inicio 
// Seção de Comandos 
 escreval(&quot;Digite o valor para 3 lados de um triangulo: &quot;) 
 leia(a) 
 leia(b) 
 leia(c) 
 
 se (a<b+c) ou (b<a+c) ou (c<a+b) entao 
 escreval(&quot;E um triangulo!!&quot;) 
 se (a=b) e (b=c) entao 
 escreval(&quot;Triangulo Equilatero&quot;) 
 senao 
 se ((a=b) e (b<>c)) ou ((a=c) e (c<>b)) ou ((b=c) e (c<>a)) entao 
 escreval(&quot;Triangulo Isosceles&quot;) 
 senao 
 escreval(&quot;Triangulo Escaleno&quot;) 
 fimse 
 fimse 
 senao 
 escreval(&quot;Nao e um triangulo!!&quot;) 
 fimse 
 
fimalgoritmo 
 
algoritmo &quot;vol-esfera&quot; 
// Função : Calcular o volume de uma esfera 
// Autor : Profa. Maristela. 
// Data : 11/01/2015 
// Seção de Declarações 
var 
 V,r: real 
 
inicio 
// Seção de Comandos 
 escreval(&quot;Digite o valor do raio: &quot;) 
 leia(r) 
 
 V<-4/3*(Pi*r^3) 
 
 escreval(&quot;&quot;) 
 escreva(&quot;O volume eh:&quot;,V) 
 
fimalgoritmo 
 
algoritmo &quot;primo&quot; 
// Função : Identificar se o número é primo 
// Autor : Prof. Maristela. 
// Data : 3/20/2015 
// Seção de Declarações 
var 
 
 numero, resto, qt_restos, i: inteiro 
inicio 
// Seção de Comandos 
//vamos trocar a entrada de um número pela 
//entrada de um numero inicial e um numero final ok? 
 
 resto<-0 
 qt_restos<-0 
 escreva(&quot;Digite um numero:&quot;) 
 leia(numero) 
 
 para i de 1 ate numero faca 
 
 resto<- numero mod i 
 se (resto=0) entao 
 qt_restos<-qt_restos+1 
 fimse 
 //escreval(&quot;resto= &quot;, resto) 
 
 fimpara 
 se (qt_restos=2) entao 
 escreva(&quot;O numero &quot;,numero, &quot; e primo&quot;) 
 senao 
 escreva(&quot;O numero &quot;,numero, &quot; nao e primo&quot;) 
 fimse 
 
fimalgoritmo 
 
algoritmo &quot;qprimo&quot; 
// Função : Contar quantos números primos há entre os valores digitados 
// Autor : Prof. Maristela. 
// Data : 3/20/2015 
// Seção de Declarações 
var 
 
 numero, resto, qt_restos, i: inteiro 
inicio 
// Seção de Comandos 
//vamos trocar a entrada de um número pela 
//entrada de um numero inicial e um numero final ok? 
 
 
 numero<-1 
 enquanto (numero<>0) faca 
 
 resto<-0 
 qt_restos<-0 
 escreval(&quot;Digite um numero (Caso deseje encerrar, digite 0 (zero):&quot;) 
 leia(numero) 
 
 para i de 1 ate numero faca 
 
 resto<- numero mod i 
 se (resto=0) entao 
 qt_restos<-qt_restos+1 
 fimse 
 fimpara 
 
 se (qt_restos=2) entao 
 escreval(&quot;O numero &quot;,numero, &quot; e primo&quot;) 
 senao 
 escreval(&quot;O numero &quot;,numero, &quot; nao e primo&quot;) 
 fimse 
 
fimenquanto 
 
fimalgoritmo 
 
algoritmo &quot;par_impar&quot; 
// Função : Identificar numeros pares ou ímpares 
// Autor : Prof. Maristela. 
// Data : 3/20/2015 
// Seção de Declarações 
var 
 n,i:inteiro 
 valor,soma:real 
inicio 
// Seção de Comandos 
//vamos trocar a entrada de um número pela 
//entrada de um numero inicial e um numero final ok? 
 
 escreva(&quot;Digite a quantidade de valores:&quot;) 
 leia(n) 
 
 para i de 1 ate n faca 
 
 escreva(&quot;Digite um valor:&quot;) 
 leia(valor) 
 se (valor>=0) entao 
 soma<-soma+valor 
 fimse 
 
 fimpara 
 escreva(&quot;A soma dos valores positivos e: &quot;, soma) 
 
fimalgoritmo 
 
algoritmo &quot;fatorial&quot; 
// Função : calcular o fatorial de um numero qualquer 
// Autor : Maristela 
// Data : 3/24/2015 
// Seção de Declarações 
var 
 fat, n, i, ant: inteiro 
inicio 
// Seção de Comandos 
 fat<-0 
 ant<-1 
 escreva(&quot;Digite um numero qualquer:&quot;) 
 leia(n) 
 
 para i de 1 ate n faca 
 fat<-i*ant 
 ant<-fat 
 fimpara 
 escreva(&quot;Fatorial de &quot;,n, &quot; e = &quot;,fat) 
 
fimalgoritmo 
 
algoritmo &quot;par_impar&quot; 
// Função : Maior e menor de 50 
// Autor : Prof. Maristela. 
// Data : 3/20/2015 
// Seção de Declarações 
var 
 i:inteiro 
 maior, menor, valor:real 
inicio 
// Seção de Comandos 
//vamos trocar a entrada de um número pela 
//entrada de um numero inicial e um numero final ok? 
 
 maior<-0 
 menor<-999999999999 
 
 para i de 1 ate 5 faca 
 
 escreva(&quot;Digite um valor:&quot;) 
 leia(valor) 
 se (valor>maior) entao 
 maior<-valor 
 fimse 
 se (valor<menor) entao 
 menor<-valor 
 fimse 
 
 fimpara 
 escreval(&quot;O maior valor digitado e: &quot;, maior) 
 escreval(&quot;O menor valor digitado e: &quot;, menor) 
 
fimalgoritmo 
 
algoritmo &quot;par_impar&quot; 
// Função : Identificar numeros pares ou ímpares 
// Autor : Prof. Maristela. 
// Data : 3/20/2015 
// Seção de Declarações 
var 
 ni, nf,resto,i:inteiro 
inicio 
// Seção de Comandos 
//vamos trocar a entrada de um número pela 
//entrada de um numero inicial e um numero final ok? 
 
 escreva(&quot;Digite um numero inteiro para iniciar:&quot;) 
 leia(ni) 
 escreva(&quot;Digite um numero inteiro para finalizar:&quot;) 
 leia(nf) 
 
 para i de ni ate nf faca 
 
 resto<-i mod 2 
 se(resto=0) entao 
 escreval(i, &quot; - par&quot;) 
 senao 
 escreval(i, &quot; - impar&quot;) 
 fimse 
 
 fimpara 
 
fimalgoritmo 
algoritmo &quot;temperatura&quot; 
// Função : Farenheit para Celsius 
// Autor : Prof. Maristela. 
// Data : 3/20/2015 
// Seção de Declarações 
var 
 
 i : inteiro 
 resp:caracter 
 c: vetor [1..100] de real 
 f: vetor [1..100] de real 
 
inicio 
//seção de comandos 
 resp<-&quot;S&quot; 
 i<-1 
 enquanto (resp=&quot;S&quot;) faca 
 escreval(&quot;*** Entrada de Dados ***&quot;) 
 escreval(&quot;&quot;) 
 escreva(&quot;Digite a temperatura em Farenheit:&quot;) 
 leia(f[i]) 
 c[i]<-(f[i]-32)/1.8 
 escreval(&quot;&quot;) 
 escreval(&quot;Deseja continuar cadastrando? (S/N)&quot;) 
 leia(resp) 
 i<-i+1 
 limpatela 
 fimenquanto 
 
 limpatela 
 escreval(&quot;*** Relatorio de Saida de Temperaturas ***&quot;) 
 escreval(&quot;&quot;) 
 
 para i de 1 ate 100 faca 
 se ((f[i]=0) e (c[i]=0)) entao 
 i<-101 
 senao 
 escreval(&quot;Farenheit: &quot;,f[i]) 
 escreval(&quot;Celsius : &quot;,c[i]) 
 se(c[i]<5) entao 
 escreval(&quot;FRIO&quot;) 
 fimse 
 se((c[i]>=5) e(c[i]<25)) entao 
 escreval(&quot;AGRADAVEL&quot;) 
 fimse