Algoritmos da Rota de Aprendizagem
48 pág.

Algoritmos da Rota de Aprendizagem


DisciplinaLógica de Programação6.198 materiais48.035 seguidores
Pré-visualização4 páginas
se(c[i]>=25) entao 
 escreval("QUENTE") 
 fimse 
 
 escreval("--------------------------------------------------------------") 
 fimse 
 fimpara 
fimalgoritmo 
 
algoritmo "vetor_10" 
// Função : Incluir 10 números em um vetor e mostrá-los 
// Autor : Prof. Maristela. 
// Data : 3/20/2015 
// Seção de Declarações 
var 
 
 i,j,k : inteiro 
 v1 : vetor [1..10] de real 
 
inicio 
//seção de comandos 
 
 para i de 1 ate 10 faca 
 escreval("Digite um numero qualquer:") 
 leia(v1[i]) 
 fimpara 
 
 limpatela 
 
 para i de 1 ate 10 faca 
 escreval("v",i,": ",v1[i]) 
 fimpara 
fimalgoritmo 
 
algoritmo "vetor_10" 
// Função : Incluir 10 números em um vetor e mostrá-los 
// Autor : Prof. Maristela. 
// Data : 3/20/2015 
// Seção de Declarações 
var 
 
 i,j,k : inteiro 
 v1 : vetor [1..10] de real 
 
 aux: real 
 
inicio 
//seção de comandos 
 
 para i de 1 ate 10 faca 
 escreval("Digite um numero qualquer:") 
 leia(v1[i]) 
 fimpara 
 
 limpatela 
 
 aux<-v[1] 
 para i de 2 ate 10 faca 
 se (aux>v[i]) entao 
 aux<-v[i] 
 senao 
 
 aux = vetor[i]; 
 vetor[i] = vetor[j]; 
 vetor[j] = aux; 
 fimpara 
 
 para i de 1 ate 10 faca 
 escreval(&quot;v&quot;,i,&quot;: &quot;,v1[i]) 
 fimpara 
fimalgoritmo 
 
algoritmo &quot;vetor_10&quot; 
// Função : Incluir 10 números em um vetor e mostrá-los 
// Autor : Prof. Maristela. 
// Data : 3/20/2015 
// Seção de Declarações 
var 
 
 i,j,k : inteiro 
 v1 : vetor [1..10] de real 
 s1 : vetor [1..10] de real 
 rep1: vetor[1..10] de real 
 rep, maior, menor, media:real 
inicio 
//seção de comandos 
 
 para i de 1 ate 10 faca 
 escreval(&quot;Digite um numero qualquer:&quot;) 
 leia(v1[i]) 
 se (i>1) entao 
 s1[i]<-s1[i-1]+v1[i] 
 senao 
 s1[i]<-v1[i] 
 fimse 
 fimpara 
 
 limpatela 
 
 maior<-0 
 menor<-999999999 
 k<-0 
 para i de 1 ate 10 faca 
 escreval(&quot;v&quot;,i,&quot;: &quot;,v1[i]) 
 escreval(&quot;somatorio parcial&quot;,i,&quot;: &quot;,s1[i]) 
 se (v1[i]>maior) entao 
 maior<-v1[i] 
 fimse 
 se (v1[i]<menor) entao 
 menor<-v1[i] 
 fimse 
 
 para j de 1 ate 10 faca 
 se(v1[i]=rep1[j]) entao 
 escreval(&quot;Repetiu: &quot;, v1[i]) 
 k<-k+1 
 rep1[k]<-v1[i] 
 fimse 
 fimpara 
 
 fimpara 
 media<-s1[10]/10 
 escreval(&quot;Maior=&quot;,maior,&quot; Menor=&quot;,menor,&quot; Media=&quot;,media) 
fimalgoritmo 
 
algoritmo &quot;matriz_aut&quot; 
 
var 
 
 matriz:vetor[1..10,1..10] de inteiro 
 i,j,m,n:inteiro 
 
inicio 
 
escreval(&quot;***** Entrada de Dados *****&quot;) 
escreval(&quot;&quot;) 
escreva(&quot;Digite o numero de linhas e o numero de colunas para matriz:&quot;) 
leia(m,n) 
para i de 1 ate m faca 
 para j de 1 ate n faca 
 matriz[i,j]<-0 
 fimpara 
fimpara 
 
limpatela 
 
escreval(&quot;***** Resultados da matriz *****&quot;) 
para i de 1 ate m faca 
 para j de 1 ate n faca 
 //escreval(&quot;Linha:&quot;,i,&quot; Coluna:&quot;,j,&quot; Numero=&quot;,matriz[i,j]) 
 escreva(matriz[i,j]) 
 fimpara 
 escreval(&quot;&quot;) 
fimpara 
 
fimalgoritmo 
 
algoritmo &quot;matriz_aut&quot; 
 
var 
 
 matriz:vetor[1..10,1..10] de inteiro 
 i,j,m,n:inteiro 
 
inicio 
 
escreval(&quot;***** Entrada de Dados *****&quot;) 
escreval(&quot;&quot;) 
escreva(&quot;Digite o numero de linhas e o numero de colunas para matriz:&quot;) 
leia(m,n) 
para i de 1 ate m faca 
 para j de 1 ate n faca 
 se(i=1) entao 
 matriz[i,j]<-1 
 senao 
 matriz[i,j]<-0 
 fimse 
 fimpara 
fimpara 
 
limpatela 
 
escreval(&quot;***** Resultados da matriz *****&quot;) 
para i de 1 ate m faca 
 para j de 1 ate n faca 
 //escreval(&quot;Linha:&quot;,i,&quot; Coluna:&quot;,j,&quot; Numero=&quot;,matriz[i,j]) 
 escreva(matriz[i,j]) 
 fimpara 
 escreval(&quot;&quot;) 
fimpara 
 
fimalgoritmo 
 
algoritmo &quot;matriz_aut&quot; 
 
var 
 
 matriz:vetor[1..10,1..10] de inteiro 
 i,j,m,n:inteiro 
 
inicio 
 
escreval(&quot;***** Entrada de Dados *****&quot;) 
escreval(&quot;&quot;) 
escreva(&quot;Digite o numero de linhas e o numero de colunas para matriz:&quot;) 
leia(m,n) 
para i de 1 ate m faca 
 para j de 1 ate n faca 
 se(j=1) entao 
 matriz[i,j]<-1 
 senao 
 matriz[i,j]<-0 
 fimse 
 fimpara 
fimpara 
 
limpatela 
 
escreval(&quot;***** Resultados da matriz *****&quot;) 
para i de 1 ate m faca 
 para j de 1 ate n faca 
 //escreval(&quot;Linha:&quot;,i,&quot; Coluna:&quot;,j,&quot; Numero=&quot;,matriz[i,j]) 
 escreva(matriz[i,j]) 
 fimpara 
 escreval(&quot;&quot;) 
fimpara 
 
fimalgoritmo 
 
algoritmo &quot;matriz_par&quot; 
 
var 
 
 m:vetor[1..3,1..3] de inteiro 
 resto, qtpar,i,j:inteiro 
 
inicio 
 
qtpar <-0 
 
escreval(&quot;***** Entrada de Dados *****&quot;) 
escreval(&quot;&quot;) 
para i de 1 ate 3 faca 
 para j de 1 ate 3 faca 
 escreva(&quot;Digite um valor para linha:&quot;,i,&quot; coluna:&quot;,j,&quot;:&quot;) 
 leia(m[i,j]) 
 resto<-m[i,j] mod 2 
 se(resto=0) entao 
 qtpar<-qtpar+1 
 fimse 
 fimpara 
fimpara 
 
limpatela 
 
escreval(&quot;***** Resultados da matriz *****&quot;) 
para i de 1 ate 3 faca 
 para j de 1 ate 3 faca 
 resto<-m[i,j] mod 2 
 se(resto=0) entao 
 escreval(&quot;Linha:&quot;,i,&quot; Coluna:&quot;,j,&quot; Numero=&quot;,m[i,j]) 
 fimse 
 fimpara 
fimpara 
escreval(&quot;Quantidade de numeros pares: &quot;, qtpar) 
 
 
 
fimalgoritmo 
 
algoritmo &quot;Mult_matrizes&quot; 
// Função : Multiplicação de matrizes 
// Autor : Maristela. 
// Data : 06/04/2015 
// Seção de Declarações 
var 
 
 mat1: vetor [1..3,1..3] de inteiro //linha,coluna 
 mat2: vetor [1..3,1..3] de inteiro //linha,coluna 
 mat3: vetor [1..3,1..3] de inteiro //linha,coluna 
 
 m,n,l,c,i,j,acumula,k:inteiro 
 
inicio 
// Seção de Comandos 
 
escreval(&quot;***** Entrada de Dados *****&quot;) 
escreval(&quot;&quot;) 
escreva(&quot;Digite o numero de linhas e o numero de colunas para as matrizes:&quot;) 
leia(m) 
leia(n) 
para i de 1 ate m faca 
 para j de 1 ate n faca 
 escreva(&quot;Matriz 1: Digite um valor para linha: &quot;,i,&quot; coluna: &quot;,j,&quot;: &quot;) 
 leia(mat1[i,j]) 
 fimpara 
fimpara 
 
para i de 1 ate m faca 
 para j de 1 ate n faca 
 escreva(&quot;Matriz 2: Digite um valor para linha: &quot;,i,&quot; coluna: &quot;,j,&quot;: &quot;) 
 leia(mat2[i,j]) 
 fimpara 
fimpara 
limpatela 
 
//l<-1 
//c<-1 
 
escreval(&quot;***** Resultado *****&quot;) 
para i de 1 ate m faca 
 para j de 1 ate n faca 
 //mat3[i,j]<-((mat1[i,1]*mat2[1,j])+(mat1[i,2]*mat2[2,j])) 
 //mat3[i,j]<-((mat1[i,c]*mat2[l,j])+(mat1[i,c+1]*mat2[l+1,j])) 
 acumula<-0 
 para k de 1 ate n faca 
 acumula<-(acumula+(mat1[i,k]*mat2[k,j])) 
 fimpara 
 mat3[i,j]<-acumula 
 escreval(&quot;Matriz 3 &quot;,i , &quot; x &quot;,j , &quot; : &quot;, mat3[i,j]) 
 
 fimpara 
fimpara 
 
fimalgoritmo 
 
 
algoritmo &quot;temperatura&quot; 
// Função : Farenheit para Celsius 
// Autor : Prof. Maristela. 
// Data : 3/20/2015 
// Seção de Declarações 
var 
 
 i,j : inteiro 
 resp:caracter 
 temperatura: vetor [1..100,1..2] de real //linha,coluna 
 
inicio 
//seção de comandos 
 resp<-&quot;S&quot; 
 i<-1 
 enquanto (resp=&quot;S&quot;) faca 
 escreval(&quot;*** Entrada de Dados ***&quot;) 
 escreval(&quot;&quot;)