A maior rede de estudos do Brasil

Grátis
7 pág.
Portugol, algoritmos complexos - Pseudo-Código

Pré-visualização | Página 1 de 1

Algoritmos e Programação
Pseudo-código 2
Professor: Eduardo Campos dos Santos - eduardo.campos@prof.una.br
http://edusantos.eti.br/una
início
 declare a, b, c, d, r, r1, r2 numérico
 leia a, b, c
 se a = 0
 então
 escreva “Não é eq. do 2o grau”
 se b = 0
então
 escreva “Não é eq. do 1o grau”
senão
 r ← -c / b
 escreva r
 fim_se
 senão
 d ← b*b – 4*a*c
 se d < 0
então
 escreva “Não há raízes reais”
senão
 r1 ← (-b – sqrt (d)) / (2*a)
 r2 ← (-b + sqrt (d)) / (2*a)
 escreva r1, r2
 fim_se
 fim_se
fim
a,b,c
a = 0
d ←b*b - 4*a*c
d < 0
r1 ← (-b - sqrt(d)) / (2*a)
r2 ← (-b + sqrt(d)) / (2*a)
“Não é uma
equação do
2o grau.”
“Não há
raízes reais.”
fim
início
nãosim
nãosim
r
b = 0
não
sim
“Não é uma
equação do
1o grau.”
r ← -c / b
ax2+bx+c=0
r1, r2
 
n1
Início
Fim
n1, n2
algoritmo
 declare n1, n2 numérico
 declare repete literal
 
 repita 
 leia n1
 leia n2
 
 se n1 < n2
então
 escreva n1
 senão
 escreva n2
 fim_se
 escreva "Executar novamente? (s/n) "
 leia repete
 enquanto repete <> 'n'
 
fim_algoritmo
se n1 < n2
n2
repete <> 'n'
“Executar 
novamente? (s/n)”
V
F
repete
V F
 
algoritmo
 declare n1, n2 numérico
 declare repete literal
 
 repita 
 leia n1
 leia n2
 
 se n1 < n2
então
 escreva n1
 senão
 escreva n2
 fim_se
 escreva "Exec nov? (s/n) "
 leia repete
 enquanto repete <> 'n'
 
fim_algoritmo
 
Interprete o código
 
Interprete e compare com o anterior
 
	Slide 1
	Slide 2
	Slide 3
	Slide 4
	Slide 5
	Slide 6
	Slide 7

Crie agora seu perfil grátis para visualizar sem restrições.