EXAME OBJETIVA 100
14 pág.

EXAME OBJETIVA 100


DisciplinaLógica de Programação e Algoritmos2.853 materiais32.482 seguidores
Pré-visualização2 páginas
EXAME OBJETIVA 100%
Questão 1/10
Para o algoritmo abaixo, identifique qual a parte de código preencheria a lacuna em aberto. O algoritmo faz a distribuição dos números em outros dois vetores, um vetor só com o zero e os números positivos e outro só com números negativos:
algoritmo "vetores"
var
 
  i,j,k,n : inteiro
  v: vetor [1..50] de real
  vp: vetor [1..50] de real
  vn: vetor [1..50] de real
  
  aux: real
  
inicio
//seção de comandos
    escreval("Digite o número de elementos do vetor:")
   leia(n)
   para i de 1 ate n faca
     escreval("Digite um numero qualquer:")
     leia(v[i])
   fimpara
    limpatela
+-------------------------------------------------------------------------------------------------------------------------------+
+-------------------------------------------------------------------------------------------------------------------------------+
   escreval("Positivos:")
   para i de 1 ate k faca
      escreval(vp[i])
   fimpara
   
   escreval("Negativos:")
   para i de 1 ate j faca
      escreval(vn[i])
   fimpara
fimalgoritmo
	
	A
	 para i de 1 ate n faca
     se (v[i]>1) entao
        k<-k+1
        vp[k]<-v[i]
     senao
        j<-j+1
        vn[j]<-v[i]
     fimse
    fimpara
	
	B
	   k<-0
   j<-0
   para i de 1 ate n faca
     se (v[i]>=0) entao
        k<-k+1
        vp[k]<-v[i]
     senao
        j<-j+1
        vn[j]<-v[i]
     fimse
   fimpara
Você acertou!
	
	C
	para i de 1 ate n faca
     se (v[i]>0) entao
        k<-k+1
        vp[i]<-v[i]
     senao
        j<-j+1
        vn[i]<-v[i]
     fimse 
fimpara
	
	D
	k<-0
j<-0
para i de 1 ate n faca
     se (v[i]>0) entao
        vp[k]<-v[i]
     senao
        vn[j]<-v[i]
     fimse
   fimpara
Questão 2/10
Aproximando-nos da maneira pela qual o computador manipula as informações, os tipos primitivos básicos utilizados para construção de programas serão:
	
	A
	Sequência, condicional e repetição.
	
	B
	Sequência, seleção e repetição.
	
	C
	Inteiro, caracter, real e lógico.
Você acertou!
Slide 05 da Aula 03.
	
	D
	Inteiro, lógico, real e numérico.
Questão 3/10
Lógica de programação pode ser definida como o uso correto das leis do pensamento, da ordem da razão e de processos de raciocínio e simbolização formais na programação de computadores. É incorreto afirmar, ao se falar de lógica e lógica de programação, que:
	
	A
	Um dos principais objetivos é a racionalidade e o desenvolvimento de técnicas que cooperam na produção de soluções logicamente válidas e coerentes.
	
	B
	O mesmo raciocínio pode ser expresso em qualquer idioma existente, mas continuaria representando o mesmo raciocínio através de outra convenção.
	
	C
	Uma vez a lógica estruturada, poderíamos representá-la em qualquer linguagem de programação.
	
	D
	O raciocínio é algo concreto e tangível.
Você acertou!
Aula 01:
&quot;O raciocínio é algo abstrato e intangível, porém seres humanos têm a capacidade de expressá-lo através da palavra falada ou escrita, baseando-se num determinado idioma que segue regras e padrões gramaticais.&quot;
Questão 4/10
Para o algoritmo abaixo, qual é o código mais adequado a incluir para calcular a quantidade de números ímpares?
algoritmo &quot;matriz_par&quot;
var
 
  m:vetor[1..3,1..3] de inteiro
  resto, qtpar,i,j:inteiro
 
inicio
 
qtpar <-0
 
escreval(&quot;***** Entrada de Dados *****&quot;)
escreval(&quot;&quot;)
para i de 1 ate 3 faca
  para j de 1 ate 3 faca
       escreva(&quot;Digite um valor para linha:&quot;,i,&quot; coluna:&quot;,j,&quot;:&quot;)
       leia(m[i,j])
        resto<-m[i,j] mod 2
        se(resto=0) entao
           qtpar<-qtpar+1
        fimse
  fimpara
fimpara
 
limpatela
 
escreval(&quot;***** Resultados da matriz *****&quot;)
para i de 1 ate 3 faca
  para j de 1 ate 3 faca
     resto<-m[i,j] mod 2
     se(resto=0) entao
        escreval(&quot;Linha:&quot;,i,&quot; Coluna:&quot;,j,&quot; Numero=&quot;,m[i,j])
     fimse
  fimpara
fimpara
escreval(&quot;Quantidade de numeros pares: &quot;, qtpar)
 
 
 
fimalgoritmo
	
	A
	resto<-m[i,j] mod 2
se(resto<>0) entao
     qtimpar<-qtimpar+1
fimse
Você acertou!
	
	B
	resto<-m[i,j] mod 2
se(resto<>0) entao
     qtimpar<-qtimpar+m[i,j]
fimse
	
	C
	resto<-m[i,j] mod 2
se(resto=~0) entao
     qtimpar<-qtimpar+1
fimse
	
	D
	resto<-m[i,j] mod 2
se(resto=0) entao
     qtimpar<-qtimpar+1
fimse
Questão 5/10
Descrição narrativa consiste em analisar o enunciado do problema e escrever, utilizando uma linguagem natural (por exemplo, a língua portuguesa), os passos a serem seguidos para sua resolução. Existem vantagens e desvantagens, com as relacionadas nas opções a seguir, exceto:
	
	A
	Vantagem: não é necessário aprender nenhum conceito novo.
	
	B
	Vantagem: utiliza língua natural, a qual é bem conhecida.
	
	C
	Desvantagem: Dificuldade para transcrição do algoritmo para programa.
	
	D
	Desvantagem: só é possível escrevê-la em Língua Portuguesa.
Você acertou!
Slides das Aulas 01 e  02, e exemplos.
Questão 6/10
Na escrita de um algoritmo que calcule a média de três valores quaisquer, a melhor resolução escrita em descrição narrativa seria:
	
	A
	1-receber os três valores. 2 \u2013 calcular a média aritmética. 3-se a média for maior que 7 dizer que o aluno está aprovado. 4-mostrar a média.
	
	B
	1-receber os três valores. 2 \u2013 calcular a soma aritmética. 3-mostrar a soma aritmética. 4-mostrar a média.
	
	C
	1-receber os três valores. 2-calcular a média aritmética. 3-mostrar a média aritmética.
Você acertou!
Slides das Aulas 01 e 02 e exemplos apresentados.
	
	D
	1-receber os três valores. 2 \u2013 somar os três valores. 3-mostrar a média aritmética.
Questão 7/10
Para o algoritmo abaixo, qual deveria ser o resultado exibido para uma matriz 3X3?
algoritmo &quot;matriz&quot;
 
var
 
  matriz:vetor[1..10,1..10] de inteiro
  i,j,m,n:inteiro
 
inicio
 
escreval(&quot;***** Entrada de Dados *****&quot;)
escreval(&quot;&quot;)
escreva(&quot;Digite o numero de linhas e o numero de colunas para matriz:&quot;)
leia(m,n)
para i de 1 ate m  faca
  para j de 1 ate n faca
       escreva(&quot;Digite um valor para linha:&quot;,i,&quot; coluna:&quot;,j,&quot;:&quot;)
       matriz[i,j]<-i+1
  fimpara
fimpara
 
limpatela
 
escreval(&quot;***** Resultados da matriz *****&quot;)
para i de 1 ate m faca
  para j de 1 ate n faca
     escreva(matriz[i,j])
  fimpara
     escreval(&quot;&quot;)
fimpara
 
fimalgoritmo
	
	A
	1 1 1
2 2 2
3 3 3
	
	B
	2 2 2
3 3 3
4 4 4
Você acertou!
	
	C
	2 2 2
2 2 2
3 3 3
	
	D
	1 1 1
3 3 3
5 5 5
Questão 8/10
Para o algoritmo abaixo, identifique o melhor enunciado para o problema:
	
	A
	Faça um programa que receba um número positivo e maior que zero, calcule mostre:
O número recebido ao quadrado;
O número recebido ao cubo;
O dobro do número.
	
	B
	Faça um programa que receba um número qualquer, calcule mostre:
O número recebido ao quadrado;
O número recebido ao cubo;
O dobro do número.
Você acertou!
Slides e videoaula 03
	
	C
	Faça um programa que receba um número positivo e maior que zero, calcule mostre:
O número recebido ao quadrado;
O dobro do número.
O número recebido ao cubo;
	
	D
	Faça um programa que receba um número qualquer, calcule mostre:
O número recebido ao cubo;
O dobro do número.
O número recebido ao quadrado;
Questão 9/10
Para o algoritmo abaixo, identifique qual a parte de código representaria melhor a entrada dos dados:
	
	A
	escreval(&quot;Digite um valor o raio : &quot;)
   leia(raio)
escreval(\u201cDigite o valor de Pi:\u201d)
   leia(Pi)
	
	B
	escreval(&quot;Digite um valor o raio : &quot;)
   leia(raio)
Você acertou!
Slides e videoaula 03
	
	C
	escreval(&quot;Digite um valor o raio : &quot;)
   leia(raio)
escreval(\u201cDigite o valor de Pi:\u201d)
	
	D
	leia(raio)
Questão 10/10
Para o algoritmo abaixo, identifique a