24.set.2014-

24.set.2014-


DisciplinaAlgoritmo e Programação1.227 materiais12.954 seguidores
Pré-visualização1 página
algoritmo "Q_1_Aula_24_set_2014"
//função: Algoritmo que apartir da sua média e frequencia,
//verifique a mostre a situação final de um aluno:
//-> Se a média >= 7,0 e o numero de faltas <= 25%
//da carga horária diciplinar, então o aluno es-
//tará aprovado por média; caso contrário será
//reprovado
//-> verificar se a reprovação foi por falta ou por
//média.
//-> Deverá informar as três notas do aluno, seu no-
//me, o numero de faltas e a carga horária da dis-
//ciplina.
//variáveis:
//média: mf
//notas: nt1, nt2, nt3
//nome do aluno: na
//carga horária: ch
//numero de faltas: ft
//frequencia: fq
var
mf,nt1,nt2,nt3:real
ft,ch:inteiro
na: caracter
inicio
escreva(&quot;Informe o nome do aluno: &quot;)
leia(na)
escreva(&quot;Informe a carga horária: &quot;)
leia(ch)
escreva(&quot;Informe o numero de faltas: &quot;)
leia(ft)
escreval(&quot;Informe as três notas: &quot;)
leia(nt1,nt2,nt3)
mf <- (nt1+nt2+nt3)/3
se (mf >= 7.0) e (ft <= ch*0.25) entao
 escreva(na,&quot; foi aprovado com média: &quot;,mf:2:2,&quot; com &quot;,ft,&quot; faltas.&quot;)
senao
 se (mf < 7.0) e (ft <= ch*0.25) entao
 escreva(na,&quot; foi reprovado por média: &quot;,mf:2:2,&quot; com &quot;,ft,&quot; faltas.&quot;)
 senao
 se (mf >= 7.0) e (ft > ch*0.25) entao
 escreva(na,&quot; foi reprovado por falta: &quot;,ft,&quot; com média: &quot;, mf:2:2)
 senao
 escreva(na,&quot; foi reprovado por media: &quot;,mf:2:2,&quot; e por falta: &quot;,ft)
 fimse
 fimse
fimse
fimalgoritmo