Apostila sobre Linguagem C++3
8 pág.

Apostila sobre Linguagem C++3


DisciplinaAlgoritmo e Programação1.513 materiais13.721 seguidores
Pré-visualização1 página
C++
Parte III
Algoritmos e Programação 2
Estruturas de dados homogêneas 
\uf0d8 Variáveis compostas do mesmo tipo de dado repetitivo 
(inteiro, real, ...) são denominadas de conjunto homogêneo 
de dados.
\uf0d8 Esses agrupamentos de variáveis são conhecidos também 
como arrays, vetores, matrizes, tabelas ou variáveis 
indexadas ou subscritas.
Algoritmos e Programação 3
Array unidimensionais 
\uf0d8 Arrays
São variáveis do mesmo tipo declaradas com o mesmo 
identificador e referenciadas por um índice para determinar 
sua localização dentro da estrutura.
Segue-se uma ilustração: 
1 2 3 4 5 índices 
brasilCp58 62 70 94 02
Algoritmos e Programação 4
\uf0d8 Declaração:
int brasilCp[4];
\uf0d8 Operações básicas:
\u2013 Atribuição:brasilCp[4] = 02;
\u2013 Leitura: cin>> brasilCp[4];
\u2013 Escrita:cout<< brasilCp[4];
C++
Arrays
Algoritmos e Programação 5
\uf0d8 Exemplo:
Calcular a média aritmética das notas de uma classe 
com cinco alunos, apresentar a média da turma e as 
notas iguais ou acima dessa média.
Arrays
Algoritmos e Programação 6
Arrays
Algoritmo: notas_e_media
início
declare var.
 escreva
 nota[i]
fim
soma \u2190 0
<=5
 escreva
'Inf. a nota.'
 leia nota[i]
i \u2190 1, 5 
soma \u2190 soma
 + nota[i]
>5 media \u2190 
Soma / 5
 escreva
&quot;Notas > ou 
 = a media&quot;
<=5
i \u2190 1, 5 >5
nota[i] >=
 media
F
V
Diagrama de blocos
Algoritmos e Programação 7
Algoritmo notas_e_media
notas : vetor[1..5] de real
 soma, nota, media : real
num : inteiro
soma <- 0
para num de 1 ate 5 faca
escreva('Entre com a ', num, 'a. nota: ')
leia(nota)
soma <- soma + nota
notas[num] <- nota
fimpara
media \u2190 soma / 5
escreva('Relacao das notas maiores ou iguais a media: ', media)
para num de 1 ate 5 faca
 se (notas[num] > media) entao
escreva(notas[num])
fimse
fimpara
Fim Algoritmo .
Pseudocódigo
Arrays
Algoritmos e Programação 8
Arrays
C++#include <iostream.h>
int main()
{
float nota[5]; // declaração do vetor
float media=0;
 int num;
for(num=0; num<5; num++)
{
cout<<&quot;Digite a &quot;<<(num+1)<<&quot;a. nota: &quot;;
cin>>nota[num]; // armazena a nota no vetor
media += nota[num];
}
media = media / 5;
cout<<&quot;\nRelacao das notas maiores ou iguais a media: 
&quot;<<media<<endl;
for(num=0; num<5; num++)
if(nota[num]>=media)
cout<<nota[num]<<endl; // lista a nota a partir do vetor
}