A maior rede de estudos do Brasil

Grátis
6 pág.
Apol 03

Pré-visualização | Página 1 de 1

Questão 1/5 - Lógica de Programação e Algoritmos
Na Aula 4 trabalhamos com o conceito de Lógica Iterativa. Analise o código abaixo que envolve este conteúdo.
 
Perceba que existe uma linha faltando no código. Assinale a alternativa que corresponde a esta linha.
Nota: 20.0
	
	A
	enquanto x de 1 ate 10 faca
	
	B
	para x de 1 ate 10
	
	C
	para i de 1 ate 10 faca
	
	D
	enquanto x<10 faca
	
	E
	para x de 1 ate 10 faca
Você acertou!
Questão 2/5 - Lógica de Programação e Algoritmos
Na Aula 5, trabalhamos com o conceito de laços de repetição. O algoritmo abaixo realiza um enquanto-faca para ler idades e sexo de pessoas. 
Existe uma parte do código faltando entre o fimenquanto e o fimalgoritmo. Que parte é essa? Assinale a alternativa que melhor representa esta parte.
Nota: 20.0
	
	A
	   escreval("*** Totais por faixa-etária e sexo ***")
   escreval("Número de meninas: ",femmenor)
   escreval("Número de mulheres: ",femmaior)
   escreval("Número de meninos: ",mascmenor)
   escreval("Número de homens: ",mascmaior)
	
	B
	   escreval("*** Totais por faixa-etária e sexo ***")
   escreval("Número de meninas: ",fem_menor)
   escreval("Número de mulheres: ",fem_maior)
   escreval("Número de meninos: ",masc_menor)
   escreval("Número de homens: ",masc_maior)
Você acertou!
	
	C
	   escreval("*** Totais por faixa-etária e sexo ***")
   escreval("Número de meninas: ",fem_menor)
   escreval("Número de mulheres: ",fem_maior)
   escreval("Número de mulheres: ",fem_menor)
   escreval("Número de meninos: ",masc_menor)
	
	D
	   escreval("*** Totais por faixa-etária e sexo ***")
   escreval("Totais: ",fem_menor,fem_maior,masc_menor,masc_maior)
	
	E
	   escreval("*** Totais por faixa-etária e sexo ***")
   para i de 1 ate qt faca
       escreval("Número de meninas: ",fem_menor)
       escreval("Número de mulheres: ",fem_maior)
       escreval("Número de meninos: ",masc_menor)
       escreval("Número de homens: ",masc_maior)
   fimpara
Questão 3/5 - Lógica de Programação e Algoritmos
Na Aula 6, trabalhamos com o conceito de vetores. O algoritmo abaixo faz a leitura de 5 números quaisquer, porém a lógica utlizada na leitura não é nada inteligente, pois vetores poderiam ser empregados no código.
Assinale a alternativa que transforma a lógica acima em algo mais adequado para a lógica de programação.
Nota: 20.0
	
	A
	
	
	B
	
	
	C
	
Você acertou!
Correto.
	
	D
	
	
	E
	
Questão 4/5 - Lógica de Programação e Algoritmos
Na Aula 6 trabalhamos com o conceito de vetores em psedocódigo. Vetores são variáveis que podem conter diversos valores. 
O algoritmo abaixo realiza a leitura de 10 nomes de pessoas e o seu sexo, e armazena os nomes em 2 vetores diferentes. 
Caso a pessoa seja homem, é armazenada no vetor Vmasc, e caso seja mulher, no vetor Vfem.
Infelizmente, o código contém erros. Assinale a alternativa que identifica todos os erros do código.
Nota: 20.0
	
	A
	A leitura do Nome e do Sexo devem estar dentro do para-se.
Estão invertidos os vetores de armazenamento dentro do se-faca. Deveria ser primeiro o Vmasc e depois oVfem. 
A variável i está declarada errada. Ela deve ser to tipo inteiro.
Você acertou!
	
	B
	A leitura do Nome e do Sexo devem estar dentro do para-se.
A variável i está declarada errada. Ela deve ser to tipo inteiro.
	
	C
	A leitura do Nome e do Sexo devem estar dentro do para-se.
Estão invertidos os vetores de armazenamento dentro do se-faca. Deveria ser primeiro o Vmasc e depois o Vfem.
	
	D
	O para-se é inapropriado para esta situação. Deve-se utilizar o enquanto-faca.
Estão invertidos os vetores de armazenamento dentro do se-faca. Deveria ser primeiro o Vmasc e depois oVfem. 
A variável i está declarada errada. Ela deve ser to tipo inteiro
	
	E
	O para-se é inapropriado para esta situação. Deve-se utilizar o enquanto-faca.
A variável i está declarada errada. Ela deve ser to tipo inteiro
Questão 5/5 - Lógica de Programação e Algoritmos
Na aula 6 trabalhamos com o conceito de vetores. Considere um vetor de dimensão 50 chamado v1.
Qual seria a melhor lógica para a identificação do menor e do maior elemento deste vetor v1? Assinale a alternativa correta e assuma que a variável que varre as posições do vetor é a variável pos, a variável maior armazena o maior valor do vetor e a variável menor armazena o menor valor do vetor.
Nota: 20.0
	
	A
	  para pos de 1 ate 10 faca
   se (v1[pos]>maior) entao
      maior<-v1[pos]
   fimse
 
   se (v1[pos]<menor) entao
      menor<-v1[pos]
   fimse
 
   fimpara
	
	B
	   maior<-v1[1]
   menor<-v1[1]
 
   para pos de 1 ate 10 faca
   se (v1[pos]>maior) entao
      maior<-v1[pos]
   senao
      menor<-v1[pos]
   fimse
 
   fimpara
	
	C
	   maior<-v1[1]
   menor<-v1[1]
 
   para pos de 1 ate 50 faca
   se (v1[pos]>maior) entao
      maior<-v1[pos]
   fimse
 
   se (v1[pos]<menor) entao
      menor<-v1[pos]
   fimse
 
   fimpara
Você acertou!
	
	D
	   maior<-v1[1]
   menor<-v1[1]
 
   se (v1[pos]>maior) entao
      maior<-v1[pos]
   fimse
 
   se (v1[pos]<menor) entao
      menor<-v1[pos]
   fimse
	
	E
	   maior<-v1[pos]
   menor<-v1[pos]
 
   para pos de 1 ate 50 faca
   se (v1[pos]>maior) entao
      maior<-v1[pos]
   fimse
 
   se (v1[pos]<menor) entao
      menor<-v1[pos]
   fimse
 
   fimpara