A maior rede de estudos do Brasil

Grátis
7 pág.
AOL 3 PROGAMACAO DE COMPUTADORES UNINASSAU

Pré-visualização | Página 1 de 2

Unidade 2 Revisar envio do teste: Avaliação On-Line 3 (AOL 3) - Questionário
Revisar envio do teste: Avaliação On-Line 3 (AOL 3) -
Questionário
Usuário Karla Monique Silva de Lima Rocha
Curso 16943 . 7 - Programação de Computadores - 20192.B
Teste Avaliação On-Line 3 (AOL 3) - Questionário
Iniciado 17/10/19 15:43
Enviado 17/10/19 15:48
Status Completada
Resultado da
tentativa
10 em 10 pontos 
Tempo
decorrido
4 minutos
Instruções
Resultados
exibidos
Todas as respostas, Respostas enviadas, Respostas corretas, Perguntas respondidas
incorretamente
Atenção! Você terá 1 opção de envio. Você pode salvar e retornar quantas vezes
desejar, pois a tentativa só será contabilizada quando você decidir acionar o botão
ENVIAR.
Após o envio da atividade, você poderá conferir sua nota e o feedback, acessando o
menu lateral esquerdo (Notas).
IMPORTANTE: verifique suas respostas antes do envio desta atividade.
Pergunta 1
Analise o algoritmo abaixo e em seguida escolha a alternativa correta. Esse algoritmo inicia,
executa, mas não faz o que deveria que é contar regressivamente de 400 até 100, recuando de
10 em 10. Porque isso acontece? 
ALGORITMO “teste”
VAR
I : inteiro
Inicio
1 em 1 pontos
Karla Monique Silva de Lima Rocha 13
←← OK OK
Revisar envio do teste: Avaliação On-Line 3 (AOL 3) - ... https://sereduc.blackboard.com/webapps/assessment/review/review.jsp?a...
1 of 7 17/10/2019 15:48
Resposta Selecionada: b.
Respostas: a.
b.
c.
d.
e.
Para i:=400 ate 100 passo 10 faca
Escreval(i)
Fimpara
FIMALGORITMO
Porque o passo está positivo e deveria ser negativo.
Porque a variável passo deveria ser declarada.
Porque o passo está positivo e deveria ser negativo.
Porque a variável I deveria ser real.
Porque a variável “i” deveria ser iniciada com 10 e não 400
Porque o passo deveria ser real.
Pergunta 2
Resposta Selecionada: a.
Respostas: a.
b.
c.
d.
e.
Nas mais diversas linguagens, costumamos encontrar o comando:
x:= x + valor
A função dessa variável X é:
Funcionar como um acumulador.
Funcionar como um acumulador.
Funcionar como um contador.
Contabilizar uma média.
Armazenar o menor valor.
Armazenar o maior valor.
Pergunta 3
Resposta Selecionada: a.
Respostas: a.
b.
Em programas de computador, costumamos encontrar comandos onde se divide um
acumulador(total) por um contador(qtd), como no comando abaixo.
X := total / qtd
Normalmente, nesse caso, a variável X está fazendo um papel de:
Média.
Média.
Acumulador.
1 em 1 pontos
1 em 1 pontos
Revisar envio do teste: Avaliação On-Line 3 (AOL 3) - ... https://sereduc.blackboard.com/webapps/assessment/review/review.jsp?a...
2 of 7 17/10/2019 15:48
c.
d.
e.
Contador.
Menor valor.
Maior valor.
Pergunta 4
Resposta
Selecionada:
a.
Respostas: a.
b.
c.
d.
e.
Leia o trecho de programa no Visualg abaixo e selecione a alternativa correta:
var
i: inteiro
inicio
Para i:=200 ate 1 faça
escreval(i + 15)
fimpara
O programa inicia uma contagem e termina rapidamente, pois o valor inicial
é maior que o final e não tem passo negativo - na hora em que for executado
não vai mostrar nada.
O programa inicia uma contagem e termina rapidamente, pois o valor inicial
é maior que o final e não tem passo negativo - na hora em que for executado
não vai mostrar nada.
O programa não vai rodar, pois a variável I deveria ser real e não inteira.
O programa faz um somatório com a variável i + 15.
O programa conta de 200 até 1, ou seja, de trás pra frente, de 15 em 15.
A variável i começa com o valor 215.
Pergunta 5
Analise o programa abaixo, na linguagem Utilizada no Visualg, e depois selecione a alternativa
correta. :
Var
p,x,i: inteiro
inicio
1 em 1 pontos
1 em 1 pontos
Revisar envio do teste: Avaliação On-Line 3 (AOL 3) - ... https://sereduc.blackboard.com/webapps/assessment/review/review.jsp?a...
3 of 7 17/10/2019 15:48
Resposta Selecionada: a.
Respostas: a.
b.
c.
d.
e.
Para i:=1 ate 10 faca
Escreval(“informe o valor da variável p”)
Leia(p)
Se p > x entao
x:=p
fimse
fimpara
Entre outras coisas, para que pode servir a variável x?
Armazena o maior valor da variável p.
Armazena o maior valor da variável p.
Calcula a média.
Conta quantos elementos são iguais a zero.
É um acumulador.
É um contador.
Pergunta 6
Observe o algoritmo abaixo, execute no visualg e escolha a alternativa correta:
ALGORITMO “USANDONOMES”
VAR
I : inteiro
nome : caractere
Inicio
Para i:=1 ate 3 faca
Escreval(“informe nome”)
leia(nome)
Fimpara
Para i:=1 ate 3 faca
1 em 1 pontos
Revisar envio do teste: Avaliação On-Line 3 (AOL 3) - ... https://sereduc.blackboard.com/webapps/assessment/review/review.jsp?a...
4 of 7 17/10/2019 15:48
Resposta
Selecionada:
d.
Respostas: a.
b.
c.
d.
e.
Escreval(“nome cadastrado :” , nome)
Fimpara
FIMALGORITMO
O algoritmo lista os nomes, mas vai mostrar apenas o último nome
cadastrado 3 vezes.
A variável nome deveria ser real.
Nesse algoritmo são recebidos 3 nomes que ficam armazenados podendo
ser listados posteriormente.
O uso de um vetor não seria apropriado nesse caso.
O algoritmo lista os nomes, mas vai mostrar apenas o último nome
cadastrado 3 vezes.
Esse algoritmo usa um vetor na sua listagem.
Pergunta 7
Resposta Selecionada: e.
Respostas: a.
b.
c.
d.
e.
Em vários programas de computador, tanto podemos encontrar o comando 
x := x + 1 quanto o comando x++ . Quando esse tipo de comando é encontrado, a variável x está
fazendo o papel de:
contador.
Média.
Acumulador.
Maior valor.
Menor valor.
contador.
Pergunta 8
Resposta
Selecionada:
d.
Respostas: a.
As alternativas abaixo tratam da linguagem utilizada no Visualg. Qual delas não corresponde a
verdade? 
No visualg, o comando PARA usa uma variável de controle do tipo caracter(ou
literal).
O comando PARA, no visualg e em outras linguagens, normalmente permite
mudar o passo da variável de controle, podendo ser 1, 2 ou qualquer outro
valor inteiro.
1 em 1 pontos
1 em 1 pontos
Revisar envio do teste: Avaliação On-Line 3 (AOL 3) - ... https://sereduc.blackboard.com/webapps/assessment/review/review.jsp?a...
5 of 7 17/10/2019 15:48
b.
c.
d.
e.
O comando SE... Então...Senao....Fimse (ou IF em outras linguagens) permite
variar a resposta que o algoritmo dá dependendo do dado que foi inserido e
do resultado da sentença lógica, podendo ser usado mais de uma vez no
programa.
O comando ENQUANTO(ou while em outras linguagens) pode ser usado em
repetições do tipo indeterminado ou determinado.
No visualg, o comando PARA usa uma variável de controle do tipo caracter(ou
literal).
O comando PARA equivale ao FOR em outras linguagens, que podem ser
mais ou menos detalhadas ou flexíveis em relação ao visualg.
Pergunta 9
Resposta
Selecionada:
a.
Respostas: a.
b.
c.
d.
e.
Leia o trecho de programa no Visualg abaixo e selecione a alternativa correta:
var
x: real
i: inteiro
inicio
Para i :=1 ate 15 faça
 x:= x + i
fimpara
escreval (x/15)
O programa exibe a média da soma dos números entre 1 e 15.
O programa exibe a média da soma dos números entre 1 e 15.
X é um contador.
O programa não vai rodar, pois a variável I deveria ser real e não
inteira.
A variável X deveria ser literal.
X armazena o menor valor da variável i.
1 em 1 pontos
1 em 1 pontos
Revisar envio do teste: Avaliação On-Line 3 (AOL 3) - ... https://sereduc.blackboard.com/webapps/assessment/review/review.jsp?a...
6 of 7 17/10/2019 15:48
Quinta-feira, 17 de Outubro de 2019 15h48min33s BRT
Pergunta 10
Resposta Selecionada: d.
Respostas: