A maior rede de estudos do Brasil

Grátis
50 pág.
Apresentação IPv6

Pré-visualização | Página 1 de 2

III Fórum de Redes de Conectividade 
Josué Batista Antunes
josue.jba@gmail.com
IPv6
• Instrutor: 
– Josué Batista
• O curso:
– Teoria: 
• Livro CCNA 4.1 Guia Completo – Marco Aurélio
• Site: http://www.ipv6.br/
– Prática: 
• Packet Tracer 5.1 
– Outros Materiais:
• https://sites.google.com/site/josuejba 
http://www.ipv6.br/
https://sites.google.com/site/josuejba
IPv6 - Introdução
• Internet Protocol – IP
IPv6 - Introdução
• Internet Protocol – IP
– Endereço IP: “Identificador numérico designado a cada 
dispositivo conectado a uma rede IP.”
– Endereço Lógico.
– Permite a comunicação entre dispositivos de redes 
independente dos tipos de LANs (Ethenet, Token Ring).
IPv6 - Introdução
• Exemplo endereço IPv4
– 192.168.0.10 /24
– 10.10.15.1 /8
– 175.198.10.15 /16
• Define a Rede e o Host dentro da rede.
IPv6 - Introdução
• Esgotamento de IPv4 disponíveis.
– IPv4 = 4.294.967.296 endereços.
– Crescimento do numero de host na internet
IPv6 - Introdução
• Evolução do estoque de IPs
IPv6 - Introdução
• Soluções Paliativas
– CIDR:
• Fim do uso de classes = blocos de tamanho apropriado.
– DHCP: 
• Alocações dinâmicas de endereços.
– NAT:
• Permite conectar toda uma rede de computadores usando apenas 
um endereço válido na Internet.
IPv6 - Introdução
• Porque uma nova versão?
– No mundo:
• 1.966.514.816 usuários de Internet e continua crescendo.
• 28,7% da população;
• Crescimento de 444,8% nos últimos 10 anos.
• Em 2014 (previsão), soma de celulares, smartphones, netbooks e 
modens 3G deve chegar a 2,25 bilhões de aparelhos.
– No Brasil:
• 27% de domicílios com acesso à Internet;
• 3,5 milhões de conexões em banda larga móvel;
• 11 milhões de conexões em banda larga fixa.
O protocolo IPv6
• IPv6 – Nova versão do protocolo IPv4
• Apresenta novos serviços e aprimora os existentes.
• Principais Motivações para mudança:
– Espaço de endereçamento 
– Qualidade de Serviço
– Mobilidade
O protocolo IPv6
• Novidades
– Novo espaço de endereçamento de 32 para 128 bits
• 192.168.0.10
• 2001:0db8:12ff:cafe:cade:d4d0:087c:140b
– Autoconfiguração de endereço:
• Suporte para atribuição automática de endereço.
• Busca o prefixo no router da rede, e acrescenta o sufixo através 
do seu endereço MAC. 
– Suporte a qualidade de serviço diferenciada.
• Aplicações como vídeo e áudio passam a estabelecer conexões 
apropriadas.
O protocolo IPv6
• Formato do Datagrama IPv4
O protocolo IPv6
• Cabeçalho: IPv4 x IPv6
• IPv4: possui 12 campos e seu tamanho possa 
variar entre 20 e 60 Bytes
• IPv6: possui apenas 8 campos e com tamanho fixo 
de 40 Bytes
• Mesmo com endereçamento de 128 bits.. 2x maior 
que IPv4, o IPv6 é apenas 2x maior.
O protocolo IPv6
• Formato do Datagrama IPv6
O protocolo IPv6
• Formato do Datagrama IPv6
O protocolo IPv6 –
Endereçamento
• Um endereço IPv4 é formado por 32 bits.
– 2^32 = 4.294.967.296
• Um endereço IPv6 é formado por 128 bits.
– 2^128 = 
340.282.366.920.938.463.463.374.607.431.768.211.45340.282.366.9
20.938.463.463.374.607.431.768.211.456
– ~ 56 octilhões (5,6x1028) de endereços IP por ser humano.
– ~ 79 octilhões (7,9x1028) de vezes a quantidade de endereços IPv4.
O protocolo IPv6 –
Endereçamento
• Os endereços IPv6 são divididos em oito grupos de 
16 bits, separando-os por “:”, escritos com dígitos 
hexadecimais.
O protocolo IPv6 –
Endereçamento
• Na representação de um endereço IPv6 é 
permitido:
– Utilizar caracteres maiúsculos ou minúsculos;
– Omitir os zeros à esquerda; e
– Representar os zeros contínuos por “::”.
• Exemplo:
– 2001:0DB8:0000:0000:130F:0000:0000:140B
– 2001:db8:0:0:130f::140b
O protocolo IPv6 –
Endereçamento
• Representação dos Prefixos
– Como o CIDR (IPv4)
• “endereço-IPv6/tamanho do prefixo”
– Exemplo:
• Prefixo 2001:db8:3003:2::/64
• Prefixo global 2001:db8::/32
• ID da sub-rede 3003:2
O protocolo IPv6 –
Endereçamento
• Existem no IPv6 três tipos de endereços definidos:
– Unicast → Identificação Individual
– Anycast → Identificação Seletiva
– Multicast → Identificação em Grupo
Obs: Não existe mais Broadcast.
O protocolo IPv6 -
Endereçamento
• Unicast 
– Global Unicast
• Equivalente aos endereços global da internet IPv4
• Possui três partes: o prefixo de roteamento global; a identificação 
da sub-rede; e a identificação da interface;
• 2000::/3
O protocolo IPv6 -
Endereçamento
• Unicast 
– Global Unicast
• Deve ser utilizado apenas localmente.
• Valido somente no enlace onde a interface esta configurada.
• FE80::/64
O protocolo IPv6 -
Endereçamento
• Endereços e faixas especiais.
– Localhost - 127.0.0.1 ::1/128 (0:0:0:0:0:0:0:1)
– IPv4-mapeado - ::FFFF:wxyz
• wxyz representa os 32 bits do endereço IPv4
– 6to4 - 2002::/16
O protocolo IPv6 -
Endereçamento
• Anycast
– Identifica um grupo de interfaces...
– Mas entrega o pacote apenas a interface mais próxima a 
origem. 
– Sintaticamente iguais aos Unicast
– Possíveis utilizações:
• Descobrir serviços na rede (DNS, proxy HTTP, etc.).
• Balanceamento de carga.
• Localizar roteadores que forneçam acesso a uma determinada 
sub-rede.
O protocolo IPv6 -
Endereçamento
• Multicast
– Identifica um grupo de interfaces
– Seu funcionamento é similar ao do broadcast.
– Diferença: no broadcast o pacote é enviado a todos os 
hosts da rede, sem exceção, enquanto que no multicast
apenas um host receberá este pacote.
– Aplicações: videoconferência, atualizações de softwares 
e jogos on-line.
O protocolo IPv6 -
Endereçamento
• Alguns endereços multicast permanentes.
O protocolo IPv6 –
Endereçamento
• Distribuição dos endereços 
– As redes /48 são recomendadas para todos os tipos de usuários, 
sejam usuários domésticos, pequenos ou grandes empresas;
– Empresas muito grandes podem receber um /47, prefixos um pouco 
menores, ou múltiplos /48;
– Redes /64 são para locais onde apenas uma sub-rede é necessária, 
para usuários 3G, por exemplo;
– Uma rede /128 quando apenas uma interface será conectada.
O protocolo IPv6
• Autoconfiguração
– Possibilidade do host se autoconfigurar com um endereço 
IP.
• Não necessita do servidor DHCP
– O host determina a informação de prefixo através de um 
router na rede.
– Adiciona como Interface ID o endereço MAC da sua placa 
de rede
• Stateless: sem servidor DCHP
• Statefull: com servidor DCHP
O protocolo IPv6 - Migração
O protocolo IPv6 - Migração
• Técnicas 
– Pilha Dupla
– Tunelamento
– Tradução
O protocolo IPv6 - Migração
• Pilha Dupla
O protocolo IPv6 - Migração
• Tunelamento
• 6to4 Tunneling
O protocolo IPv6 - Migração
• Tradução
O protocolo IPv6 - Migração
• Dual Stacking 
• 6to4 Tunneling
O protocolo IPv6
Prática 

O protocolo IPv6 - Prática
• Ambiente:
– No Packet Tracer 
– Arquivo: Topologia_prática_IPv6.pkt
O protocolo IPv6 - Prática
O protocolo IPv6 - Prática
O protocolo IPv6 - Prática
• Tarefas
– Configurar IP e Protocolo de Rotemento RIP com IPv4 e 
IPv6.
• Router_MOC
• Router_BH
• Router_UBERLANDIA
– Testar a conectividade
– Analisar os pacotes
O protocolo IPv6 - Prática
• IPv4_Router_MOC
Enable 
Configure terminal 
interface FastEthernet0/0 
ip address 192.168.0.1 255.255.255.0 
exit 
router rip 
network 192.168.0.0 
end
O protocolo IPv6 - Prática
• IPv4_Router_BH
Enable 
Configure terminal 
interface FastEthernet0/0 
ip address 192.168.0.1 255.255.255.0 
exit 
interface FastEthernet0/1 
ip address 10.0.0.1 255.0.0.0 
exit 
router rip 
network 192.168.0.0 
network 10.0.0.0 
end
O protocolo IPv6 - Prática
• IPv4_Router_UBERLANDIA
Enable 
Configure terminal 
interface FastEthernet0/0 
ip address 10.0.0.2 255.255.255.0 
exit 
router rip 
network 10.0.0.0 
end
O protocolo IPv6 - Prática
• IPv6_Router_MOC
Enable 
Configure terminal 
ipv6 unicast-routing 
interface FastEthernet0/0 
ipv6 address 2001:12:12:12:12:12:12:1/112 
ipv6 rip LAB enable 
ipv6 router rip LAB 
end