A maior rede de estudos do Brasil

Grátis
5 pág.
Programação

Pré-visualização | Página 1 de 1

Nome: Pedro Luís Bezerra Fontes RA: 101180380 Matéria: Programação Data: 18/10/2018 
 
 
7) Faça um algoritmo e o DB para calcular o valor de reajuste salarial de um funcionário 
(salário bruto), baseado num índice de reajuste. Feito isso calcule: 
• Contribuição para a associação da empresa (3%) 
• Impostos e outras deduções (15%) 
• Salario líquido 
Ao final do programa, mostre o salario anterior; índice de reajuste; salario bruto; $ contribuição 
para a associação; $ impostos e outras deduções; salario líquido. 
 
programa 
{ 
 // Programa: Algoritimo para calcular salário 
 // Autor: Pedro Fontes 
 // Data: 17/10/2018 
funcao inicio() 
{ 
real a, b, soma, sub, mult, div 
escreva("Digite seu Salário: ") 
leia(a) 
 
escreva("Digite o Índice de Reajuste %: ") 
leia(b) 
 
mult = (a * (1 + b/100)) 
escreva("\nSalário bruto: ", mult) 
 
mult = (a * (1 + b/100)) * 0.03 
escreva("\nContribuíção para Associação: ", mult) 
 
mult = (a * (1 + b/100)) * 0.15 
escreva("\nImposto e outras deduções: ", mult) 
 
mult = (a * (1 + b/100)) - ((a * (1 + b/100)) * 0.18) 
escreva("\nSalário Liquído: ", mult) 
 
} 
} 
 
 
 
 
 
 
 
 
 
 
Nome: Pedro Luís Bezerra Fontes RA: 101180380 Matéria: Programação Data: 18/10/2018 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Início 
Receber Salário a 
Receber Reajuste % b 
Imposto e outras deduções = 
(a * (1 + b/100)) * 0.15 
Salário Liquido = (a * (1 + b/100)) - 
((a * (1 + b/100)) * 0.18) 
Salário bruto = 
(a * (1 + b/100)) 
Contribuição para Associação = 
(a * (1 + b/100)) * 0.03 
Mostrar Salário 
bruto 
Mostrar Contribuição 
para Associação 
Mostrar Imposto e 
outras deduções 
Mostrar Salário 
Liquido 
Fim 
Nome: Pedro Luís Bezerra Fontes RA: 101180380 Matéria: Programação Data: 18/10/2018 
 
8) Faça um programa que leia uma temperatura em graus Celsius e a converta para graus 
Fahrenheit. A fórmula de conversão é: 
F = (9*C+160)/5 
 
programa 
{ 
// Programa: ºC para Fahrenheit 
 // Autor: Pedro Fontes 
 // Data: 17/10/2018 
funcao inicio() 
{ 
real a, b, soma, sub, mult, div 
escreva("Digite a temperatura em ºC: ") 
leia(a) 
 
mult = ((9 * a) + 160) / 5 
escreva("\nA temperatura em Fahrenheit é: ", mult) 
} 
} 
 
 
 
9) A Loja Mamão com Açúcar está vendendo seus produto s em 5 (cinco) prestações sem 
juros, mas a 1ª prestação é uma entrada de 35%. Faça um algoritmo que receba um valor de uma 
compra e mostre o valor das prestações. 
 
programa 
{ 
// Programa: Loja – Entrada + 4 parcelas 
 // Autor: Pedro Fontes 
 // Data: 17/10/2018 
funcao inicio() 
{ 
real a, b, soma, sub, mult, div 
escreva("Digite valor da compra: ") 
leia(a) 
 
soma = a / 100 * 35 // Soma os dois valores 
escreva("\nA Primeira prestação é: ", soma) 
 
soma = a / 100 * 65 / 4 // Soma os dois valores 
escreva("\nAs outras 4 parcelas são no valor de: ", soma) 
} 
} 
 
 
 
Nome: Pedro Luís Bezerra Fontes RA: 101180380 Matéria: Programação Data: 18/10/2018 
 
 
10) Faça um programa que calcule e mostre a área de um triângulo. Sabe-se que: 
Área= (base*altura)/2. 
 
Programa 
{ 
// Programa: Área de um triângulo 
 // Autor: Pedro Fontes 
 // Data: 17/10/2018 
funcao inicio() 
{ 
real a, b, soma, sub, mult, div 
escreva("Digite a base do triangulo: ") 
leia(a) 
 
escreva("Digite a altura do triangulo: ") 
leia(b) 
mult = a * b / 2 // Multiplica os dois valores 
escreva("\nA área do triangulo é: ", mult) 
} 
} 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Nome: Pedro Luís Bezerra Fontes RA: 101180380 Matéria: Programação Data: 18/10/2018 
 
Exercício EXTRA! Faça um programa para ler um número inteiro e informar se o número é 
par ou ímpar. 
 
programa 
{ 
 // Programa: Verificar se número é par ou impar 
 // Autor: Pedro Fontes 
 // Data: 18/10/2018 
funcao inicio() 
{ 
 inteiro numero 
 escreva ("Digite um número:") 
 
 leia(numero) 
 
 se (numero % 2==0) { 
 escreva ("O número é par.") } 
 
 senao { 
 escreva ("O número é impar.") } 
 } 
}