A maior rede de estudos do Brasil

Grátis
2 pág.
ALGORITMO VISUALG - CALCULADORA JUROS SIMPLES E COMPOSTOS

Pré-visualização | Página 1 de 1

Algoritmo "Calculadora de Juros Simples e Compostos"
var
M :real	//montante
C :real	//capital
i :real	//taxa de juros
t :inteiro //tempo
taxa :real	//taxa de juros em %
x	:inteiro //utilizado no para
J	:real //juros do mês
 
 //M = C.(1+i.t)
 
inicio
// Seção de Comandos 
escreva ("Capital investido: R$ ")
leia(C)
escreva ("Taxa de juros (%): ")
leia(taxa)
i<- taxa/100
escreva ("Período em meses : ")
leia(t)
CASO 1
escreval("")
escreval("Cálculo de Juros Simples")
escreval("Capital inicial : R$ ",C:1:2)
escreval("Montante a cada mês: ")
M <- C //montante inicial
para x de 1 ate t faca //para cada um dos meses
J <- M*i //calcula o juros do mês
M <- M+J //calcula o montante do mês
escreval(x:2,"° mes R$ ",M:1:2)
fimPara
CASO 2
escreval("")
escreval("Cálculo de Juros Compostos")
escreval("Capital inicial : R$ ",C:1:2)
escreval("Montante a cada mês: ")
para x de 1 ate t faca //para cada um dos meses
 M <- C*(1+i)^x //calcula o montante do mês
escreval(x:2,"° mes R$ ",M:1:2)
fimPara
fimAlgoritmo

Crie agora seu perfil grátis para visualizar sem restrições.