Buscar

Comandos condicionais simples (pseudocódigo)

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Você viu 3, do total de 11 páginas

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Você viu 6, do total de 11 páginas

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Você viu 9, do total de 11 páginas

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Prévia do material em texto

1. Considerando os valores para as variáveis cont=20; vinicial =12; n=l e p=4, analise e teste os trechos condicionais dos algoritmos nas sentenças a seguir
Clique aqui
Pode-se afirmar que:
Q A. Apenas os trechos condicionais I c II cscrcvem "Verdadeiro".
O B. Apenas o trecho condicional III escreve "Verdadeiro".
• C. Apenas o trecho condicional 1 escreve "Falso”
o D. Todos os trechos condicionais escrevem "Falso".
o E. Todos os trechos condicionais escrevem "Verdadeiro".
2. Dado o problema: Ler dois valores LI e L2 que representam os lados de um retângulo. Verifique se os lados podem formar um retângulo, sabendo que, para formar um 
retângulo, os dois lados devem ser diferentes. Caso possa formar um retângulo, exiba a mensagem “Forma um retângulo".
Analise as alternativas de comandos de seleção simples apresentadas:
Alternativa 1 Alternativa II Alternativa III
Var 
L l , L2: real 
Inicio 
Leia (L1,L2) 
se (L1+L2 = L l) entao 
Escreval("Forma um retângulo") 
fimse 
fimalgoritmo
Var 
L l , L2: real 
Inicio 
Leia (L1,L2) 
se (L l <>L2) entao 
Escreval("Forma um retângulo") 
fimse 
fimalgoritmo
Var 
L l , L2: real 
Inicio 
Leia (L1,L2) 
se (L1=L2) entao 
Escreval("Forma um retângulo") 
fimse 
fimalgoritmo
Selecione quais comandos de seleção simples com a expressão lógica apresentada atendem a solução do problema.
B. Alternativa II.
O C. Alternativas II c III.
Q A. Alternativa I.
O D. Alternativas I e III. 
O E. Alternativas I. II e III.
3. Dado o algoritmo em pseudocódigo que testa se um número é negativo, positivo ou zero.
Algoritmo "teste_numero" 
var 
n: inteiro 
Inicio
escreva("lnforme um numero inteiro:") 
leia(n)
se(n<0) entao 
escreva("0 numero informado é negativo") 
fimse
se(n>0) entao 
escreva("0 numero informado é positivo.") 
fimse
se(n=0) entao 
escreva("0 numero informado é zero.") 
fimse 
fimalgoritmo
Marque a alternativa correta.
Marque a alternativa correta.
A. Funciona corretamente para qualquer valor.
O B. Funciona somente para números maiores que zero. 
Q C. Funciona para números menores ou iguais a zero. 
Q D. Funciona para números maiores ou iguais a zero. 
Q E. Funciona para números diferentes de zero.
Algoritmo "maiorjdade" 
var
ano, ano_atual, diferença: inteiro 
Inicio
Escrevaflnforme o ano do seu nascimento:") 
Leia(ano)
EscrevafInforme o ano atual:") 
Leia(ano_atual) 
diferença <- ano_atual - ano 
se ( expressão Lógica) entao 
EscrevalfÉ maior de idade") 
fimse 
fimalgoritmo
4. Dado o algoritmo em pseudocódigo:
Selecione a alternativa que preenche corretamente a expressão lógica do comando de controle simples.
Selecione a alternativa que preenche corretamente a expressão lógica do comando de controle simples.
O A. difcrcnca >18
O B. difcrcnca < 18
O C. difcrcnca <=18
O D. difcrcnca <>18
E. diferença >=18
5. Dado o algoritmo.
Algoritmo "teste” 
var 
c: inteiro 
a, b ,x: real 
Inicio 
Leia(a,b,c) 
se (a<1) entao 
x< - 0 
fimse
se( a>=1)e(a<=10) entao 
x<-bA2 - 4 + ( c \ 2 ) 
fimse
se( a>10) e (a <=20) entao 
x <- quad(a) * raizq(c) 
fimse
se( a>20)entao 
x <- a + (20 mod 3) - quad(b) 
fimse
escreva l("x =", x) 
fimalgoritmo
Realize o teste do algoritmo com os valores de entrada para a=22, b=3 e c= 9 .0 valor impresso da variável x ao término do algoritmo será:
Q A. 0 (zero)
O B. 1452
O C9
0 0 .1 5
O E-22

Materiais relacionados

Perguntas relacionadas

Materiais recentes

Perguntas Recentes