Buscar

4. Considere o seguinte algoritmo em pseudocódigo, os dois dígitos à esquerda identificam a linha do algoritmo: 01- algoritmo "matrizes" 02- var ...

4. Considere o seguinte algoritmo em pseudocódigo, os dois dígitos à esquerda identificam a linha do algoritmo: 01- algoritmo "matrizes" 02- var 03- valores: vetor[1..5,1..6] de real 04- i,j: inteiro 05- inicio 06- para i de 1 ate 5 passo 1 faca 07- para j de 1 ate 6 passo 1 faca 08- escreva("Digite valor: ") 09- leia(valores[i,j]) 10- fimpara 11- fimpara 12- para i de 1 ate 5 passo 1 faca 13- para j de 1 ate 6 passo 1 faca 14- escreval("valor[",i,",",j,"): ",valores[i,j]) 15- fimpara 16- fimpara 17- para i de 1 ate 5 passo 1 faca 18- escreval("") 19- para j de 1 ate 6 passo 1 faca 20- escreva(" ",valores[i,j]: 21- fimpara 22- fimpara 23- fimalgoritmo Analise as alternativas a seguir e selecione a CORRETA: A. a) Para cada processo de manipulação da matriz, são sempre utilizados três comandos "para...faça" encadeados. B. b) O trecho de comandos da linha 12 até 16 tem o mesmo objetivo geral do trecho da linha 17 até 22. C. c) No comando da linha 20, é especificado que somente serão mostrados os valores menores do que :5 D. d) O comando da linha 09 "leia(valores[i,j])" pode ser substituído por "leia(valores[i],[j])". E. e) O algoritmo lê uma matriz de 20 elementos e depois apresenta essa matriz duas vezes em formatos diferentes.

💡 1 Resposta

User badge image

Ed Verified user icon

A alternativa correta é a letra B) b) O trecho de comandos da linha 12 até 16 tem o mesmo objetivo geral do trecho da linha 17 até 22. O trecho de comandos da linha 12 até 16 tem como objetivo exibir os valores da matriz, enquanto o trecho da linha 17 até 22 tem como objetivo exibir uma matriz formatada. Ambos os trechos têm como objetivo geral exibir a matriz, mas de maneiras diferentes. As outras alternativas apresentam informações incorretas ou que não estão presentes no algoritmo.

0
Dislike0

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis


✏️ Responder

SetasNegritoItálicoSublinhadoTachadoCitaçãoCódigoLista numeradaLista com marcadoresSubscritoSobrescritoDiminuir recuoAumentar recuoCor da fonteCor de fundoAlinhamentoLimparInserir linkImagemFórmula

Para escrever sua resposta aqui, entre ou crie uma conta.

User badge image

Outros materiais