A maior rede de estudos do Brasil

Fazer um programa que calcule, escreva a soma dos 50 primeiros termos da seguinte série:

100/1 - 997/2 + 994/3 - 991/4 + ...

7 resposta(s)

User badge image

Fabio Ricardo

Há mais de um mês

Também pode ser dessa forma, fica menor:

#include <stdio.h>
int main()
{
float soma=1000, num=1000; /*soma ja recebeu o primeiro termo, 1000 */
int i;
for (i=2; i<=50; i++) /*como o primeiro termo ja foi add em soma, precisamos somente de mais 49, daí i=2 */
{
num= num-3;
soma= soma + ((den/i)*-1);
{
   printf("Soma = %f\n", soma); 
   return 0;

 

Também pode ser dessa forma, fica menor:

#include <stdio.h>
int main()
{
float soma=1000, num=1000; /*soma ja recebeu o primeiro termo, 1000 */
int i;
for (i=2; i<=50; i++) /*como o primeiro termo ja foi add em soma, precisamos somente de mais 49, daí i=2 */
{
num= num-3;
soma= soma + ((den/i)*-1);
{
   printf("Soma = %f\n", soma); 
   return 0;

 

User badge image

Carlos Augusto

Há mais de um mês

#include <stdio.h> /* Pacotes com funções de entrada e saída */
int main()
{
float soma=0, termo=0, num=1000; int i;
for (i=1; i<=50; i++)
{
termo = num/i;
if(i%2==0)

soma = soma - termo;

else
   soma = soma + termo;

num = num - 3;
}

   printf("Soma = %f\n", soma); 
 return 0; /* Retorna 0, pois `main` retorna um `int` */
User badge image

Bruno Nakashima Rodrigues Santos

Há mais de um mês

Construir um algoritmo para calcular a média de um conjunto de valores inteiros fornecidos em uma unidade de entrada qualquer. Contar o maior, o menor quantas vezes o número 10 foi digitado

INÍCIO

INTEIRO: NUM, CONT, SOMA, MAIOR, MENOR, CONT2

CARACTER: OP

REAL: MEDIA

 CONT0, SOMA0, MAIOR-9999, MENOR+9999, CONT20, OP “s”

 ENQUANTO OP = “S” FAÇA

 ESCREVA (“DIGITE UM VALOR INTEIRO:”)

LEIA(NUM)

SOMASOMA+NUM

CONTCONT+1

SE NUM > MAIOR

  ENTÃO MAIOR  NUM

FIM SE

SE NUM < MENOR

  ENTÃO MENOR  NUM

FIM SE

SE NUM = 10

  ENTÃO CONT2CONT2+1

FIM SE

 ESCREVA (“CONTINUAR? S OU N”)

  LEIA(OP)

FIM ENQUANTO

MEDIASOMA/CONT

ESCREVA(“MEDIA = “, MEDIA)

ESCREVA (“MAIOR =”, MAIOR, “MENOR =”, MENOR)

ESCREVA(“ O NUM 10 FOI DIGITADO”, CONT2, “VEZES”)

FIM











Dia 11/11/2020

NOME:BRUNO NAKASHIMA RODRIGUES SANTOS

Lista 8


1)Fazer um algoritmo que leia 40 notas e calcule a média aritmética das mesmas.


INÍCIO

REAL: NOTA, SOMA, MEDIA

INTEIRO: I

SOMA←0

PARA I ←0 ATÉ 40 FAÇA

ESCREVA(“DIGETE A”,I,”ª NOTA:”)

LEIA(NOTA)

SOMA←SOMA+NOTA

FIM PARA

MEDIA←NOTA/40

ESCREVA(“MEDIA DAS NOTAS É:”,NOTA)


FIM
















2) Fazer um algoritmo que calcule e escreva o valor de S.

S = 1 / 1 + 2 / 2 + 4 / 3 + 8 / 4 + ... (100 termos)


INICIO

REAL: SOMA

INTEIRO: NUM, DEN, I

PARA I←1 ATÉ 100 FAÇA

SOMA←SOMA+NUM/DEN

NUM←NUM*2

DEM←DEM+1

FIM PARA

ESCREVA (“SOMA=, SOMA)

FIM


3) Sendo H= 1 + 1 / 2 + 1 / 3 + 1 / 4 + ... + 1 / N, fazer um algoritmo para gerar o número H. O número N é lido através de uma unidade de entrada qualquer uma única vez.

INICIO

INTEIRO:N,I

REAL:H

H←0

ESCREVA(“Digite um número:”)

LEIA (N)

PARA I←1 ATÉ N FAÇA

H←H + 1/I;

FIM PARA

ESCREVA(“H=,H”)

FIM

Essa pergunta já foi respondida por um dos nossos estudantes