A maior rede de estudos do Brasil

Como calcular divisão sem ser por divisão? Ajuda-me!

Faça um algoritmo capaz de pbter o quociente inteiro da divisão de dois numeros fornecidos, sem utlizar a operação da divisão e nem divisão inteira (div). Com estrutura de repetição.


2 resposta(s)

User badge image

Adriano

Há mais de um mês

Você terá que utilizar a operação de subtração. Dentro de um laço de repetição subtraia do dividendo o divisor, e em uma variável contadora, incremente 1 unidade. Faça isso enquanto o dividendo seja maior que o divisor. Exemplo: 25/5

 

INICIO

variavel dividendo = 25;

variavel divisor = 5;

variavel contador = 0;

repita enquanto dividendo >= divisor (passara por aqui 5 vezes, testando se 5, 10, 15, 20 e 25 são menores ou iguais a 25)

  dividendo = dividendo - divisor;

  contador = contador + 1;

fim do repita

imprime contador; (imprimirá o valor 5, ou seja, o número de vezes que o 5 cabe no 25)

 

FIM

 

A ideia básica é essa. Não sei se meu pseudo código esta certo, nem usei linguagem alguma, é só para dar uma luz mesmo. Agora é necessário tratar para casos especiais, quando o divisor for maior que o dividendo por exemplo, ou caso necessite mostrar o resto, enfim, ai é contigo.

Você terá que utilizar a operação de subtração. Dentro de um laço de repetição subtraia do dividendo o divisor, e em uma variável contadora, incremente 1 unidade. Faça isso enquanto o dividendo seja maior que o divisor. Exemplo: 25/5

 

INICIO

variavel dividendo = 25;

variavel divisor = 5;

variavel contador = 0;

repita enquanto dividendo >= divisor (passara por aqui 5 vezes, testando se 5, 10, 15, 20 e 25 são menores ou iguais a 25)

  dividendo = dividendo - divisor;

  contador = contador + 1;

fim do repita

imprime contador; (imprimirá o valor 5, ou seja, o número de vezes que o 5 cabe no 25)

 

FIM

 

A ideia básica é essa. Não sei se meu pseudo código esta certo, nem usei linguagem alguma, é só para dar uma luz mesmo. Agora é necessário tratar para casos especiais, quando o divisor for maior que o dividendo por exemplo, ou caso necessite mostrar o resto, enfim, ai é contigo.

User badge image

Renata

Há mais de um mês

Definir a, b, resto, contador, Como entero
Escribir "Informe o dividento e o divisor"
Leer a
leer b
resto<-a
contador<-0
Mientras resto>=b Hacer
resto<-resto-b
contador<-contador+1
Fin Mientras
escribir " =o valor da divisão é: ", contador " e o resto é: ", resto
FinProceso

Essa pergunta já foi respondida por um dos nossos estudantes