A maior rede de estudos do Brasil

.alguém consegue resolver esses exercícios em portugol pra mim?

1.Crie um algoritmo para ler uma sequência de 20 números informados pelo usuário e inserir os números lidos em uma fila. Em seguida o algoritmo deverá imprimir a cabeça e cauda da fila.


2. Crie um algoritmo para ler uma sequência de 10 números informados pelo usuário e em seguida escrever os mesmos na mesma ordem de leitura.


3. Crie um algoritmo para ler uma sequência de 25 números e ao final informar:
a. O maior número armazenado na fila;
b. O menor número armazenado na fila;
c. A soma dos números armazenados na fila;


4. Implemente uma estrutura de pilha segundo o material dado e execute as seguintes operações:


a. Empilhe: 5
b. Empilhe: 8
c. Empilhe: 22
d. Escreva o topo da pilha
e. Desempilhe
f. Imprima o topo da pilha
g. Empilhe: 30
h. Empilhe: 32
i. Imprima o resultado de Desempilhe
j. Imprima a quantidade de itens empilhados


3 resposta(s)

User badge image

Fernando

Há mais de um mês

1 - 

Algoritmo "semnome"
Var
i : inteiro
nome: vetor[1..20] de inteiro
Inicio
para i de 1 ate 20 faca
escreval("Informe o numero ", i," da fila")
leia(nome[i])
fimpara
escreval("A cabeca da fila ", nome[1])
escreval("A cauda da fila ", nome[20])
Fimalgoritmo

1 - 

Algoritmo "semnome"
Var
i : inteiro
nome: vetor[1..20] de inteiro
Inicio
para i de 1 ate 20 faca
escreval("Informe o numero ", i," da fila")
leia(nome[i])
fimpara
escreval("A cabeca da fila ", nome[1])
escreval("A cauda da fila ", nome[20])
Fimalgoritmo

User badge image

Fernando

Há mais de um mês

3 -

 

Algoritmo "semnome"
Var
i : inteiro
nome: vetor[1..25] de inteiro
ma, me, som, cal: inteiro

Inicio

ma <- 0
me <- 100000
som <- 0
para i de 1 ate 25 faca
escreval("Informe o numero ", i)
leia(nome[i])
som := som + nome[i]
se(ma<nome[i]) entao
ma<-nome[i]
fimse
se(me>nome[i]) entao
me<-nome[i]
fimse
fimpara
escreval("O valor maior e: ", ma)
escreval("O valor menor e: ", me)
escreval("A soma dos numeros e: ", som)
Fimalgoritmo

User badge image

Fernando

Há mais de um mês

2 -


Algoritmo "semnome"
Var
i : inteiro
nome: vetor[1..10] de inteiro
Inicio
para i de 1 ate 10 faca
escreval("Informe o numero ", i)
leia(nome[i])
fimpara
para i de 1 ate 10 faca
escreva(" ", nome[i])
fimpara
Fimalgoritmo

Essa pergunta já foi respondida por um dos nossos estudantes