A maior rede de estudos do Brasil

Me ajudem com o seguinte algoritmo:

Descrição

Ler um número inteiro (assuma até três dígitos) e imprimir a saída da seguinte forma:
CENTENA = x
DEZENA = x
UNIDADE = x

Algoritmos

UNOPAR


4 resposta(s) - Contém resposta de Especialista

User badge image

RD Resoluções Verified user icon

Há mais de um mês

Primeiramente definimos as variáveis a serem utilizadas no algoritmo, dessa forma teremos que :

numero, centena, dezena e unidade:inteiro


Utilizando pseudocódigo para resolução do problema. Iniciaremos verificando se o numero informado é maior que 999, ou seja, tem mais de três dígitos.

Leia(numero)

Se(numero>999) faça//verifica a variável número para a continuação ou não do algoritmo

Fimalgoritmo


Assim, para definir a quantidade de centenas deveremos realizar a divisão inteira do numero informado por 100, isso retornará a quantidade de centenas. Dessa forma teremos que:

Centenas <- numero/100


Através da divisão inteira também conseguiremos determinar as dezenas. Dessa forma teremos que:

Dezenas <- (numero-centenas*100)/10//valor restante dividido por 10


Com isso, se diminuirmos os valores de dezenas e centenas obteremos as unidades. Dessa forma teremos que:

Unidade <-(numero-centenas*100 – dezenas*10)


Assim, para finalizar basta imprimir os valores de centenas, dezenas e unidades do número inicial

Escreva(“Centenas =”)

Escreval(centena)

Escreva(“Dezenas=”)

Escreval(dezenas)

Escreva(“Unidades =”)

Escreval(unidade)

Primeiramente definimos as variáveis a serem utilizadas no algoritmo, dessa forma teremos que :

numero, centena, dezena e unidade:inteiro


Utilizando pseudocódigo para resolução do problema. Iniciaremos verificando se o numero informado é maior que 999, ou seja, tem mais de três dígitos.

Leia(numero)

Se(numero>999) faça//verifica a variável número para a continuação ou não do algoritmo

Fimalgoritmo


Assim, para definir a quantidade de centenas deveremos realizar a divisão inteira do numero informado por 100, isso retornará a quantidade de centenas. Dessa forma teremos que:

Centenas <- numero/100


Através da divisão inteira também conseguiremos determinar as dezenas. Dessa forma teremos que:

Dezenas <- (numero-centenas*100)/10//valor restante dividido por 10


Com isso, se diminuirmos os valores de dezenas e centenas obteremos as unidades. Dessa forma teremos que:

Unidade <-(numero-centenas*100 – dezenas*10)


Assim, para finalizar basta imprimir os valores de centenas, dezenas e unidades do número inicial

Escreva(“Centenas =”)

Escreval(centena)

Escreva(“Dezenas=”)

Escreval(dezenas)

Escreva(“Unidades =”)

Escreval(unidade)

User badge image

Andre

Há mais de um mês

Me ajudem com o seguinte algoritmo:

Ler um número inteiro (assuma até três dígitos) e imprimir a saída da seguinte forma:

CENTENA = x

DEZENA = x

UNIDADE = x

#Programação#Algoritmo#visualg#pseudocódigo


Primeiramente definimos as variáveis a serem utilizadas no algoritmo, dessa forma teremos que :

numero, centena, dezena e unidade:inteiro


Utilizando pseudocódigo para resolução do problema. Iniciaremos verificando se o numero informado é maior que 999, ou seja, tem mais de três dígitos.

Leia(numero)

Se(numero>999) faça//verifica a variável número para a continuação ou não do algoritmo

Fimalgoritmo


Assim, para definir a quantidade de centenas deveremos realizar a divisão inteira do numero informado por 100, isso retornará a quantidade de centenas. Dessa forma teremos que:

Centenas <- numero/100


Através da divisão inteira também conseguiremos determinar as dezenas. Dessa forma teremos que:

Dezenas <- (numero-centenas*100)/10//valor restante dividido por 10


Com isso, se diminuirmos os valores de dezenas e centenas obteremos as unidades. Dessa forma teremos que:

Unidade <-(numero-centenas*100 – dezenas*10)


Assim, para finalizar basta imprimir os valores de centenas, dezenas e unidades do número inicial

Escreva(“Centenas =”)

Escreval(centena)

Escreva(“Dezenas=”)

Escreval(dezenas)

Escreva(“Unidades =”)

Escreval(unidade)

User badge image

Marcella

Há mais de um mês

você pode usar o esquema: 

N/100 = centena

(N - centena*100)/10 = dezena

N - centena*100 - dezena*10 = unidade  

 

User badge image

Andre

Há mais de um mês

Primeiramente definimos as variáveis a serem utilizadas no algoritmo, dessa forma teremos que :

numero, centena, dezena e unidade:inteiro


Utilizando pseudocódigo para resolução do problema. Iniciaremos verificando se o numero informado é maior que 999, ou seja, tem mais de três dígitos.

Leia(numero)

Se(numero>999) faça//verifica a variável número para a continuação ou não do algoritmo

Fimalgoritmo


Assim, para definir a quantidade de centenas deveremos realizar a divisão inteira do numero informado por 100, isso retornará a quantidade de centenas. Dessa forma teremos que:

Centenas <- numero/100


Através da divisão inteira também conseguiremos determinar as dezenas. Dessa forma teremos que:

Dezenas <- (numero-centenas*100)/10//valor restante dividido por 10


Com isso, se diminuirmos os valores de dezenas e centenas obteremos as unidades. Dessa forma teremos que:

Unidade <-(numero-centenas*100 – dezenas*10)


Assim, para finalizar basta imprimir os valores de centenas, dezenas e unidades do número inicial

Escreva(“Centenas =”)

Escreval(centena)

Escreva(“Dezenas=”)

Escreval(dezenas)

Escreva(“Unidades =”)

Escreval(unidade)

Essa pergunta já foi respondida por um dos nossos especialistas