A maior rede de estudos do Brasil

31) Faça um algoritmo que leia os valores A, B e C. Mostre uma mensagem que informe se a soma de A com B é menor, maior ou igual a C.

Algoritmos

ESTÁCIO


6 resposta(s) - Contém resposta de Especialista

User badge image

RD Resoluções Verified user icon

Há mais de um mês

Utilizando linguagem C para resolução do problema, inicialmente devemos declaras as variáveis e recebe-las:

int main()

{

int A,B,C;//Declara variáveis

printf("Digite o número A ");

scanf("%i",&A);//Recebe A

printf("Digite o número B ");

scanf("%i",&B);

printf("Digite o número C ");

scanf("%i",&C);


Com isso, teremos que realizar as verificações necessárias para saber se C é menor que a soma de A e B, assim teremos:

if((A+B)>C){//condição

printf("A soma de A e B é maior que C");//escrve que C é maior que A+B

}


Agora verificaremos se a soma de A e B é igual a C, dessa forma:

if((A+B)=C){

printf("A soma de A e B é igual a C");

}


Por fim, verificamos se C é maior que a soma de A e B, assim teremos que:

if((A+B)<C){

printf("A soma de A e B é menor que C");

}

return 0;

}

Utilizando linguagem C para resolução do problema, inicialmente devemos declaras as variáveis e recebe-las:

int main()

{

int A,B,C;//Declara variáveis

printf("Digite o número A ");

scanf("%i",&A);//Recebe A

printf("Digite o número B ");

scanf("%i",&B);

printf("Digite o número C ");

scanf("%i",&C);


Com isso, teremos que realizar as verificações necessárias para saber se C é menor que a soma de A e B, assim teremos:

if((A+B)>C){//condição

printf("A soma de A e B é maior que C");//escrve que C é maior que A+B

}


Agora verificaremos se a soma de A e B é igual a C, dessa forma:

if((A+B)=C){

printf("A soma de A e B é igual a C");

}


Por fim, verificamos se C é maior que a soma de A e B, assim teremos que:

if((A+B)<C){

printf("A soma de A e B é menor que C");

}

return 0;

}

User badge image

Gilberto Lopes

Há mais de um mês

Olá,
Segue Algoritimo feito no UAL;

prog ComparaçãoC
int vrA, vrB, vrC;
imprima "\nValor A: "; leia vrA;
imprima "\nValor B: "; leia vrB;
imprima "\nValor C: "; leia vrC;

se (vrA+vrB < vrC)
{imprima "\nValor Menor que C\n";}

senao {
se (vrA+vrB > vrC)
{imprima "\nValor Maior que C\n";}

senao
{imprima "\nValor Igual a C\n";}
}
fimprog

 

 

User badge image

Lucas Montano

Há mais de um mês

1. algoritmo "ler valores de A, B e C"

2. // Função : Compara se a soma dos valores de a e b são maiores, menores ou iguais a c

3. // Autor : Fernando Bueno

4. var

5. valor1 : real

6. valor2 : real

7. valor3 : real

8. soma1e2 : real

9. inicio

10. escreval ("Informe o valor 1")

11. leia (valor1)

12. escreval ("Informe o valor 2")

13. leia (valor2)

14. escreval ("Informe o valor3")

15. leia (valor3)

16. soma1e2 <- (valor1 + valor2)

17. se soma1e2 < valor3 entao

18. escreva ("A soma do valor 1 com valor 2 é menor que o valor 3")

19. fimse

20. se soma1e2 > valor3 entao

21. escreva ("A soma do valor 1 com valor 2 é maior que o valor 3")

22. fimse

23. se soma1e2 = valor3 entao

24. escreva ("A soma do valor 1 com valor 2 é igual ao valor 3")

25. fimse

26. fimalgoritmo

User badge image

Fernando Rocha

Há mais de um mês

Peguei esse codigo e teste no visualG

 

 

algoritmo "Questao brother"

//31)Faça um algoritmo que leia os valores A, B e C.
//Mostre uma mensagem que informe se a soma de A com B é menor, maior ou igual a C.

var

   a,b,c:Inteiro

inicio

   escreva("Um lado a: ")
   leia(a)
   escreva("Um lado b: ")
   leia(b)
  escreva("Um lado c: ")
   leia(c)

   Se(a+b=c) entao
      escreval("A soma  de A com B é igual a C")
   senao
      Se(a+b>c) entao
         escreval("A soma  de A com B é maior que C")
      senao
         Se(a+b<c) entao
            escreval("A soma  de A com B é menor que C")
         fimse
      fimse
   fimse
fimalgoritmo
 

Essa pergunta já foi respondida por um dos nossos especialistas