A maior rede de estudos do Brasil

Escreva um algoritmo para calcular e escrever a tabuada dos números de 1 a 10

Por favor, alguém pode me ajudar? (e me explicar) acabei perdendo a aula q explicava como fazer e vale ponto
AlgoritmosIfpa - Campus Cameta

11 resposta(s) - Contém resposta de Especialista

User badge image

RD Resoluções Verified user icon

Há mais de um mês

algoritmo "Tabuada"

var 
x,numero:inteiro 
inicio 
// Seção de Comandos 
escreval ("============ Tabuada ============") 
escreval ("") 
escreva ("Digite um numero: ") 
leia(numero) 
escreval ("") 
escreval ("============ Tabuada de ",numero," ============") 
escreval ("") 

para x de 1 ate 10 faca 
escreval(numero," x ",x," = ",(numero * x)) 
fimpara 
fimalgoritmo 

algoritmo "Tabuada"

var 
x,numero:inteiro 
inicio 
// Seção de Comandos 
escreval ("============ Tabuada ============") 
escreval ("") 
escreva ("Digite um numero: ") 
leia(numero) 
escreval ("") 
escreval ("============ Tabuada de ",numero," ============") 
escreval ("") 

para x de 1 ate 10 faca 
escreval(numero," x ",x," = ",(numero * x)) 
fimpara 
fimalgoritmo 

User badge image

Willian

Há mais de um mês

Oi Clara, estou com insonia e ja fiz seu programa :) Segue o algoritmo (Não esquece de fazer o teste com o Netbeans):

 

package teste1;
import java.util.Scanner;
/**
*
* @author Will
*/
public class Tabuada {
public static void main (String [] args){

Scanner scan = new Scanner (System.in);

int i = 0;
int result = 0;
int num = 0;

System.err.println("Informe qual nº deseja imprimir a tabuada: ");
num = scan.nextInt();

for ( i=1; i<=10; i++){

result = num * i;

System.err.println(num + "x" + i + "=" + result);
}
}
}

User badge image

Clara

Há mais de um mês

e me incentiva tbm, a entender mais do assunto
User badge image

Clara

Há mais de um mês

Boa noite, Willian! Que pergunte ao usuário a tabuada de qual número (é uma tabuada de multiplicação eu acho. Pq a questão ñ é muito específica), na qual vc digita, por exemplo... "2". E vai parecer toda a tabuada de 2 para o usuário. É para o dia 19/02

Essa pergunta já foi respondida por um dos nossos especialistas