A maior rede de estudos do Brasil

Escreva um algoritmo que some três números e imprima o maior deles.

Modelo Narrativo.

Algoritmos

FACEMA


4 resposta(s) - Contém resposta de Especialista

User badge image

Andre Verified user icon

Há mais de um mês

Para realizar essa questão, devemos escrever o seguinte algorítimo.

irt a, b, c, s;

printf(" entre com a, b e c");

Scanf("%d", &a);

Scanf("%d",&b);

Scanf("%d",&c);

S=a+b+c;

Printf( "a soma é %d",s).

Para realizar essa questão, devemos escrever o seguinte algorítimo.

irt a, b, c, s;

printf(" entre com a, b e c");

Scanf("%d", &a);

Scanf("%d",&b);

Scanf("%d",&c);

S=a+b+c;

Printf( "a soma é %d",s).

User badge image

Noel Paiva

Há mais de um mês

Rodolfo faltou coisas ai nesse algoritmo, mostrar o maior.

Fiz em java pois nao me lembro os comandos em portugol mas segue:

public class SomaTresMostraMaior {

public static void main(String[] args) throws IOException {
// TODO Auto-generated method stub
int numero1 = 0,numero2 = 0,numero3 = 0;
Scanner in = new Scanner(System.in);
System.out.println("Digite o primeiro numero");//Escreve na tela
numero1 = in.nextInt();//Le o proximo inteiro
System.out.println("Digite o segundo numero");
numero2 = in.nextInt();
System.out.println("Digite o terceiro numero");
numero3 = in.nextInt();
//imprime a soma
int soma;
soma = numero1+numero2;
soma = soma + numero3;
System.out.println("A soma é: "+soma);
//Encontrar o maior
int maior = numero1; //Como nao tenho nada o maior é o primeiro numero.
if(numero2 > maior){
maior = numero2;//Se o numero 2 for maior entao maior recebe numero 2
}
if(numero3 > maior){
maior = numero3;//Se o numero 2 for maior entao maior recebe numero 3
}
System.out.println("O maior é: "+maior);
}

}

User badge image

Luiz Alves

Há mais de um mês

Algoritmo "soma 3 numeros para numeros positivos"

inteiro maior=0, soma,numero,contador=0;

enquanto(contador<=3)faça

escreva("Informe uma numero");

leia(numero);

contador=contador+1;

se(numero>maior)faça

maior=numero;

fimse

senao

escreva("Numero informado nao é positivo");

fimsenao

fimenquanto

escreva("a soma é:soma");

escreva( "o maior numero é:maior");

fimalgoritmo

User badge image

Rodolfo Carvalho Silva

Há mais de um mês

Algoritmo "some três números"

var

numero, q, soma:inteiro

inicio

numero = 0

q = 1

soma = 0

se (q <= 3) entao

-escreva ("entre com o número")

-leia (numero)

-soma = numero + soma

-q = q + 1

-senao 

-escreval (numero)

fimse

fimalgoritmo

Essa pergunta já foi respondida por um dos nossos especialistas