A maior rede de estudos do Brasil

Exercício pra ser feito no VisuAlg

1.      Faça um algoritmo para calcular o produto de dois números lidos da entrada (n1 e n2) através do método de somas sucessivas. Suponha que n1 e n2 são positivos.

Exemplo:

Valores lidos: 3   4

Impressão:           12

Dica: 3 x 4 = 3 + 3 + 3 + 3 = 12

Algoritmos

UNIGRAN


2 resposta(s) - Contém resposta de Especialista

User badge image

RD Resoluções Verified user icon

Há mais de um mês

algoritmo "semnome"
// Função :
// Autor :
// Data : 
// Seção de Declarações 
var
   n1, n2, resultado: inteiro
inicio
      escreva("Insira os dois numeros: ")
      leia(n1)
      leia(n2)
      resultado<-0
      enquanto n1>=1 faca
             resultado=resultado+n2;
             n1<-n1-1;
      fimenquanto
      escreval("Resultado: ", resultado)
fimalgoritmo
 

algoritmo "semnome"
// Função :
// Autor :
// Data : 
// Seção de Declarações 
var
   n1, n2, resultado: inteiro
inicio
      escreva("Insira os dois numeros: ")
      leia(n1)
      leia(n2)
      resultado<-0
      enquanto n1>=1 faca
             resultado=resultado+n2;
             n1<-n1-1;
      fimenquanto
      escreval("Resultado: ", resultado)
fimalgoritmo
 

User badge image

Reinaldo Vieira

Há mais de um mês

Olá tudo bem, este link explica como ficaria a codificação para calcular o produto de dois números: https://www.youtube.com/watch?v=itlYicphc8A

Espero ter ajudado.

Essa pergunta já foi respondida por um dos nossos especialistas