A maior rede de estudos do Brasil

Resolução de um Algoritmo no Visualg Com Vetores

Ele tem que ler o peso número indeterminado de mulheres homens e calcule a quantidade, a porcentagem e a média do peso deles e delas.
Algorítmos ComputacionaisColegio Olimpos Ldta

3 resposta(s) - Contém resposta de Especialista

User badge image

RD Resoluções Verified user icon

Há mais de um mês

Devemos iniciar declarando as variáveis que serão utilizadas.

Var

pesomulher,pesohome:vetor[1..100] de inteiro

mediamulher,mediahomem,peso,ph,pm:real

nm,nh,i:inteiro


Assim devemos saber a quantidade de homens e mulheres.

Inicio

escreval("Quantidade de homens")

leia(nh)

escreval("Quantidade de mulheres")

leia(nm)


Com isso, podemos receber os valores de peso das mulheres e dos homens sempre realizando um somatório a cada loop.

para i de 1 ate nh faca

escreval("Peso homem:")

leia(peso)

mediahomem <-mediahomem+peso

fimpara

para i de 1 ate nm faca

escreval("Peso Mulher:")

leia(peso)

mediamulher <-mediamulher+peso

fimpara


Assim, calcularemos as médias e as apresentaremos aos usuários.

mediahomem<-mediahomem/nh

mediamulher<-mediamulher/nm

escreval("Media mulher",mediamulher)

escreval("Media homem",mediahomem)

Por fim, podemos mostras a porcentagem de homens e mulheres e encerrar o algoritmo.

ph<-(nh/(nh+nm))*100

pm<-(nm/(nh+nm))*100

escreval("Porcentade de mulheres:",pm,"%")

escreval("Porcentade de homens:",ph,"%")

Fimalgoritmo

Devemos iniciar declarando as variáveis que serão utilizadas.

Var

pesomulher,pesohome:vetor[1..100] de inteiro

mediamulher,mediahomem,peso,ph,pm:real

nm,nh,i:inteiro


Assim devemos saber a quantidade de homens e mulheres.

Inicio

escreval("Quantidade de homens")

leia(nh)

escreval("Quantidade de mulheres")

leia(nm)


Com isso, podemos receber os valores de peso das mulheres e dos homens sempre realizando um somatório a cada loop.

para i de 1 ate nh faca

escreval("Peso homem:")

leia(peso)

mediahomem <-mediahomem+peso

fimpara

para i de 1 ate nm faca

escreval("Peso Mulher:")

leia(peso)

mediamulher <-mediamulher+peso

fimpara


Assim, calcularemos as médias e as apresentaremos aos usuários.

mediahomem<-mediahomem/nh

mediamulher<-mediamulher/nm

escreval("Media mulher",mediamulher)

escreval("Media homem",mediahomem)

Por fim, podemos mostras a porcentagem de homens e mulheres e encerrar o algoritmo.

ph<-(nh/(nh+nm))*100

pm<-(nm/(nh+nm))*100

escreval("Porcentade de mulheres:",pm,"%")

escreval("Porcentade de homens:",ph,"%")

Fimalgoritmo

User badge image

Andre

Há mais de um mês

Devemos iniciar declarando as variáveis que serão utilizadas.

Var

pesomulher,pesohome:vetor[1..100] de inteiro

mediamulher,mediahomem,peso,ph,pm:real

nm,nh,i:inteiro


Assim devemos saber a quantidade de homens e mulheres.

Inicio

escreval("Quantidade de homens")

leia(nh)

escreval("Quantidade de mulheres")

leia(nm)


Com isso, podemos receber os valores de peso das mulheres e dos homens sempre realizando um somatório a cada loop.

para i de 1 ate nh faca

escreval("Peso homem:")

leia(peso)

mediahomem <-mediahomem+peso

fimpara

para i de 1 ate nm faca

escreval("Peso Mulher:")

leia(peso)

mediamulher <-mediamulher+peso

fimpara


Assim, calcularemos as médias e as apresentaremos aos usuários.

mediahomem<-mediahomem/nh

mediamulher<-mediamulher/nm

escreval("Media mulher",mediamulher)

escreval("Media homem",mediahomem)

Por fim, podemos mostras a porcentagem de homens e mulheres e encerrar o algoritmo.

ph<-(nh/(nh+nm))*100

pm<-(nm/(nh+nm))*100

escreval("Porcentade de mulheres:",pm,"%")

escreval("Porcentade de homens:",ph,"%")

Fimalgoritmo

User badge image

Andre

Há mais de um mês

Devemos iniciar declarando as variáveis que serão utilizadas.

Var

pesomulher,pesohome:vetor[1..100] de inteiro

mediamulher,mediahomem,peso,ph,pm:real

nm,nh,i:inteiro


Assim devemos saber a quantidade de homens e mulheres.

Inicio

escreval("Quantidade de homens")

leia(nh)

escreval("Quantidade de mulheres")

leia(nm)


Com isso, podemos receber os valores de peso das mulheres e dos homens sempre realizando um somatório a cada loop.

para i de 1 ate nh faca

escreval("Peso homem:")

leia(peso)

mediahomem <-mediahomem+peso

fimpara

para i de 1 ate nm faca

escreval("Peso Mulher:")

leia(peso)

mediamulher <-mediamulher+peso

fimpara


Assim, calcularemos as médias e as apresentaremos aos usuários.

mediahomem<-mediahomem/nh

mediamulher<-mediamulher/nm

escreval("Media mulher",mediamulher)

escreval("Media homem",mediahomem)

Por fim, podemos mostras a porcentagem de homens e mulheres e encerrar o algoritmo.

ph<-(nh/(nh+nm))*100

pm<-(nm/(nh+nm))*100

escreval("Porcentade de mulheres:",pm,"%")

escreval("Porcentade de homens:",ph,"%")

Fimalgoritmo

Essa pergunta já foi respondida por um dos nossos especialistas