A maior rede de estudos do Brasil

Faça um algoritmo em portugol que calcule a idade de pessoa?


3 resposta(s) - Contém resposta de Especialista

User badge image

RD Resoluções Verified user icon

Há mais de um mês

Então temos abaixo o código que calcula a idade de uma pessoa no ano de 2019.

algoritmo "calculaIdade"

var ano, idade:real

inicio

leia(ano)

idade:=2019-ano

escreval("A idade é: ", idade)

fimalgoritmo

Agora iremos explicar o código. Na primeira linha declaramos duas variáveis, a primeira receberá o ano que a pessoa nasceu, já a segunda receberá o resultado do cálculo que será feito. Dando início ao código então leremos a idade da pessoa, logo em seguida faremos a cálculo subtraindo o ano que estamos, no caso, 2019. Feito isso, atribuiremos esse valor a variável idade. Por último escrevemos na tela o a idade da pessoa.

Portanto temos acima o código que calcula a idade de uma pessoa.

Então temos abaixo o código que calcula a idade de uma pessoa no ano de 2019.

algoritmo "calculaIdade"

var ano, idade:real

inicio

leia(ano)

idade:=2019-ano

escreval("A idade é: ", idade)

fimalgoritmo

Agora iremos explicar o código. Na primeira linha declaramos duas variáveis, a primeira receberá o ano que a pessoa nasceu, já a segunda receberá o resultado do cálculo que será feito. Dando início ao código então leremos a idade da pessoa, logo em seguida faremos a cálculo subtraindo o ano que estamos, no caso, 2019. Feito isso, atribuiremos esse valor a variável idade. Por último escrevemos na tela o a idade da pessoa.

Portanto temos acima o código que calcula a idade de uma pessoa.

User badge image

Victor Manhani

Há mais de um mês

algoritmo "Idade"
var
ano_nascimento:inteiro
idade_atual:inteiro
ano_atual:inteiro
inicio
// Seção de Comandos 
ano_atual<-2019

escreva("digite o ano do nascimento")
leia(ano_nascimento)

idade_atual<-  ano_atual - ano_nascimento
escreva ("a sua idade atual é:",idade_atual)

fimalgoritmo

Essa pergunta já foi respondida por um dos nossos especialistas