A maior rede de estudos do Brasil

- Desenvolva um algoritmo em pseudocódigo para entrar com 10 números e imprimir o quadrado de cada número.

Ti - Tecnico em Informatica

Biológicas / Saúde


4 resposta(s) - Contém resposta de Especialista

User badge image

RD Resoluções Verified user icon

Há mais de um mês

Um algoritmo é um conjunto de instruções, normalmente para resolver uma classe de problemas ou realizar um cálculo. Algoritmos são especificações inequívocas para executar cálculos , processamento de dados , raciocínio automatizado e outras tarefas.

Como método eficaz , um algoritmo pode ser expresso dentro de uma quantidade finita de espaço e tempo e em uma linguagem formal bem definida para calcular uma função.

A transição de um estado para outro não é necessariamente determinística; alguns algoritmos, conhecidos como algoritmos aleatórios , incorporam entrada aleatória. O conceito de algoritmo existe há séculos. Os matemáticos gregos usavam algoritmos na peneira de Eratóstenes para encontrar números primos e o algoritmo euclidiano para encontrar o maior divisor comum de dois números.

Sabendo disso, o algoritmo será:

algoritmo "Par ou Ímpar"

var

n: inteiro

inicio

escreval("Insira um número inteiro: ")

leia(n)

se(n mod 2 = 0) entao

escreval("O número: ",n," é par")

senao

escreval("O número: ",n," é impar")

fimse

fimalgoritmo

Um algoritmo é um conjunto de instruções, normalmente para resolver uma classe de problemas ou realizar um cálculo. Algoritmos são especificações inequívocas para executar cálculos , processamento de dados , raciocínio automatizado e outras tarefas.

Como método eficaz , um algoritmo pode ser expresso dentro de uma quantidade finita de espaço e tempo e em uma linguagem formal bem definida para calcular uma função.

A transição de um estado para outro não é necessariamente determinística; alguns algoritmos, conhecidos como algoritmos aleatórios , incorporam entrada aleatória. O conceito de algoritmo existe há séculos. Os matemáticos gregos usavam algoritmos na peneira de Eratóstenes para encontrar números primos e o algoritmo euclidiano para encontrar o maior divisor comum de dois números.

Sabendo disso, o algoritmo será:

algoritmo "Par ou Ímpar"

var

n: inteiro

inicio

escreval("Insira um número inteiro: ")

leia(n)

se(n mod 2 = 0) entao

escreval("O número: ",n," é par")

senao

escreval("O número: ",n," é impar")

fimse

fimalgoritmo

Essa pergunta já foi respondida por um dos nossos especialistas