A maior rede de estudos do Brasil

Faça a leitura de 60 idades e os agrupes as idades em três vetores, conforme a faixa etária.

Alguém tem o seguinte estudo de caso de algoritmo:
ESTUDO DE CASO
Desenvolva um algoritmo que:
a) faça a leitura de 60 idades;
b) agrupe as idades em três vetores conforme a faixa etária abaixo.
Lembrando que existem cenários possíveis em que o usuário pode informar apenas 60 idades da faixa menores, por exemplo.

Faixa    Intervalo
Menores    0-18 anos
Adultos    19-60 anos
Idosos    Maiores de 60 anos

c) imprimir todas as idades separadas por faixa, como por exemplo: 
    Menores: 2, 4, 5, 13, 18.
    Adultos: 20, 20, 45, 55, 60. 
    Idosos: 67, 68, 72, 78, 79, 80.
d) imprimir a quantidade de pessoas por faixa, como por exemplo: 
    Menores: 5.
    Adultos: 5. 
    Idosos: 6.
e) imprimir a média de idade por faixa, como por exemplo: 
    Menores: 8,4.
    Adultos: 40. 
    Idosos: 74.
f) imprimir a média geral, como por exemplo: 
Média geral: 42,875.
 

Algoritmos

UNIASSELVI


5 resposta(s)

User badge image

I Truck

Há mais de um mês

Desenvolvi, quase todo o algoritmo sozinho(aprendi muito), mas tive ajuda no fórum do Clube do Hardware, Na parte da impressão dads faixa etárias. Algo positivo por lá é que eles não lhe dão o codígo de mão beijada, o intuito e segundo a filosofia é voçê aprender. Dão dicas de qual é o melhor caminho a seguir. Mesmo assim, ainda tenho dificuldade,como vê na parte da impressão das faixas etárias, ainda imprime os zeros, o ideal era imprimir apenas as idades acima de 0 (zero). Mas como ainda não consegui e está findando o tempo de entregar a atividades, deixo o algoritmo aqui, caso alguém precisar.

Baixei o VisualAG a versão 3.07, ficou bugado, dando erro de sintaxe, só fui descobrir quando coloquei o codigo no forum do Clube do Hardware, para pedir ajuda, foi quando um dos membros informou que estava rodado normalmente e que eu deveria fazer um downgrade do aplicativo, baixei a versão anterior e deu certo. Perdi muito tempo (falta de pratica).

Deixa de conversa, aqui o algoritmo, melhorias seria bem vindas.

algoritmo "vetorContSomaMedia1"
// Ler 3 idades e armazena nas vetores correspondente
// conta quantas idades foi inseridas em cada vetores
// faz as medias das faixa etárias e a geral

var
    idade: vetor[1..3] de inteiro
    menor: vetor[1..3] de inteiro
    adulto: vetor[1..3] de inteiro
    idoso: vetor[1..3] de inteiro
    i: inteiro
    ci, cm, ca, cid: inteiro
    si, sm, sa, sid: inteiro
    mi, mm, ma, mid: real

inicio

escreval("Digite 3 idades:")

para i de 1 ate 3 faca
  leia(idade[i])
  ci := ci + 1
  si := si + idade[i]
  mi <- si / ci

         se (idade[i] >= 0) e (idade[i] <= 18) entao
            menor[i] <- idade[i]
             cm := cm + 1    // contador
             sm := sm + idade[i]        // soma das idades
             mm <- sm / cm        // média das idades
         fimse

         se (idade[i] >= 19) e (idade[i] <=60) entao
            adulto[i] <- idade[i]
             ca := ca + 1
             sa := sa + idade[i]
             ma <- sa / ca
         fimse

         se idade[i] > 61 entao
            idoso[i] <- idade[i]
            cid := cid + 1
            sid := sid + idade[i]
            mid <- sid / cid
         fimse
fimpara

limpatela

// Impressão das idades por faixas etárias <-ESSA PARTE AQUI TIVE AJUDA
escreval("Idades por faixa etária")
   escreva ("Menores: ")
   para i de 1 ate ci faca
      escreva (menor[i], ",")
   fimPara
   escreval("")
   escreva ("Adultos: ")
   para i de 1 ate ci faca
      escreva (adulto[i], ",")
   fimPara
   escreval("")
      escreva ("Idosos : ")
   para i de 1 ate ci faca
      escreva (idoso[i], ",")
   fimPara
   escreval("")
   escreval("")

escreval("-------------------------------------------------------------------")

// Impressão de quantidades de pessoas por faixa etária e geral
escreval("Quantidade de pessoas da faixa etária dos Menores: ", cm)
escreval("Quantidade de pessoas da faixa etária dos Adultos: ", ca)
escreval("Quantidade de pessoas da faixa etária dos Idosos : ", cid)

escreval("-------------------------------------------------------------------")

// Média das idades por faixas etárias e geral
escreval("Média da faixa etária dos Menores: ", mm)
escreval("Média da faixa etária dos Adultos: ", ma)
escreval("Média da faixa etária dos Idosos : ", mid)

escreval("-------------------------------------------------------------------")

// Média geral de todas as idades
escreva("Média geral de todas idades: ", mi)

fimalgoritmo

Desenvolvi, quase todo o algoritmo sozinho(aprendi muito), mas tive ajuda no fórum do Clube do Hardware, Na parte da impressão dads faixa etárias. Algo positivo por lá é que eles não lhe dão o codígo de mão beijada, o intuito e segundo a filosofia é voçê aprender. Dão dicas de qual é o melhor caminho a seguir. Mesmo assim, ainda tenho dificuldade,como vê na parte da impressão das faixas etárias, ainda imprime os zeros, o ideal era imprimir apenas as idades acima de 0 (zero). Mas como ainda não consegui e está findando o tempo de entregar a atividades, deixo o algoritmo aqui, caso alguém precisar.

Baixei o VisualAG a versão 3.07, ficou bugado, dando erro de sintaxe, só fui descobrir quando coloquei o codigo no forum do Clube do Hardware, para pedir ajuda, foi quando um dos membros informou que estava rodado normalmente e que eu deveria fazer um downgrade do aplicativo, baixei a versão anterior e deu certo. Perdi muito tempo (falta de pratica).

Deixa de conversa, aqui o algoritmo, melhorias seria bem vindas.

algoritmo "vetorContSomaMedia1"
// Ler 3 idades e armazena nas vetores correspondente
// conta quantas idades foi inseridas em cada vetores
// faz as medias das faixa etárias e a geral

var
    idade: vetor[1..3] de inteiro
    menor: vetor[1..3] de inteiro
    adulto: vetor[1..3] de inteiro
    idoso: vetor[1..3] de inteiro
    i: inteiro
    ci, cm, ca, cid: inteiro
    si, sm, sa, sid: inteiro
    mi, mm, ma, mid: real

inicio

escreval("Digite 3 idades:")

para i de 1 ate 3 faca
  leia(idade[i])
  ci := ci + 1
  si := si + idade[i]
  mi <- si / ci

         se (idade[i] >= 0) e (idade[i] <= 18) entao
            menor[i] <- idade[i]
             cm := cm + 1    // contador
             sm := sm + idade[i]        // soma das idades
             mm <- sm / cm        // média das idades
         fimse

         se (idade[i] >= 19) e (idade[i] <=60) entao
            adulto[i] <- idade[i]
             ca := ca + 1
             sa := sa + idade[i]
             ma <- sa / ca
         fimse

         se idade[i] > 61 entao
            idoso[i] <- idade[i]
            cid := cid + 1
            sid := sid + idade[i]
            mid <- sid / cid
         fimse
fimpara

limpatela

// Impressão das idades por faixas etárias <-ESSA PARTE AQUI TIVE AJUDA
escreval("Idades por faixa etária")
   escreva ("Menores: ")
   para i de 1 ate ci faca
      escreva (menor[i], ",")
   fimPara
   escreval("")
   escreva ("Adultos: ")
   para i de 1 ate ci faca
      escreva (adulto[i], ",")
   fimPara
   escreval("")
      escreva ("Idosos : ")
   para i de 1 ate ci faca
      escreva (idoso[i], ",")
   fimPara
   escreval("")
   escreval("")

escreval("-------------------------------------------------------------------")

// Impressão de quantidades de pessoas por faixa etária e geral
escreval("Quantidade de pessoas da faixa etária dos Menores: ", cm)
escreval("Quantidade de pessoas da faixa etária dos Adultos: ", ca)
escreval("Quantidade de pessoas da faixa etária dos Idosos : ", cid)

escreval("-------------------------------------------------------------------")

// Média das idades por faixas etárias e geral
escreval("Média da faixa etária dos Menores: ", mm)
escreval("Média da faixa etária dos Adultos: ", ma)
escreval("Média da faixa etária dos Idosos : ", mid)

escreval("-------------------------------------------------------------------")

// Média geral de todas as idades
escreva("Média geral de todas idades: ", mi)

fimalgoritmo

User badge image

Patricia Carvalho

Há mais de um mês

Var

// Seção de Declarações das variáveis 

idade: vetor [1..16] de Inteiro

menor: vetor [1..16] de Inteiro

adulto: vetor [1..16] de Inteiro

idoso: vetor [1..16] de Inteiro

i: Inteiro

ci, cm, ca, cid: Inteiro

si, sm, sa, sid: Inteiro

mi, mm, ma, mid: Real


Inicio

// Seção de Comandos, procedimento, funções, operadores, etc... 

Escreval ("Digite dezesseis idades diferentes:")

Para i de 1 ate 16 faca

Leia (idade[i])

ci:=ci+1

si:=si+idade[i]

mi <- si/ci


  Se (idade[i]>=0) e (idade[i]<=18) Entao

menor[i]<-idade[i]

  cm:=cm+1

  sm:=sm+idade[i]

  mm<-sm/cm

  Fimse


  Se (idade[i]>=19) e (idade[i]<=60) Entao

adulto[i]<-idade[i]

   ca:=ca+1

   sa:=sa+idade[i]

   ma<-sa/ca

   Fimse

    

   Se (idade[i] > 60) Entao

idoso[i]<-idade[i]

     cid:=cid+1

     sid:=sid+idade [i]

     mid<-sid/cid

     Fimse

     

  Fimpara

Escreval ("Idades por faixa etária")

   Escreval ("Menores: ")

Para i de 1 ate ci faca

   Escreval (menor[i], ", ")

Fimpara

Escreval ("Adultos: ")

Para i de 1 ate ci faca

   Escreval (adulto[i], ", ")

Fimpara

Escreval ("Idosos: ")

Para i de 1 ate ci faca

   Escreval (idoso[i], ", ")

Fimpara

Escreval ("Quantidade de pessoas por faixa etaria dos menores:", cm)

Escreval ("Quantidade de pessoas por faixa etaria dos adultos:", ca)

Escreval ("Quantidade de pessoas por faixa etaria dos idosos:", cid)

Escreval ("Media faixa etaria dos menores:", mm)

Escreval ("Media faixa etaria dos adultos:", ma)

Escreval ("Media da faixa etaria dos idosos:", mid)

Escreval ("Media geral de todas as idades:", mi)


Fimalgoritmo

Essa pergunta já foi respondida por um dos nossos estudantes