A maior rede de estudos do Brasil

Em que ocasiões se usa o switch


3 resposta(s)

User badge image

Leo

Há mais de um mês

Você vai usar sempre que você puder dar opções a sua resposta. O if checa se aquela condicional é verdadeira se não passa para else if e assim por diante, até testar tudo.

O switch case, você vai usar quando você tiver muitas opções. Como nesse caso feito em visualG

algoritmo

// Autor : Leonardo Pinto Silva Calazans

// Matricula: 2020101772

var

  nome, mesImprime:caracter

  dia, mes, ano, idade:inteiro

inicio

// Seção de Comandos 

  escreva("Nome: ")

  leia(nome)

  escreval("Data de nascimento - Exemplo 13 09 1992")

  escreva("Dia: ")

  leia(dia)

  escreva("Mes: ")

  leia(mes)

  escreva("Ano: ")

  leia(ano)

  

  escolha (mes)

  caso 1

    mesImprime <- "janeiro"

  caso 2

    mesImprime <- "fevereiro"

  caso 3

    mesImprime <- "março"

  caso 4

    mesImprime <- "abril"

  caso 5

    mesImprime <- "maio"

  caso 6

    mesImprime <- "junho"

  caso 7

    mesImprime <- "julho"

  caso 8

    mesImprime <- "agosto"

  caso 9

    mesImprime <- "setembro"

  caso 10

    mesImprime <- "outubro"

  caso 11

    mesImprime <- "novembro"

  caso 12

    mesImprime <- "dezembro"

  fimescolha


  idade <- 2020-ano


  limpatela


  escreval("Aluno: ",nome," tem",idade," anos.")

  escreval("Nascido em",dia," de ",mesImprime," de",ano)



fimalgoritmo


Você vai usar sempre que você puder dar opções a sua resposta. O if checa se aquela condicional é verdadeira se não passa para else if e assim por diante, até testar tudo.

O switch case, você vai usar quando você tiver muitas opções. Como nesse caso feito em visualG

algoritmo

// Autor : Leonardo Pinto Silva Calazans

// Matricula: 2020101772

var

  nome, mesImprime:caracter

  dia, mes, ano, idade:inteiro

inicio

// Seção de Comandos 

  escreva("Nome: ")

  leia(nome)

  escreval("Data de nascimento - Exemplo 13 09 1992")

  escreva("Dia: ")

  leia(dia)

  escreva("Mes: ")

  leia(mes)

  escreva("Ano: ")

  leia(ano)

  

  escolha (mes)

  caso 1

    mesImprime <- "janeiro"

  caso 2

    mesImprime <- "fevereiro"

  caso 3

    mesImprime <- "março"

  caso 4

    mesImprime <- "abril"

  caso 5

    mesImprime <- "maio"

  caso 6

    mesImprime <- "junho"

  caso 7

    mesImprime <- "julho"

  caso 8

    mesImprime <- "agosto"

  caso 9

    mesImprime <- "setembro"

  caso 10

    mesImprime <- "outubro"

  caso 11

    mesImprime <- "novembro"

  caso 12

    mesImprime <- "dezembro"

  fimescolha


  idade <- 2020-ano


  limpatela


  escreval("Aluno: ",nome," tem",idade," anos.")

  escreval("Nascido em",dia," de ",mesImprime," de",ano)



fimalgoritmo


User badge image

Raphael

Há mais de um mês

A instrução switch é similar a uma série de instruções IF sobre a mesma expressão. Em muitas ocasiões, você pode querer comparar a mesma variável (ou expressão) com muitos valores diferentes, executando uma peça diferente do código dependendo de qual valor ele se encaixar. Este é exatamente o que a instrução switch faz.

Essa pergunta já foi respondida por um dos nossos estudantes