A maior rede de estudos do Brasil

Elabore um algoritmo que calcule o total de números primos entre 1 e 1000 utilizando a estrutura de repetição para.

AlgoritmosFASM

2 resposta(s)

User badge image

José

Há mais de um mês

Var
   Cont1, N, divisores, Cont2, primo: inteiro

Inicio
   para Cont1 de 1 ate 1000 faca
      N <- Cont1
      divisores <- 0
      para Cont2 de 1 ate N faca
         se (N % Cont2 = 0) então
            divisores <- divisores + 1
         fimse
      fimpara
      se (divisores = 2) então
         primo <- primo + 1
      fimse
   fimpara

   escreval("Total de números primos: ", primo)

Fimalgoritmo


Var
   Cont1, N, divisores, Cont2, primo: inteiro

Inicio
   para Cont1 de 1 ate 1000 faca
      N <- Cont1
      divisores <- 0
      para Cont2 de 1 ate N faca
         se (N % Cont2 = 0) então
            divisores <- divisores + 1
         fimse
      fimpara
      se (divisores = 2) então
         primo <- primo + 1
      fimse
   fimpara

   escreval("Total de números primos: ", primo)

Fimalgoritmo


User badge image

João Vitor

Há mais de um mês

Var
   Cont1, N, divisores, Cont2, primo: inteiro

Inicio
   para Cont1 de 1 ate 1000 faca
      N <- Cont1
      divisores <- 0
      para Cont2 de 1 ate N faca
         se (N % Cont2 = 0) então
            divisores <- divisores + 1
         fimse
      fimpara
      se (divisores = 2) então
         primo <- primo + 1
      fimse
   fimpara

   escreval("Total de números primos: ", primo)

Fimalgoritmo


Essa pergunta já foi respondida por um dos nossos estudantes