A maior rede de estudos do Brasil

Grátis
123 pág.
lógica e algoritmo apol 1 a 5

Pré-visualização | Página 3 de 9

(n1>n3) e (n2>n3) entao 
            escreva (" n1>n2>n3 ", n1,">", n2,">", n3)
  fimse
  se (n1>n3) e (n1>n2) e (n3>n2) entao
        escreva (" n1>n3>n2 ", n1,">", n3,">", n2)
  fimse
C
Você acertou!
Slides e Vídeoaula 03 

���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
  se (n1>n2) e (n1=n3) e (n2<>n3) entao 
            escreva (" n1>n2>n3 ", n1,">", n2,">", n3)
  fimse
  se (n1>n3) e (n1>n2) e (n3>n2) entao
        escreva (" n1>n3>n2 ", n1,">", n3,">", n2)
  fimse
D   se (n1>n2) e (n1<n3) e (n2>n3) entao 
            escreva (" n1>n2>n3 ", n1,">", n2,">", n3)
  fimse
  se (n1>n3) e (n1<n2) e (n3>n2) entao
        escreva (" n1>n3>n2 ", n1,">", n3,">", n2)
  fimse
Questão 7/10
Para o algoritmo abaixo, identifique nas alternativas a parte de código que, inserida na linha faltante, efetuaria o cálculo correto: 
Algoritmo expoente
algoritmo "expon"
// Função : Calcular um numero elevado a outro
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
// Autor : Profa. Maristela.
// Data : 12/03/2015
// Seção de Declarações
var
   result, base, expo: real
 
inicio
// Seção de Comandos
   escreval("Digite um valor para a base : ")
   leia(base)
   escreval("Digite um valor para o expoente : ")
   leia(expo)
  
   ____________________________
 
   escreval("")
   escreva(base, " elevado a ",expo, " vale ", result)
  
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
fimalgoritmo 
A result<-base***expo 
B result<-^base*expo 
C result<-base^expo
D result<-base*(expo)^2 
Questão 8/10
Para o algoritmo abaixo, identifique qual a parte de código representaria melhor a entrada dos dados: 
Você acertou!
Slides e vídeoaula 03.

���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
A
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
escreval("Digite um valor o raio : ") 
   leia(raio)
escreval(“Digite o valor de Pi:”)
   leia(Pi) 
B escreval("Digite um valor o raio : ") 
   leia(raio) 
C escreval("Digite um valor o raio : ") 
   leia(raio)
escreval(“Digite o valor de Pi:”)
D leia(raio)
Questão 9/10
Para o algoritmo abaixo, identifique o melhor enunciado para o problema: 
Você acertou!
Slides e videoaula 03

���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
A
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
Faça um programa que receba um número positivo e maior que zero, calcule mostre: 
O número recebido ao quadrado;
O número recebido ao cubo;
O dobro do número. 
B Faça um programa que receba um número qualquer, calcule mostre: 
O número recebido ao quadrado;
O número recebido ao cubo;
O dobro do número.
C Faça um programa que receba um número positivo e maior que zero, calcule mostre: 
O número recebido ao quadrado;
O dobro do número.
O número recebido ao cubo;
D
Você acertou!
Slides e videoaula 03

���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
Faça um programa que receba um número qualquer, calcule mostre: 
O número recebido ao cubo;
O dobro do número.
O número recebido ao quadrado;
Questão 10/10
Para o algoritmo abaixo, identifique o melhor enunciado para o problema: 
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
A Faça um programa que receba a data de nascimento de uma pessoa e a data atual, calcule e mostre: 
Quantos anos a pessoa terá em 2020.
A idade da pessoa;
B Faça um programa que receba o ano de nascimento de uma pessoa e idade da pessoa, calcule e mostre: 
O ano atual;
Quantos anos a pessoa terá em 2021.
C Faça um programa que receba o ano de nascimento de uma pessoa e o ano atual, calcule mostre: 
A idade da pessoa;
Quantos anos a pessoa terá em 2020.
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
D Faça um programa que receba o ano de nascimento de uma pessoa e o ano atual, confira se o ano atual é maior que
o ano de nascimento, calcule e mostre: 
A idade da pessoa;
Quantos anos a pessoa terá em 2020.
Você acertou!
Slides e videoaula 03.

���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� ����
APOL 3
PROTOCOLO: 20150916122455247B96EARTUR CEZAR BORGES DOS SANTOS - RU: 1224552 Nota: 100
Disciplina(s):
Lógica de Programação e Algoritmos
Lógica de Programação e Algoritmos
Data de início: 16/09/2015 12:38
Prazo máximo entrega: - 
Data de entrega: 16/09/2015 18:43
Questão 1/10
Para o algoritmo abaixo, identifique qual a parte de código preencheria a parte faltante (substitui o quadro): 
algoritmo "prog1"
var
x, idade,crianca,preadole,adolescente,adulto: inteiro
 
inicio
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� ����
// Seção de Comandos
para x de 1 ate 10 faca
     escreva("Digite uma idade: ")
     leia(idade)
     se idade<=11 entao
        crianca<-crianca+1
     fimse 
+----------------------------------------+ 
|                                                                                                 | 
|                                                                                                 | 
|                                                                                                 | 
|                                                                                                 | 
|                                                                                                 | 
+----------------------------------------+ 
  se (idade>14) e (idade<=17) entao
        adolescente<-adolescente+1
     fimse
     se idade >= 18 entao
        adulto<-adulto+1
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� ����
     fimse
fimpara
   escreval("*** Totais por faixa-etária ***")
   escreval("Número de criancas: ",crianca)
   escreval("Número de pre-adolescentes: ",preadole)
   escreval("Número de adolescentes: ",adolescente)
   escreval("Número de adultos: ",adulto)
fimalgoritmo
A se (idade>12) e (idade<=14) entao 
        preadole<-preadole+1
     fimse
B se (idade>=11) e (idade<=14) entao 
        preadole<-preadole+1
     fimse
C se (idade>11) e (idade<=14) entao 
        preadole<-preadole+1
     fimse
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� ����
D se (idade>11) e (idade<14) entao 
        preadole<-preadole+1
     fimse
Questão 2/10
Para o algoritmo abaixo, qual a melhor substituição para que o programa execute n vezes a repetição: 
algoritmo "prog2"
var
x, idade,crianca,preadole,adolescente,adulto: inteiro
 
inicio
// Seção de Comandos
 
para x de 1 ate 10 faca