A maior rede de estudos do Brasil

Grátis
123 pág.
lógica e algoritmo apol 1 a 5

Pré-visualização | Página 8 de 9

fimpara
fimpara
 
limpatela
 
escreval("***** Resultados da matriz *****")
para i de 1 ate m faca
  para j de 1 ate n faca
     escreva(matriz[i,j])
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
  fimpara
     escreval("")
fimpara
 
fimalgoritmo
A 2 1 3 
2 1 3
B 1 2 3 
1 2 3
C 2 3 4 
2 3 4
D 2 2 2 
2 2 2
Você acertou!
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
Questão 10/10
Para o algoritmo abaixo, qual deveria ser a saída para uma matriz 5X5? 
algoritmo "matriz"
 
var
 
  matriz:vetor[1..10,1..10] de inteiro
  i,j,m,n:inteiro
 
inicio
 
escreval("***** Entrada de Dados *****")
escreval("")
escreva("Digite o numero de linhas e o numero de colunas para matriz:")
leia(m,n)
para i de 1 ate m  faca
  para j de 1 ate n faca
       escreva("Digite um valor para linha:",i," coluna:",j,":")
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
       matriz[i,j]<-j+i
  fimpara
fimpara
 
limpatela
 
escreval("***** Resultados da matriz *****")
para i de 1 ate m faca
  para j de 1 ate n faca
     escreva(matriz[i,j])
  fimpara
     escreval("")
fimpara
 
fimalgoritmo
A
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
2 3 4 5 6 
4 5 6 7 8
5 6 7 8 9
6 7 8 9 10
7 8 9 10 11
B 2 3 4 5 6 
3 4 5 6 7
4 5 6 7 8
5 6 7 8 9
6 7 8 9 10
C 1 3 4 5 6 
2 5 6 7 8
3 6 7 8 9
4 7 8 9 10
5 8 9 10 11
Você acertou!
Conforme apresentado no material e videoaulas .

���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
D 1 2 3 4 5 
2 4 5 6 7
3 5 6 7 8
4 6 7 8 9
5 7 8 9 10
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� ����
APOL 5
PROTOCOLO: 2015100212245524E12C4ARTUR CEZAR BORGES DOS SANTOS - RU: 1224552 Nota: 100
Disciplina(s):
Lógica de Programação e Algoritmos
Data de início: 02/10/2015 21:01
Prazo máximo entrega: - 
Data de entrega: 02/10/2015 21:19
Questão 1/10
Considerando o bloco de código de um algoritmo mostrado abaixo qual seria a alternativa adequada para substituí-lo? 
preco[1]<-150.00
preco [2]<-250.00
preco[3]<-10.00
preco [4]<-40.00
preco[5]<-120.00
preco [6]<-500.00
preco[7]<-12.00
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� ����
preco [8]<-13.00 
A  n<-8 
 para i de 1 ate n faca
    leia(preco(i))   
 fimpara 
B  n<-8 
 para i de 1 ate n faca
    leia(preco[i])   
 fimpara 
C
Você acertou!
Assunto das aulas 7, 8, 9 e 10

���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� ����
para i de 1 ate n faca 
    leia(preco(k))   
fimpara
D para i de 1 ate n faca 
    leia(preco)   
fimpara
Questão 2/10
Avalie o bloco de código de um algoritmo mostrado abaixo, e selecione a alternativa adequada para substituí-lo. 
preco[1,1]<-1 
preco [1,2]<-2
preco[1,3]<-3
preco [1,4]<-4
preco[2,1]<-23.00
preco [2,2]<-500.00
preco[2,3]<-12.00
preco [2,4]<-13.00 
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� ����
A para i de 1 ate 2 faca 
     para j de 1 ate 4 faca
         leia(preco[i,j])
     fimpara
fimpara
B para i de 1 ate 2 faca 
     para j de 1 ate 4 faca
         leia(preco(i,j))
     fimpara
fimpara
C
Você acertou!
Conteúdo abordado nas aulas 7, 8, 9 e 10

���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� ����
para i de 1 ate 2 faca 
     para j de 1 ate 4 faca
         leia(preco[j,i])
     fimpara
fimpara
D para i de 1 ate 2 faca 
     para j de 1 ate 4 faca
         leia(preco[i])
     fimpara
fimpara
Questão 3/10
O que a função definida no algoritmo abaixo faz? 
 
algoritmo "Função"
// Seção de Declarações
var
 
n1,n2,resultado1:real
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� ����
 
funcao fsx(v1,v2:real):real
var
  total:real
inicio
  total<-v1+(v2*v2)
  retorne total
fimfuncao
  
inicio
// Seção de Comandos
 
escreva("Digite um valor:")
leia(n1)
escreva("Digite o segundo valor:")
leia(n2)
 
resultado1<-fsx(n1,n2)
 
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� ����
escreval("O valor da operação de ",n1," com ",n2," =",resultado1)
  
fimalgoritmo
A A soma dos quadrados dos valores. 
B A soma do primeiro valor com o quadrado do segundo valor. 
C A soma do quadrado do primeiro valor pelo segundo valor. 
D O quadrado das somas dos valores. 
Questão 4/10
Para que o programa abaixo faça a divisão de dois valores, sendo o primeiro pelo segundo, quais seriam as linhas de código mais
adequadas a substituirem as linhas pontilhadas? 
Você acertou!
Conteúdo abordado nas aulas 7, 8, 9 e 10.

���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� ����
algoritmo "Função"
// Seção de Declarações
var
 
n1,n2,x:real
 
funcao fsx(v1,v2:real):real
var
total:real
............................................
............................................
............................................
 
fimfuncao
 
 
inicio
// Seção de Comandos
 
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� ����
escreva("Digite um valor:")
leia(n1)
escreva("Digite o segundo valor:")
leia(n2)
 
x<-fsx(n1,n2)
 
escreval("O valor da operação de ",n1," com ",n2," =",x)
 
 fimalgoritmo
A inicio 
total<-v1/v2
retorne total
Você acertou!
Conteúdo abordado nas aulas 7, 8, 9 e 10. 

���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
B inicio 
total<-v1/2
retorne resultado
C inicio 
 total<-v2/v1
 retorne total
D inicio 
total<-v2/2
retorne resultado
Questão 5/10
Para que o programa abaixo faça a média ponderada, quais seriam as linhas de código mais adequadas para substituírem a parte
pontilhada? 
 
algoritmo "Função"
// Seção de Declarações
var
 
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR�� �����
n1,n2,n3,n4,x:real
 
funcao fsx(v1,v2,v3,v4:real):real
var
total:real
..........................
..........................
..........................
 
fimfuncao
 
inicio
// Seção de Comandos
 
escreva("Digite o primeiro valor:")
leia(n1)
escreva("Digite o segundo valor:")
leia(n2)
escreva("Digite o peso do primeiro valor:")
���������� $9$�81,9,5786
KWWS���XQLYLUWXV�����������VD�HDVW���HOE�DPD]RQDZV�FRP�DYD�ZHE���DYD�$YDOLDFDR8VXDULR+LVWRULFR�������QRYR��