A maior rede de estudos do Brasil

Grátis
exe 4 algoritimo

Pré-visualização | Página 1 de 1

algoritmo "semnome"
// Função :
// Autor :
// Data : 16/09/2015
// Seção de Declarações
var
per:logico
n1,n2,n3,i,b,soma:inteiro
nome:literal
inicio
soma <- 0
per <- falso
para b <- 1 ate 15 faca
 escreval("Informe o nome do acadêmico")
 leia(nome)
 escreval("Informe os três numeros escolhidos de 1 até 5000 apenas.")
 leia(n1,n2,n3)
 se (n1 > 1) e (n1 < 5000) entao
 para i <- 1 ate (n1 -1) faca
 se n1 mod i = 0 entao
 soma <- soma + i
 fimse
 se soma = n1 entao
 per <- verdadeiro
 fimse
 fimpara
 fimse
 soma <- 0
 i <- 0
 se (n2 > 1) e (n2 < 5000) entao
 para i <- 1 ate n2 faca
 se n2 mod i = 0 entao
 soma <- soma + i
 fimse
 se soma = n2 entao
 per <- verdadeiro
 fimse
 fimpara
 fimse
 soma <- 0
 i <- 0
 se (n3 > 1) e (n3 < 5000) entao
 para i <- 1 ate n3 faca
 se n3 mod i = 0 entao
 soma <- soma + i
 fimse
 se soma = n3 entao
 per <- verdadeiro
 fimse
 fimpara
 fimse
 se per = verdadeiro entao
 escreval("Cara de sorte!")
 escreval("Parabéns!!! Você acaba de ganhar um PEN DRIVE 32GB! Uhuuuul!")
 senao
 escreval("Não ganhou nada")
 fimse
fimpara
// Seção de Comandos
fimalgoritmo

Crie agora seu perfil grátis para visualizar sem restrições.