A maior rede de estudos do Brasil

Vetor.

Faça um algoritmo em Portugol IDE para ler um vetor A com 8 elementos e um vetor B com 10 elementos do tipo INTEIRO.

Gere um vetor C apenas com os elementos de A que NÃO existem em B.

Imprima os três vetores, cada um em uma linha, com os elementos separados por espaço em branco.


4 resposta(s) - Contém resposta de Especialista

User badge image

RD Resoluções Verified user icon

Há mais de um mês

Inicialmente devemos definir os vetores que serão utilizados.

Var

A:vetor[1..8]de inteiro

B :vetor[1..10]de inteiro

i,j,h,s: inteiro

c: vetor[1..8] de inteiro


Assim, podemos receber os valores do vetor A e depois do vetor B.

inicio

para i de 1 ate 8 faca

escreva("Digite o valor de A")

leia(A[i])

fimpara

para i de 1 ate 10 faca

escreva("Digite o valor de B")

leia(B[i])

fimpara


Agora devemos comparar o que não existe em B que existe em A, utilizando uma flag s, caso s seja 1, então o número existe em B e não deve ser salvo, caso contrário será salvo em c.

h<-1

para i de 1 ate 8 faca

para j de 1 ate 10 faca

se A[i]=B[j] entao

s<-1

fimse

fimpara

se s=0 entao

c[h]<-A[i]

h<-h+1

fimse

s<-0

fimpara

Agora basta apresentar ao usuário os 3 vetores e finalizar o algoritmo.

para i de 1 ate 8 faca

escreva("",A[i])

fimpara

escreval("")

para i de 1 ate 10 faca

escreva("",B[i])

fimpara

escreval("")

para i de 1 ate 8 faca

escreva("",c[i])

fimpara

Fimalgoritmo

Inicialmente devemos definir os vetores que serão utilizados.

Var

A:vetor[1..8]de inteiro

B :vetor[1..10]de inteiro

i,j,h,s: inteiro

c: vetor[1..8] de inteiro


Assim, podemos receber os valores do vetor A e depois do vetor B.

inicio

para i de 1 ate 8 faca

escreva("Digite o valor de A")

leia(A[i])

fimpara

para i de 1 ate 10 faca

escreva("Digite o valor de B")

leia(B[i])

fimpara


Agora devemos comparar o que não existe em B que existe em A, utilizando uma flag s, caso s seja 1, então o número existe em B e não deve ser salvo, caso contrário será salvo em c.

h<-1

para i de 1 ate 8 faca

para j de 1 ate 10 faca

se A[i]=B[j] entao

s<-1

fimse

fimpara

se s=0 entao

c[h]<-A[i]

h<-h+1

fimse

s<-0

fimpara

Agora basta apresentar ao usuário os 3 vetores e finalizar o algoritmo.

para i de 1 ate 8 faca

escreva("",A[i])

fimpara

escreval("")

para i de 1 ate 10 faca

escreva("",B[i])

fimpara

escreval("")

para i de 1 ate 8 faca

escreva("",c[i])

fimpara

Fimalgoritmo

User badge image

Stefano

Há mais de um mês

Inicio

    Vetor A;

    Vetor B;

    Vetor C;

    i <- 0;

    Enquanto A And B

         Se A[i] != B[i]

              C[i] <- A[i]

         Fim Se

         i <- i+1

   Fim Enquanto

   Imprime A;

   Imprime B;

   Imprime C;

 

Não conheço muito a notação de portugol, A é um vetor e A[i] é um elemento do vetor.

User badge image

Andre

Há mais de um mês

Inicialmente devemos definir os vetores que serão utilizados.

Var

A:vetor[1..8]de inteiro

B :vetor[1..10]de inteiro

i,j,h,s: inteiro

c: vetor[1..8] de inteiro


Assim, podemos receber os valores do vetor A e depois do vetor B.

inicio

para i de 1 ate 8 faca

escreva("Digite o valor de A")

leia(A[i])

fimpara

para i de 1 ate 10 faca

escreva("Digite o valor de B")

leia(B[i])

fimpara


Agora devemos comparar o que não existe em B que existe em A, utilizando uma flag s, caso s seja 1, então o número existe em B e não deve ser salvo, caso contrário será salvo em c.

h<-1

para i de 1 ate 8 faca

para j de 1 ate 10 faca

se A[i]=B[j] entao

s<-1

fimse

fimpara

se s=0 entao

c[h]<-A[i]

h<-h+1

fimse

s<-0

fimpara

Agora basta apresentar ao usuário os 3 vetores e finalizar o algoritmo.

para i de 1 ate 8 faca

escreva("",A[i])

fimpara

escreval("")

para i de 1 ate 10 faca

escreva("",B[i])

fimpara

escreval("")

para i de 1 ate 8 faca

escreva("",c[i])

fimpara

Fimalgoritmo

User badge image

Andre

Há mais de um mês

Inicialmente devemos definir os vetores que serão utilizados.

Var

A:vetor[1..8]de inteiro

B :vetor[1..10]de inteiro

i,j,h,s: inteiro

c: vetor[1..8] de inteiro


Assim, podemos receber os valores do vetor A e depois do vetor B.

inicio

para i de 1 ate 8 faca

escreva("Digite o valor de A")

leia(A[i])

fimpara

para i de 1 ate 10 faca

escreva("Digite o valor de B")

leia(B[i])

fimpara


Agora devemos comparar o que não existe em B que existe em A, utilizando uma flag s, caso s seja 1, então o número existe em B e não deve ser salvo, caso contrário será salvo em c.

h<-1

para i de 1 ate 8 faca

para j de 1 ate 10 faca

se A[i]=B[j] entao

s<-1

fimse

fimpara

se s=0 entao

c[h]<-A[i]

h<-h+1

fimse

s<-0

fimpara

Agora basta apresentar ao usuário os 3 vetores e finalizar o algoritmo.

para i de 1 ate 8 faca

escreva("",A[i])

fimpara

escreval("")

para i de 1 ate 10 faca

escreva("",B[i])

fimpara

escreval("")

para i de 1 ate 8 faca

escreva("",c[i])

fimpara

Fimalgoritmo

Essa pergunta já foi respondida por um dos nossos especialistas