A maior rede de estudos do Brasil

Faça um algoritmo que leia uma matriz M[10X20] e exiba na tela, a matriz transposta Mt da matriz lida.

Alguém consegue resolver em Portugol?

AlgoritmosFACAPE

5 resposta(s) - Contém resposta de Especialista

User badge image

RD Resoluções Verified user icon

Há mais de um mês

Incialmente devemos compreender que a Matriz transposta é uma operação que transforma as linhas de uma matriz em colunas de uma matriz


Assim, a transposta de M será onde as linhas de M serão correspondentes as colunas de , dessa forma teremos:


Agora, para desenvolvimento do algoritmo em Portugol, utilizaremos o VISUALG 3.0.7, assim temos o programa dividido em tópicos:

Algoritmo

(informações gerais sobre o programa, nome, desenvolvedor...)

var

(Definir variáveis)

Início

(todos comandos do programa)

Fimalgotimo (Relata que o programa chegou ao fim)


Com isso, para iniciar o algoritmo é necessário definir as variáveis que serão utilizadas, logo definiremos as variável M[1...10,1...20] que corresponde a uma matriz de 10 linhas e 20 colunas que será do tipo vetor. Também criaremos as variáveis linhas e colunas do tipo inteiro para controle da Matriz. Assim, utilizando o visual g desenvolvemos as seguintes declarações.

Algoritmo "matriz transposta"

var

linhas, colunas :inteiro

M: vetor[1..10,1..20] de inteiro


Assim, podemos iniciar a lógica do programa que deverá inicialmente receber a matriz M. Com isso utilizaremos laços de repetição para preencher toda a matriz, assim teremos:

Inicio

para linhas de 1 ate 10 faca // varre valores de todas as linhas

para colunas de 1 ate 20 faca // varre valores de todas colunas

escreva("digite os valores") //recebe cada valor

leia(M[i, j]) // salva o valor corresponde aquela linha e coluna

fimpara //Se colunas = 20, o laço de repetição para

fimpara //Se linhas = 10, o laço de repetição para


Quando matriz M estiver totalmente preenchida será necessário realizar o cálculo de sua transposta, assim utilizaremos os mesmos laços considerando que deveremos inverter os valores de linhas e colunas para representação da matriz transposta encerraremos o programa. Dessa forma, teremos:

escreval("Matriz transposta:")

para linhas de 1 ate 10 faca

para colunas de 1 ate 20 faca

escreva(" " ,M[colunas,linhas]) // valores das linhas serão colocados em colunas

fimpara

escreval(" ") // quebra de linha

fimpara

fimalgoritmo

Incialmente devemos compreender que a Matriz transposta é uma operação que transforma as linhas de uma matriz em colunas de uma matriz


Assim, a transposta de M será onde as linhas de M serão correspondentes as colunas de , dessa forma teremos:


Agora, para desenvolvimento do algoritmo em Portugol, utilizaremos o VISUALG 3.0.7, assim temos o programa dividido em tópicos:

Algoritmo

(informações gerais sobre o programa, nome, desenvolvedor...)

var

(Definir variáveis)

Início

(todos comandos do programa)

Fimalgotimo (Relata que o programa chegou ao fim)


Com isso, para iniciar o algoritmo é necessário definir as variáveis que serão utilizadas, logo definiremos as variável M[1...10,1...20] que corresponde a uma matriz de 10 linhas e 20 colunas que será do tipo vetor. Também criaremos as variáveis linhas e colunas do tipo inteiro para controle da Matriz. Assim, utilizando o visual g desenvolvemos as seguintes declarações.

Algoritmo "matriz transposta"

var

linhas, colunas :inteiro

M: vetor[1..10,1..20] de inteiro


Assim, podemos iniciar a lógica do programa que deverá inicialmente receber a matriz M. Com isso utilizaremos laços de repetição para preencher toda a matriz, assim teremos:

Inicio

para linhas de 1 ate 10 faca // varre valores de todas as linhas

para colunas de 1 ate 20 faca // varre valores de todas colunas

escreva("digite os valores") //recebe cada valor

leia(M[i, j]) // salva o valor corresponde aquela linha e coluna

fimpara //Se colunas = 20, o laço de repetição para

fimpara //Se linhas = 10, o laço de repetição para


Quando matriz M estiver totalmente preenchida será necessário realizar o cálculo de sua transposta, assim utilizaremos os mesmos laços considerando que deveremos inverter os valores de linhas e colunas para representação da matriz transposta encerraremos o programa. Dessa forma, teremos:

escreval("Matriz transposta:")

para linhas de 1 ate 10 faca

para colunas de 1 ate 20 faca

escreva(" " ,M[colunas,linhas]) // valores das linhas serão colocados em colunas

fimpara

escreval(" ") // quebra de linha

fimpara

fimalgoritmo

User badge image

Andre

Há mais de um mês

Incialmente devemos compreender que a Matriz transposta é uma operação que transforma as linhas de uma matriz em colunas de uma matriz


Assim, a transposta de M será onde as linhas de M serão correspondentes as colunas de , dessa forma teremos:


Agora, para desenvolvimento do algoritmo em Portugol, utilizaremos o VISUALG 3.0.7, assim temos o programa dividido em tópicos:

Algoritmo

(informações gerais sobre o programa, nome, desenvolvedor...)

var

(Definir variáveis)

Início

(todos comandos do programa)

Fimalgotimo (Relata que o programa chegou ao fim)


Com isso, para iniciar o algoritmo é necessário definir as variáveis que serão utilizadas, logo definiremos as variável M[1...10,1...20] que corresponde a uma matriz de 10 linhas e 20 colunas que será do tipo vetor. Também criaremos as variáveis linhas e colunas do tipo inteiro para controle da Matriz. Assim, utilizando o visual g desenvolvemos as seguintes declarações.

Algoritmo "matriz transposta"

var

linhas, colunas :inteiro

M: vetor[1..10,1..20] de inteiro


Assim, podemos iniciar a lógica do programa que deverá inicialmente receber a matriz M. Com isso utilizaremos laços de repetição para preencher toda a matriz, assim teremos:

Inicio

para linhas de 1 ate 10 faca // varre valores de todas as linhas

para colunas de 1 ate 20 faca // varre valores de todas colunas

escreva("digite os valores") //recebe cada valor

leia(M[i, j]) // salva o valor corresponde aquela linha e coluna

fimpara //Se colunas = 20, o laço de repetição para

fimpara //Se linhas = 10, o laço de repetição para


Quando matriz M estiver totalmente preenchida será necessário realizar o cálculo de sua transposta, assim utilizaremos os mesmos laços considerando que deveremos inverter os valores de linhas e colunas para representação da matriz transposta encerraremos o programa. Dessa forma, teremos:

escreval("Matriz transposta:")

para linhas de 1 ate 10 faca

para colunas de 1 ate 20 faca

escreva(" " ,M[colunas,linhas]) // valores das linhas serão colocados em colunas

fimpara

escreval(" ") // quebra de linha

fimpara

fimalgoritmo

User badge image

Andre

Há mais de um mês

Faça um algoritmo que leia uma matriz M[10X20] e exiba na tela, a matriz transposta Mt da matriz lida.

Alguém consegue resolver em Portugol?


Incialmente devemos compreender que a Matriz transposta é uma operação que transforma as linhas de uma matriz em colunas de uma matriz


Assim, a transposta de M será onde as linhas de M serão correspondentes as colunas de , dessa forma teremos:


Agora, para desenvolvimento do algoritmo em Portugol, utilizaremos o VISUALG 3.0.7, assim temos o programa dividido em tópicos:

Algoritmo

(informações gerais sobre o programa, nome, desenvolvedor...)

var

(Definir variáveis)

Início

(todos comandos do programa)

Fimalgotimo (Relata que o programa chegou ao fim)


Com isso, para iniciar o algoritmo é necessário definir as variáveis que serão utilizadas, logo definiremos as variável M[1...10,1...20] que corresponde a uma matriz de 10 linhas e 20 colunas que será do tipo vetor. Também criaremos as variáveis linhas e colunas do tipo inteiro para controle da Matriz. Assim, utilizando o visual g desenvolvemos as seguintes declarações.

Algoritmo "matriz transposta"

var

linhas, colunas :inteiro

M: vetor[1..10,1..20] de inteiro


Assim, podemos iniciar a lógica do programa que deverá inicialmente receber a matriz M. Com isso utilizaremos laços de repetição para preencher toda a matriz, assim teremos:

Inicio

para linhas de 1 ate 10 faca // varre valores de todas as linhas

para colunas de 1 ate 20 faca // varre valores de todas colunas

escreva("digite os valores") //recebe cada valor

leia(M[i, j]) // salva o valor corresponde aquela linha e coluna

fimpara //Se colunas = 20, o laço de repetição para

fimpara //Se linhas = 10, o laço de repetição para


Quando matriz M estiver totalmente preenchida será necessário realizar o cálculo de sua transposta, assim utilizaremos os mesmos laços considerando que deveremos inverter os valores de linhas e colunas para representação da matriz transposta encerraremos o programa. Dessa forma, teremos:

escreval("Matriz transposta:")

para linhas de 1 ate 10 faca

para colunas de 1 ate 20 faca

escreva(" " ,M[colunas,linhas]) // valores das linhas serão colocados em colunas

fimpara

escreval(" ") // quebra de linha

fimpara

fimalgoritmo

User badge image

Eduardo

Há mais de um mês

Testa aí mano: 

ar
matriz : vetor[0..2,0..2] de inteiro
i ,j : inteiro
inicio
para i de 0 ate 2 faca
para j de 0 ate 2 faca
leia(matriz[i,j])
fimpara
fimpara
para j de 0 ate 2 faca
para i de 0 ate 2 faca
Escreva(matriz[i,j])
fimpara
Escreval()
fimpara
fimalgoritmo

Essa pergunta já foi respondida por um dos nossos especialistas