A maior rede de estudos do Brasil

pessoal não estou conseguindo resolver esse exercicio pelo visualg

Crie um algoritmo (1) ler 25 valores e armazenar em um vetor de números inteiros de dimensão adequada. Após a leitura, (2) efetue a leitura de um outro número e busque-o dentro do vetor carregado no passo (1). Por fim, (3) imprima a posição (índice) em que o número lido se encontra.

AlgoritmosIFMT

2 resposta(s) - Contém resposta de Especialista

User badge image

RD Resoluções Verified user icon

Há mais de um mês

Algoritmo "busca"
// Disciplina:
// Algoritmo :
// Função :
// Autor : 
// Data :
var
vetor: vetor [1..25] de inteiro
num: inteiro
inicio
para i de 1 ate 25 faca
    leia(vetor[i])
fimpara
escreval("Digite o numero que deseja buscar: ")
leia(num)
para i de 1 ate 25 faca
    se vetor[i]==num
        escreval("O numero se encontra na posicao ", i)
​​​​​​​    fimse
fimpara
fimalgoritmo
Algoritmo "busca"
// Disciplina:
// Algoritmo :
// Função :
// Autor : 
// Data :
var
vetor: vetor [1..25] de inteiro
num: inteiro
inicio
para i de 1 ate 25 faca
    leia(vetor[i])
fimpara
escreval("Digite o numero que deseja buscar: ")
leia(num)
para i de 1 ate 25 faca
    se vetor[i]==num
        escreval("O numero se encontra na posicao ", i)
​​​​​​​    fimse
fimpara
fimalgoritmo
User badge image

Cicero

Há mais de um mês

tente na linguagem c é mais facil 

Essa pergunta já foi respondida por um dos nossos especialistas