A maior rede de estudos do Brasil

Olá pessoal! Alguém pode me ajudar resolver essa questão?

Elabore um algoritmo utilizando a estrutura de seleção que calcule o que deve ser pago por um projeto, considerando o preço normal de etiqueta e a escolha da condição de pagamento. Utilize os códigos da tabela a seguir para ler qual a condição de pagamento escolhida e efetuar o cálculo adequado, conforme tabela abaixo:

 Código

Condição de pagamento

1

À vista em dinheiro ou cheque, recebe 10% de desconto

2

À vista no cartão de crédito ou débito, recebe 5% de desconto

3

Em duas vezes, preço normal de etiqueta sem juros

4

Em três vezes, preço normal de etiqueta mais juros de 10%

 

Você deverá definir os tipos de variáveis de acordo com o tipo de dado que a variável irá receber. Os comentários não são necessários serem feitos, mas você pode inseri-los para ajudar na construção de seu algoritmo.

 

Algoritmo "Forma de Pagamento"

// Função : Calcular valores a partir da forma de pagamento

// Autor :   Luiz Walnei

// Data : 26/02/2011

// Seção de Declarações 

var

 

vmercadoria:real

forma:real

parcela:real

 

inicio

// Seção de Comandos

 

Escreval ("Entre com o Valor da Mercadoria:")

leia (vmercadoria)

Escreval ("Forma de Pagamento:")

escreval ("Dinheiro digite 1")

escreval ("Cheque Digite 2")

escreval ("Cartão de Crédito Digite 3")

leia(forma)

escreval ("Parcelas:")

escreval ("1 - Á vista")

escreval ("2 - 2 vezes")

escreval ("3 - 3 vezes")

leia (parcela)

 

// Aqui coloquei as condições para a opção em dinheiro

 

SE (forma = 1) E (parcela = 1) ENTAO

ESCREVA ("O Valor a ser Pago é de ", vmercadoria*90/100:2:2, " Reais a Vista - 10% de Desconto")

FIMSE

SE (forma = 1) E (parcela = 2) ENTAO

ESCREVA ("O Valor a ser Pago é 2 Parcelas de: ", vmercadoria/2:2:2, " Reais")

FIMSE

SE (forma = 1) E (parcela = 3) ENTAO

ESCREVA ("O Valor a ser Pago 3 Parcelas de: ", vmercadoria/3+10/100:2:2, " Reais - 10% de Juros")

FIMSE

 

 

//Aqui coloquei as condições de forma de pagamento em cheque.

 

SE (forma = 2) E (parcela = 1) ENTAO

ESCREVA ("O Valor a ser Pago é de ", vmercadoria*95/100:2:2, " Reais a Vista - 5% de Desconto")

FIMSE

SE (forma = 2) E (parcela = 2) ENTAO

ESCREVA ("O Valor a ser Pago é 2 Parcelas de: ", vmercadoria/2:2:2, " Reais")

FIMSE

SE (forma = 2) E (parcela = 3) ENTAO

ESCREVA ("O Valor a ser Pago 3 Parcelas de: ", vmercadoria/3+10/100:2:2, " Reais - 10% de Juros")

 

FIMSE

 

// Pagamento com cartão de crédito

 

SE (forma = 3) E (parcela = 1) ENTAO

ESCREVA ("O Valor a ser Pago é de: ", vmercadoria*110/100:2:2, " Reais a Vista - Taxa de 10% Sobre o Valor da Etiqueta")

FIMSE

SE (forma = 3) E (parcela = 2) ENTAO

ESCREVA ("O Valor a ser Pago é 2 Parcelas de: ", vmercadoria*110/100/2:2:2, " Reais")

FIMSE

SE (forma = 3) E (parcela = 3) ENTAO

ESCREVA ("O Valor a ser Pago 3 Parcelas de: ", vmercadoria*110/100/3:2:2, " Reais - 10% de Juros")

FIMSE

Fimalgoritmo

Algoritmos

IF SUL DE MINAS


5 resposta(s) - Contém resposta de Especialista

User badge image

RD Resoluções Verified user icon

Há mais de um mês

Como resultado do programa temos:


Dessa forma, concluímos que com a linguagem C é possível realizar programas que leia dados e retorne um resultado.

Como resultado do programa temos:


Dessa forma, concluímos que com a linguagem C é possível realizar programas que leia dados e retorne um resultado.

User badge image

Jeniffer Genaotto Vanzin

Há mais de um mês

Você já tentou usar o Switch/Case pra melhorar seu código? Você trabalha com um opção para cada, menos código que usando se/senão.

User badge image

Andre Smaira

Há mais de um mês

Foi utilizando o software Dev C++ para realizar o programa abaixo:

 

Como resultado do programa temos:


Dessa forma, concluímos que com a linguagem C é possível realizar programas que leia dados e retorne um resultado.

User badge image

Andre Smaira

Há mais de um mês

Como resultado do programa temos:


Dessa forma, concluímos que com a linguagem C é possível realizar programas que leia dados e retorne um resultado.

Essa pergunta já foi respondida por um dos nossos especialistas