A maior rede de estudos do Brasil

Grátis
5 pág.
ativ 31699

Pré-visualização | Página 1 de 1

algoritmoS
atividades DA aula 08
Todos os algoritmos desta atividade deverão ser desenvolvidos no VISUALG e enviados no Microsoft Word.
Faça um algoritmo para ler uma matriz 5x5 de números inteiros e ler um número inteiro x. A seguir, o algoritmo deve multiplicar os elementos da segunda coluna da matriz por x e exibir a matriz modificada.
algoritmo "MultColuna2"
// Função : Mostra a multiplicação da segunda coluna
// Autor : Diego Luis Santos Scherer RGM. 343.2427
// Data : 28/05/2018
// Seção de Declarações
var
num: vetor[1..5, 1..5]de inteiro
l, c, x: inteiro
inicio
escreva("Digite um valor para x: ")
leia(x)
escreval()
para l de 1 ate 5 faca
 para c de 1 ate 5 faca
 escreva("Digite um valor para a posição [", l, ",", c, "]: ")
 leia(num[l,c])
 fimpara
fimpara
escreval("1º matriz digitada ")
escreval("===================")
para l de 1 ate 5 faca
 para c de 1 ate 5 faca
 escreva(num[l,c])
 fimpara
 escreval
fimpara
escreval("")
escreval("A multiplicação da segunda coluna ficou: ")
escreval("===========================================")
para l de 1 ate 5 faca
 num[l,2]<-num[l,2]*x
 escreval(num[l,1],num[l,2],num[l,3],num[l,4],num[l,5])
fimpara
fimalgoritmo
Faça um algoritmo para ler uma matriz 5x5 de números inteiros e verificar se a soma da diagonal principal é igual ou não a soma da diagonal secundária.
algoritmo "diagonal"
// Função : Matriz para calcular diagonal principal e secundaria,
// e mostrar se as somas são iguais
// AUTOR : Diego Luis Santos Scherer RGM. 343.2427
// Data : 28/05/2018
// Seção de Declarações
var
m: vetor[1..5, 1..5] de inteiro
l,c,sdp,sds,correspondete: inteiro
inicio
sdp <- 0
para l de 1 ate 5 faca
 para c de 1 ate 5 faca
 escreva("Digite o valor da posição [",l,",",c,"]: ")
 leia (m[l,c])
 se (l = c) entao
 sdp <- sdp + m[l,c]
 senao
 sds <- (m[1,5]+ m[2,4] + m[3,3] + m[4,2] + m[5,1])
 fimse
 fimpara
fimpara
escreval()
se sdp = sds entao
 para l de 1 ate 5 faca
 para c de 1 ate 5 faca
 escreva(m[l,c]:3)
 fimpara
 escreval()
 fimpara
 escreval()
 escreval("a soma das diagonais são iguais ")
 escreval("A soma da diagonal principal é: ",sdp)
escreval("A soma da diagona secundaria é: ",sds)
senao
para l de 1 ate 5 faca
 para c de 1 ate 5 faca
 escreva(m[l,c]:3)
 fimpara
 escreval()
 fimpara
escreval()
escreval("A soma das diagonais são diferentes")
escreval("A soma da diagonal principal é: ",sdp)
escreval("A soma da diagonal secundaria é: ",sds)
fimse
fimalgoritmo
Faça um algoritmo para ler uma matriz 5x5 de inteiros e calcular a sua transposta AT. Exemplo para matriz de ordem 4 (apenas um exemplo!!!):
�		
�
algoritmo "TRANSPOSTA"
// Função : Calcular a matriz transposta de uma outra matriz
// AUTOR : Diego Luis Santos Scherer RGM. 343.2427
// Data : 28/05/2018
var
MP: vetor[1..5, 1..5]de inteiro
MT: vetor[1..5, 1..5]de inteiro
l,c: inteiro
inicio
para l de 1 ate 5 faca
 para c de 1 ate 5 faca
 escreva(" Digite um valor: [", l, ",", c, "] ")
 leia(MP[l,c])
 fimpara
fimpara
escreval("")
escreval("Matriz Principal")
para l de 1 ate 5 faca
 para c de 1 ate 5 faca
 escreva(MP[l,c]:4)
 fimpara
 escreval("")
fimpara
escreval("")
para l de 1 ate 5 faca
 para c de 1 ate 5 faca
 MT[l,c]<-(MP[c,l])
 fimpara
fimpara
escreval("A Sua transposta ")
para c de 1 ate 5 faca
 para l de 1 ate 5 faca
 escreva(MT[c,l]:4)
 fimpara
 escreval("")
fimpara
fimalgoritmo
Faça um algoritmo para ler uma matriz A de ordem 5x5 de números inteiros e verificar se a matriz é ou não simétrica. Dizemos que uma matriz é simétrica quando todo elemento aij é igual ao elemento aji, para todo i, j ≤ 5. Exemplo para matriz simétrica de ordem 4 (apenas um exemplo!!!):
algoritmo "Simetrica"
// Função : Mostar se matriz é simetrica ou não
// Autor: Diego Luis Santos Scherer RGM. 343.2427
// Data : 28/05/2018
var
simetrica: vetor[1..5, 1..5]de inteiro
l,c: inteiro
x: logico
inicio
para l de 1 ate 5 faca
 para c de 1 ate 5 faca
 escreva(" Digite um valor: [", l, ",", c, "] ")
 leia(simetrica[l,c])
 fimpara
fimpara
escreval("")
escreval("==== MATRIZ ====")
para l de 1 ate 5 faca
 para c de 1 ate 5 faca
 escreva(simetrica[l,c]:4)
 fimpara
 escreval("")
fimpara
escreval("")
x<-verdadeiro
para l de 1 ate 5 faca
 para c de 1 ate 5 faca
 se (simetrica[l,c] <> simetrica[c,l]) entao
 x<-falso
 fimse
 fimpara
fimpara
se (x=verdadeiro) entao
 escreval ("A matriz é simetrica ")
senao
 escreval ("A matriz não é simetrica ")
fimse
fimalgoritmo
� EMBED Equation.3 ���
_958850669.unknown
_1572850716.unknown
_958850668.unknown