Buscar

Considere o seguinte algoritmo em pseudocódigo (os dois dígitos à esquerda identificam o número da linha do algoritmo): 01- algoritmo "vetores" 02...

Considere o seguinte algoritmo em pseudocódigo (os dois dígitos à esquerda identificam o número da linha do algoritmo):

01- algoritmo "vetores"
02- var
03- valores: vetor[1..5] de real
04- indice: inteiro
05- inicio
06- para indice de 1 ate 5 passo 1 faca
07- escreva("Digite valor: ")
08- leia(valores[indice])
09- fimpara
10- para indice de 1 ate 5 passo 1 faca
11- escreval("Valor[",indice,"]: ",valores[indice])
12- fimpara
13- fimalgoritmo

Analise as alternativas a seguir e selecione a INCORRETA.


C. Se forem trocados de lugar os blocos de instruções das linhas 06-09 com 10-12, o programa será executado da mesma forma e funcionará corretamente. Os dados serão mostrados e o vetor será lido. Normalmente, o processo de trabalhar com um vetor inclui a leitura ou atribuição de informações para os elementos do vetor e somente depois é possível mostrar o seu conteúdo.

Essa pergunta também está no material:

Estrutura de Dados Homogêneas do tipo vetor exercicios com gabarito
3 pág.

Estrutura de Dados I Escola Superior Aberta do BrasilEscola Superior Aberta do Brasil

💡 1 Resposta

User badge image

Ed Verified user icon

A alternativa incorreta é a C. Se forem trocados de lugar os blocos de instruções das linhas 06-09 com 10-12, o programa não será executado da mesma forma e não funcionará corretamente. Isso ocorre porque o programa primeiro lê os valores do vetor e depois os exibe. Se os blocos de instruções forem trocados, o programa exibirá os valores do vetor antes de lê-los, resultando em valores incorretos ou vazios sendo exibidos.

0
Dislike0

Faça como milhares de estudantes: teste grátis o Passei Direto

Esse e outros conteúdos desbloqueados

16 milhões de materiais de várias disciplinas

Impressão de materiais

Agora você pode testar o

Passei Direto grátis

Você também pode ser Premium ajudando estudantes

✏️ Responder

SetasNegritoItálicoSublinhadoTachadoCitaçãoCódigoLista numeradaLista com marcadoresSubscritoSobrescritoDiminuir recuoAumentar recuoCor da fonteCor de fundoAlinhamentoLimparInserir linkImagemFórmula

Para escrever sua resposta aqui, entre ou crie uma conta.

User badge image

Outros materiais