A maior rede de estudos do Brasil

escreva um algoritmo para ler as medidas dos lados de um retangulo, calcular e escrever as suas areas e medidas da diagonal.

Algoritmos

UNIC


4 resposta(s) - Contém resposta de Especialista

User badge image

RD Resoluções Verified user icon

Há mais de um mês

Para calcular a área de um retângulo/quadrado sabemos que é só multiplicar a base pela altura. Feito isso temos a área total do mesmo, e para obter o valor da diagonal do mesmo, somente precisamos obter a raiz quadrada da área total multiplicado por 2.


algoritmo "Area"

var

altura, base, area: inteiro

diagonal: real

inicio

// Seção de Comandos

escreva("Digite a medida da altura do quadrado em metros: ")

leia(altura)

escreva("Digite a medida da base do quadrado em metros: ")

leia(base)

//Calculando a área do retângulo/quadrado

area <- (altura * base)

//Calcula diagonal

//escreva(raizq(calculo *2)) //Outra Maneira

diagonal <- ((base^2 + altura^2)^(1/2))

//Exibe resultado

escreval("A medida da área do retangulo/quadrado é de: ", area, " metros quadrados")

escreva("A medida da diagonal do retangulo/quadrado é de: ", diagonal, " metros")

fimalgoritmo

Para calcular a área de um retângulo/quadrado sabemos que é só multiplicar a base pela altura. Feito isso temos a área total do mesmo, e para obter o valor da diagonal do mesmo, somente precisamos obter a raiz quadrada da área total multiplicado por 2.


algoritmo "Area"

var

altura, base, area: inteiro

diagonal: real

inicio

// Seção de Comandos

escreva("Digite a medida da altura do quadrado em metros: ")

leia(altura)

escreva("Digite a medida da base do quadrado em metros: ")

leia(base)

//Calculando a área do retângulo/quadrado

area <- (altura * base)

//Calcula diagonal

//escreva(raizq(calculo *2)) //Outra Maneira

diagonal <- ((base^2 + altura^2)^(1/2))

//Exibe resultado

escreval("A medida da área do retangulo/quadrado é de: ", area, " metros quadrados")

escreva("A medida da diagonal do retangulo/quadrado é de: ", diagonal, " metros")

fimalgoritmo

User badge image

Valdi Junior

Há mais de um mês

 

Segue algoritmo (OBS: o algoritmo vai ler a base e a altura e vai imprimir o perimetro, area e diagonal).


var
h, b: inteiro {h = altura. b = base}
area, perimetro, diagonal: real
inicio
escreva ("entre com à altura:  ")
leia (h)
escreva ("entre com a base:  ")
leia (b)
area := (h * b)
perimetro := (h * 2) + (b * 2)
diagonal := raizq(quad(h) + quad(b))
escreval ("Area:  ",area)
escreval ("perimetro:  ",perimetro)
escreval ("diagonal:  ",diagonal)
fimalgoritmo
User badge image

Andre Smaira

Há mais de um mês

escreva um algoritmo para ler as medidas dos lados de um retangulo, calcular e escrever as suas areas e medidas da diagonal.


Para calcular a área de um retângulo/quadrado sabemos que é só multiplicar a base pela altura. Feito isso temos a área total do mesmo, e para obter o valor da diagonal do mesmo, somente precisamos obter a raiz quadrada da área total multiplicado por 2.


algoritmo "Area"

var

altura, base, area: inteiro

diagonal: real

inicio

// Seção de Comandos

escreva("Digite a medida da altura do quadrado em metros: ")

leia(altura)

escreva("Digite a medida da base do quadrado em metros: ")

leia(base)

//Calculando a área do retângulo/quadrado

area <- (altura * base)

//Calcula diagonal

//escreva(raizq(calculo *2)) //Outra Maneira

diagonal <- ((base^2 + altura^2)^(1/2))

//Exibe resultado

escreval("A medida da área do retangulo/quadrado é de: ", area, " metros quadrados")

escreva("A medida da diagonal do retangulo/quadrado é de: ", diagonal, " metros")

fimalgoritmo

User badge image

Andre Smaira

Há mais de um mês

Para calcular a área de um retângulo/quadrado sabemos que é só multiplicar a base pela altura. Feito isso temos a área total do mesmo, e para obter o valor da diagonal do mesmo, somente precisamos obter a raiz quadrada da área total multiplicado por 2.


algoritmo "Area"

var

altura, base, area: inteiro

diagonal: real

inicio

// Seção de Comandos

escreva("Digite a medida da altura do quadrado em metros: ")

leia(altura)

escreva("Digite a medida da base do quadrado em metros: ")

leia(base)

//Calculando a área do retângulo/quadrado

area <- (altura * base)

//Calcula diagonal

//escreva(raizq(calculo *2)) //Outra Maneira

diagonal <- ((base^2 + altura^2)^(1/2))

//Exibe resultado

escreval("A medida da área do retangulo/quadrado é de: ", area, " metros quadrados")

escreva("A medida da diagonal do retangulo/quadrado é de: ", diagonal, " metros")

fimalgoritmo

Essa pergunta já foi respondida por um dos nossos especialistas