A maior rede de estudos do Brasil

criar um algoritmo

Foi feito uma pesquisa para determinar o índice de mortalidade infantil em um certo
período. Fazer um algoritmo que:
• leia inicialmente o número de crianças nascidas no período;
• leia, em seguida, um número indeterminado de linhas, contendo, cada uma, o
sexo de uma criança morta (masculino, feminino) e o número de meses de vida
da criança. a última linha, que não entrará nos cálculos, contém no lugar do
sexo a palavra v̈azio ̈;
• determine e imprima:
– a porcentagem de crianças mortas no período;
– a porcentagem de crianças do sexo masculino mortas no periodo;
– a porcentagem de crianças que viveram 24 meses ou menos no período;


2 resposta(s) - Contém resposta de Especialista

User badge image

RD Resoluções Verified user icon

Há mais de um mês

var 
tot_nasc, num_meses, tot_mortas, tot_masc_mortas, tot_menos_24: inteiro 
sexo: caracter 
inicio 
tot_mortas <- 0 
tot_masc_mortas <- 0 
tot_menos_24 <- 0 
escreva ("Informe a quantidade de crianças nascidas no período: ") 
leia (tot_nasc) 
escreva ("Informe o sexo da criança [M/F ou V para encerrar]: ") 
leia (sexo) 
enquanto (sexo <> "V") faca 
escreva ("Informe o número de meses de vida da criança: ") 
leia (num_meses) 
tot_mortas <- tot_mortas + 1 
se (sexo = "M") entao 
tot_masc_mortas <- tot_masc_mortas + 1 
fimse 
se (num_meses <= 24) entao 
tot_menos_24 <- tot_menos_24 + 1 
fimse 
escreva ("Informe o sexo da criança [M/F ou V para encerrar]: ") 
leia (sexo) 
fimenquanto 
escreval ("Porcentagem de crianças mortas no período: ", tot_mortas * 100 / tot_nasc) 
escreval ("Porcentagem de crianças do sexo masculino mortas no período: ", tot_masc_mortas * 100 / tot_nasc) 
escreval ("Porcentagem de crianças que vivem 24 meses ou menos no período: ", tot_menos_24 * 100 / tot_nasc) 
fimalgoritmo

var 
tot_nasc, num_meses, tot_mortas, tot_masc_mortas, tot_menos_24: inteiro 
sexo: caracter 
inicio 
tot_mortas <- 0 
tot_masc_mortas <- 0 
tot_menos_24 <- 0 
escreva ("Informe a quantidade de crianças nascidas no período: ") 
leia (tot_nasc) 
escreva ("Informe o sexo da criança [M/F ou V para encerrar]: ") 
leia (sexo) 
enquanto (sexo <> "V") faca 
escreva ("Informe o número de meses de vida da criança: ") 
leia (num_meses) 
tot_mortas <- tot_mortas + 1 
se (sexo = "M") entao 
tot_masc_mortas <- tot_masc_mortas + 1 
fimse 
se (num_meses <= 24) entao 
tot_menos_24 <- tot_menos_24 + 1 
fimse 
escreva ("Informe o sexo da criança [M/F ou V para encerrar]: ") 
leia (sexo) 
fimenquanto 
escreval ("Porcentagem de crianças mortas no período: ", tot_mortas * 100 / tot_nasc) 
escreval ("Porcentagem de crianças do sexo masculino mortas no período: ", tot_masc_mortas * 100 / tot_nasc) 
escreval ("Porcentagem de crianças que vivem 24 meses ou menos no período: ", tot_menos_24 * 100 / tot_nasc) 
fimalgoritmo

User badge image

erick

Há mais de um mês

esta  fazendo em qual programa visualg dev c++ , qual ? 

Essa pergunta já foi respondida por um dos nossos especialistas