A maior rede de estudos do Brasil

Em se tratando de vetores e matrizes, devemos sempre adicionar o tamanho fixo de nossa estrutura, para quando executarmos nosso algoritmo, sabermos at

Em se tratando de vetores e matrizes, devemos sempre adicionar o tamanho fixo de nossa estrutura, para quando executarmos nosso algoritmo, sabermos até em que momento podemos adicionar dados. Analise o código fonte a seguir: Inicio constante TAM = 6; tipo X = vetor [1..TAM] de inteiros; inteiro: i, j; para i de 1 ate TAM passo 1 faça Escreva (“Entre com os valores para o vetor: ”); Leia (X[i]); Fimpara; para j de 1 ate TAM passo 1 faça Escreva (X[j]); Fimpara; Fimalgoritmo. Considerando as informações, o código fonte exposto e o conteúdo estudado, analise as afirmativas a seguir: I. Em nosso Algoritmo temos uma constante que irá definir o tamanho do vetor. II. As variáveis “i” e “j” servem para o controle dos laços de repetição. III. Na estrutura do laço de repetição, o comando “passo” irá incrementar em 1 a variável “i” cada iteração. IV. Temos a existência de dois laços de repetição, uma para a leitura dos dados e outro para a apresentação dos dados. É correto o que se afirma em: \t\tI e IV, apenas. \t\tII e III, apenas. \t\tI, II e IV, apenas. \t\tI, III e IV, apenas. \t\tI, II, III e IV

Informática IColegio Fazer Crescer

3 resposta(s) - Contém resposta de Especialista

User badge image

RD Resoluções Verified user icon

Há mais de um mês

As estruturas de dados são uma maneira de realizar a manipulação de grandes quantidades de dados de maneira eficiente para usos como grandes bancos de dados e serviços de indexação da Internet . Geralmente, estruturas de dados eficientes são fundamentais para projetar algoritmos eficientes.

Alguns métodos formais de design e linguagens de programação destacam estruturas de dados, ao invés de algoritmos, como o principal fator organizacional no design de software.

Sabendo disso, analisando o algoritmo acima, vemos que a afirmativa I está errada, pois o algoritmo solicita a leitura dos dados pelo usuário somente dos vetores X e Y. O vetor Z não é usado na leitura, apenasé inserido os valores de X e Y nele. A afirmativa IV está errada, pois não há erro de sintaxe no último laço de repetição, como o seu tamanho é 20, o laço deve se encerrar em 20.

Assim, só estão corretas II e III, apenas.

As estruturas de dados são uma maneira de realizar a manipulação de grandes quantidades de dados de maneira eficiente para usos como grandes bancos de dados e serviços de indexação da Internet . Geralmente, estruturas de dados eficientes são fundamentais para projetar algoritmos eficientes.

Alguns métodos formais de design e linguagens de programação destacam estruturas de dados, ao invés de algoritmos, como o principal fator organizacional no design de software.

Sabendo disso, analisando o algoritmo acima, vemos que a afirmativa I está errada, pois o algoritmo solicita a leitura dos dados pelo usuário somente dos vetores X e Y. O vetor Z não é usado na leitura, apenasé inserido os valores de X e Y nele. A afirmativa IV está errada, pois não há erro de sintaxe no último laço de repetição, como o seu tamanho é 20, o laço deve se encerrar em 20.

Assim, só estão corretas II e III, apenas.

Essa pergunta já foi respondida por um dos nossos especialistas