A maior rede de estudos do Brasil

dúvida sobre estruturas de repetição

Boa noite. Tenho uma dúvida sobre estruturas de repetição de um exercício. Eis o exercício: Desenvolva um algoritmo que mostre uma contagem regressiva de 30 até 1, marcando os números que forem divisíveis por 4, exatamente como mostrado abaixo: 30 29 [28] 27 26 25 [24] 23 22 21 [20] 19 18 17 [16]...​Eis meu algortimo: algoritmo "divisiveis"​var c: inteiro inicio c <- 30 enquanto (c >=1)faca c <- c - 1​se (c mod 4 = 0) entao escreval ("[", c, "]") senao escreval (c)​fimse fimenquanto​fimalgoritmo​Estou com um problema que eu não consigo achar solução desde que eu acrescentei o SE, ele não inclui mais o número "30" na apresentação e também mostra o "0". Gostaria de uma ajuda para solução deste exercício.

Algoritmos

FAEL


2 resposta(s)

User badge image

Eduardo Aquino

Há mais de um mês

Faz tempo que não escrevo em pseudocódigo, mas pela lógica se você colocar c<- c- 1 após o fimse vai dar certinho. O problema está sendo que o valor de c é reduzido antes do programa imprimir na tela o valor, então já começa do 29 e vai até o 0.

Essa pergunta já foi respondida por um dos nossos estudantes