A maior rede de estudos do Brasil

Grátis
11 pág.
APOL 03   Lógica de Programação e Algorítimos NOTA 100

Pré-visualização | Página 1 de 2

APOL 3 
 
 
 
Questão 1/10 
Para o algoritmo abaixo, como colocar a exibição das totalizações (substituir o quadro)? 
algoritmo "prog4" var x, idade,qt,fem_maior, fem_menor,masc_maior, 
masc_menor: inteiro sexo:caracter 
inicio 
// Seção de Comandos escreval("Digite a 
quantidade de entradas:") 
leia(qt) 
enquanto x < qt faca 
 escreva("Digite uma idade: ") 
 leia(idade) escreva("Digite o 
sexo (f/m): ") leia(sexo) 
 se (idade<18) e (sexo="f") entao fem_menor<-fem_menor+1 
 fimse 
 se (idade<18) e (sexo="m") entao masc_menor<-
masc_menor+1 
 fimse 
 se (idade>=18) e (sexo="f") entao fem_maior<-fem_maior+1 
 fimse 
 se (idade>=18) e (sexo="m") entao masc_maior<-
masc_maior+1 
 fimse x<-x+1 fimenquanto 
+----------------------------------------+ 
| | 
| | 
| | 
| | 
| | 
+----------------------------------------+ 
fimalgoritmo 
 A escreval("*** Totais por faixa-etária e sexo ***") escreval("Número de meninas: ",femmenor) escreval("Número de mulheres: ",femmaior) escreval("Número de meninos: ",mascmenor) escreval("Número de homens: ",mascmaior) 
 B escreval("*** Totais por faixa-etária e sexo ***") escreval("Número de meninas: ",fem_menor) escreval("Número de mulheres: ",fem_maior) 
escreval("Número de meninos: ",masc_menor) escreval("Número de 
homens: ",masc_maior) 
 
 C escreval("*** Totais por faixa-etária e sexo ***") escreval("Número de meninas: ",fem_menor) escreval("Número de mulheres: ",fem_maior) escreval("Número de mulheres: ",fem_menor) escreval("Número de meninos: ",masc_menor) 
 D escreval("*** Totais por faixa-etária e sexo ***") 
 escreval("Totais: ",fem_menor,fem_maior,masc_menor,masc_maior)0 
 
Questão 2/10 
Para o algoritmo abaixo, identifique qual a parte de código preencheria a parte faltante (substitui o quadro): 
algoritmo "prog1" var x, 
idade,crianca,preadole,adolescente,adulto: inteiro 
inicio 
// Seção de Comandos 
para x de 1 ate 10 faca escreva("Digite 
uma idade: ") 
 leia(idade) 
 se idade<=11 entao crianca<-crianca+1 
fimse 
+----------------------------------------+ 
| | 
| | 
| | 
| | 
| | 
+----------------------------------------+ 
 se (idade>14) e (idade<=17) entao adolescente<-adolescente+1 
 
 fimse se idade >= 18 
entao adulto<-
adulto+1 fimse 
fimpara 
 escreval("*** Totais por faixa-etária ***") escreval("Número de criancas: ",crianca) escreval("Número de pre-adolescentes: ",preadole) escreval("Número de adolescentes: ",adolescente) escreval("Número de adultos: ",adulto) fimalgoritmo 
 A se (idade>12) e (idade<=14) entao preadole<-preadole+1 
 fimse 
 B se (idade>=11) e (idade<=14) entao preadole<-preadole+1 
 fimse 
 C se (idade>11) e (idade<=14) entao preadole<-preadole+1 
 fimse 
 
 D se (idade>11) e (idade<14) entao preadole<-preadole+1 
 fimse 
 
Questão 3/10 
Para a parte de programa abaixo, com m=3 e n=3, qual seria a saída? 
leia(m,n) para i de 1 ate 
m faca para j de 1 ate n 
faca se(i=j) entao 
matriz[i,j]<-1 senao 
matriz[i,j]<-0 fimse 
 fimpara fimpara 
 A 1 0 0 
0 1 0 
0 0 1 
 
 
 
 
 B 1 0 0 
1 0 0 
1 0 0 
 C 1 1 1 
1 0 0 
1 0 0 
 D 1 1 1 
0 0 0 
0 0 0 
 
Questão 4/10 
Para o algoritmo abaixo, qual a melhor substituição para que o programa utilize o comando enquanto-faca no lugar do para-faca? 
algoritmo "prog3" var x, 
idade,crianca,preadole,adolescente,adulto,qt: inteiro 
inicio 
// Seção de Comandos 
Escreval(“Digite a quantidade de entradas:”) 
leia(qt) 
para x de 1 ate qt faca escreva("Digite 
uma idade: ") 
 leia(idade) 
 se idade<=11 entao 
crianca<-crianca+1 fimse 
 se (idade>11) e (idade<=14) entao preadole<-preadole+1 
 fimse 
 se (idade>14) e (idade<=17) entao adolescente<-adolescente+1 
 fimse se idade >= 18 
entao adulto<-
adulto+1 fimse 
fimpara 
 escreval("*** Totais por faixa-etária ***") escreval("Número de criancas: ",crianca) escreval("Número de pre-adolescentes: ",preadole) escreval("Número de adolescentes: ",adolescente) escreval("Número de adultos: ",adulto) fimalgoritmo 
 A enquanto x < qt faca . 
. 
. 
x<-x+1 fimenquanto 
 
 B enquanto x < qt faca . 
. 
. 
qt<-qt+1 fimenquanto 
 C enquanto x < qt faca 
. 
. 
. 
x<-x+1 fimepara 
 D enquanto x = qt faca 
. 
. 
. 
x<-x+1 fimenquanto 
 
Questão 5/10 
Para o algoritmo abaixo, como calcular os percentuais de cada idade-sexo (substituir o quadro)? 
algoritmo "prog4" var x, idade,qt,fem_maior, fem_menor,masc_maior, 
masc_menor: inteiro sexo:caracter 
inicio 
// Seção de Comandos escreval("Digite a 
quantidade de entradas:") 
leia(qt) 
enquanto x < qt faca 
 escreva("Digite uma idade: ") 
 leia(idade) escreva("Digite o 
sexo (f/m): ") leia(sexo) 
 
 se (idade<18) e (sexo="f") entao fem_menor<-fem_menor+1 
 fimse 
 se (idade<18) e (sexo="m") entao masc_menor<-
masc_menor+1 
 fimse 
 se (idade>=18) e (sexo="f") entao fem_maior<-fem_maior+1 
 fimse 
 se (idade>=18) e (sexo="m") entao masc_maior<-
masc_maior+1 
 fimse 
x<-x+1 fimenquanto 
 escreval("*** Totais por faixa-etária e sexo ***") 
 escreval("Número de meninas: ",fem_menor) escreval("Número de 
mulheres: ",fem_maior) escreval("Número de meninos: 
",masc_menor) escreval("Número de homens: ",masc_maior) 
+----------------------------------------+ 
| | 
| | 
| | 
| | 
| | +----------------------------------------+ 
fimalgoritmo 
 A escreval("% de meninas: ",fem_menor*10/qt," %") escreval("% de mulheres: ",fem_maior*10/qt," %") escreval("% de meninos: ",masc_menor*10/qt," %") escreval("% de homens: ",masc_maior*10/qt," %") 
 B escreval("% de meninas: ",fem_menor/qt," %") escreval("% de mulheres: ",fem_maior/qt," %") escreval("% de meninos: ",masc_menor/qt," %") escreval("% de homens: ",masc_maior/qt," %") 
 C escreval("% de meninas: ",fem_menor*100/x-qt," %") escreval("% de mulheres: ",fem_maior*100/ x-qt," %") escreval("% de meninos: ",masc_menor*100/ x-qt," %") escreval("% de homens: ",masc_maior*100/

Crie agora seu perfil grátis para visualizar sem restrições.